Bug Hunting Session
Bug 100983 - Libreoffice slow and unresponsive when opening large file
Summary: Libreoffice slow and unresponsive when opening large file
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1 all versions
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc, filter:odt
Depends on:
Blocks: DOC
  Show dependency treegraph
 
Reported: 2016-07-18 12:51 UTC by family-guy
Modified: 2017-06-01 11:07 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description family-guy 2016-07-18 12:51:01 UTC
Step to reproduce:
- Download http://www.ambiente.marche.it/Portals/0/Territorio/Prezzario/prezzario2010.zip
- Open the .doc file in it with Libreoffice, Writer show a progress bar importing the file but then hang for minutes before showing the content.
- Now save the file in .odt format and exit from libreoffice.
- Open the file created with the steps above with libreoffice.

What happens:
- Libreoffice needs MINUTES to open the file (seven minutes on my system).

What's expected to happen:
- Libreoffice open the file in SECONDS like Apache Openoffice (AOO 4.1.2 open the same file in 10 seconds on my system).
Comment 1 Cor Nouws 2016-07-18 14:05:45 UTC
Hi,

Thanks for reporting. Your system is faster then mine: takes much more time to open.
Also in AOO 4.1.1. - latest version I have and LibreOffice 3.4.6

Ciao - Cor
Comment 2 unresponsive 2017-04-25 12:03:09 UTC
Worst part of this issue with large files is that libreoffice becomes unresponsive during the process, apparently because it’s maxing out the CPU core.   So if you have a file that takes some time to process, you can’t do anything with Libreoffice until it’s done.  You can’t open a new file.   You can’t save other files.  The program just chokes.   

Be real, be sober.
Comment 3 Telesto 2017-05-30 13:45:17 UTC
Repro with
Version: 5.5.0.0.alpha0+
Build ID: ec79f3453471ee9b6ae32e71ff16ea99d9b7751c
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-05-28_23:21:44
Locale: nl-NL (nl_NL); Calc: CL
Comment 4 family-guy 2017-05-31 18:03:23 UTC
I believe this bug is not "Inherited From OOo" because Apache OpenOffice doesn't have it. 
(maybe my description wasn't clear)
Comment 5 family-guy 2017-05-31 20:24:40 UTC
I've done some testing. Libreoffice versions 3.3.0 trough 4.0.0.1 are definitely not affected.

Early version that's completely unresponsive is version 5.1.0.1, however previous version are quick to load the file but are unresponsive as long as the file is open in libreoffice.

I'm trying to open the .odt file created saving the .doc file linked. So the bug affect the .odt file and not the .doc file.

I've changed the description accordingly.
Comment 6 family-guy 2017-05-31 20:42:06 UTC
Some other test.

The last version that you can use to "work" on the file is LibreOffice 4.4.7.2 

The last version that load the file without "hanging" is LibreOffice 5.0.6.3, but it is extremely difficult to work on the file because LO is maxing 1 CPU core as long as the file is open, and so is sluggish to respond to every command (even keystrokes).
Comment 7 family-guy 2017-06-01 10:48:39 UTC
I've tested the more recent stable version of LibreOffice (LO 5.3.3.2) and the bug is not present anymore (sorry to not test this version before).
The .doc file is slower to open comparing to previous version of LO but I see that's another bug open related to this problem... maybe I do some tests here.