Bug 101009 - Greek symbols should default to italics
Summary: Greek symbols should default to italics
Status: RESOLVED DUPLICATE of bug 52225
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
5.1.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-19 12:24 UTC by john
Modified: 2016-07-19 14:09 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description john 2016-07-19 12:24:56 UTC
Greek symbols in LibreOffice formula editor are entered using codes like %rho and %DELTA. Currently (since ~2012), Greek symbols have defaulted to non-italic text even though earlier versions (~2011) gave italics by default.

This change puts LibreOffice at odds with regular formula editors in Microsoft Office, with standard Latex math, and with Wikipedia. Any standard mathematics textbook or chemistry, engineering or physics textbook will use Greek italics as the almost universal convention. All the academic journals I know use Greek italics as their preferred formatting. Only authors who have little or no experience of accepted publishing conventions will choose to use non-italic greek letter as their default.

Nevertheless, in 2010, the OpenOffice developer Thomas Lange made a change which resulted in nonitalic Greek letters being the default, and no we must use %irho, %itheta etc in order to get 'normal' behaviour. This was done on the basis of a supposed user survey, but as noted above, I am quite sure that the decision was made completely at odds with accepting high-quality publishing conventions. This change makes old documents behave strangely, since editing an equation with %rho etc will cause italic greek letters to change spontaneously to non-italic. It is also annoying, since there are more keystrokes required to render an equation, and equations become less readable.

I note also that, at least for a while, there was a registry setting in LibreOffice that could be used to restore the standard Greek character formatting (see https://ask.libreoffice.org/en/question/3966/greek-letters-in-math-formula-have-reverted-to-non-italic/?answer=20212#post-id-20212). But when I test this in LO 5.1.4.2, this feature also seems to have disappeared.

Could we please restore the sane pre-2011 behaviour in LO and/or allow users a way to set their preferred rendering of Greek characters %rho %DELTA etc to *italic* instead of *non-italic*?
Comment 1 john 2016-07-19 12:39:59 UTC
Further testing with LO 5.1.4.2 seems to show that even if I edit using the Symbol Catalog Editor to force %alpha to be defined by Liberation Serif, Italic, Ux03B1 (whoich the Symbol Catalog permits me to do), then when I come along and insert %alpha into my formula, it still reverts to non-italic.
Comment 2 V Stuart Foote 2016-07-19 14:09:28 UTC
Please don't open new bugs when you have an existing issue already. Place comments with bug 52225

*** This bug has been marked as a duplicate of bug 52225 ***