Bug 101054 - Crash when changing "Tools - Options - LibreOffice - Paths" in LO 5.2.0.1rc3 on Debian
Summary: Crash when changing "Tools - Options - LibreOffice - Paths" in LO 5.2.0.1rc3 ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.2.0.3 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
QA Contact:
URL:
Whiteboard: target:5.3.0 target:5.1.5 target:5.2.0
Keywords: bibisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2016-07-21 08:06 UTC by thackert
Modified: 2016-10-25 18:39 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
bzip2'ed "soffice --backtrace" output (2.83 KB, application/x-bzip)
2016-07-21 11:52 UTC, thackert
Details
bzip2'ed "soffice --strace" output (843.56 KB, application/x-bzip)
2016-07-21 11:55 UTC, thackert
Details
terminal output from bibisection (2.12 KB, text/plain)
2016-07-21 16:11 UTC, Terrence Enger
Details
typescript of gdb session (60.97 KB, text/plain)
2016-07-21 16:26 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description thackert 2016-07-21 08:06:20 UTC
Hello @ll,
I hope, I have chosen the right component etc. If not, feel free to change it adequately ... ;)

I have found the following bug, which is reproducible on my system:

1. download and install 5.2.0.3 in parallel, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel/Linux
2. start /path/to/installdir/soffice from command line
3. open "Tools - Options" and go to "LibreOffice - Paths"
4. double-click on "My documents"
5. change the path to some other dir (say "~/Desktop" or ~/an/existing/dir"
6. click on "Select"

LO crashes immediately and LO's recovery message pops up... :( It does not matter if I use my preferred method (using only keyboard keys to jump to the end of a line, entering the first character of the directory and entering on the searched one, and using mnemonics to choose "Select") or clicking on the buttons. And it does not matter, if I use German (my native lang) or English as GUI language ... :( It was possible to change the path with LO 5.2.0.2 without any crash, so I am not sure, if I should mark this bug as a regression ... :(

OS: Debian Testing AMD64
LO: Version: 5.2.0.3
Build ID: 7dbd85f5a18cfeaf6801c594fc43a5edadc2df0c
CPU Threads: 4; OS Version: Linux 4.5; UI Render: default; 
Locale: de-DE (de_DE.UTF-8)

Sorry for the inconvenience
Thomas.
Comment 1 thackert 2016-07-21 11:52:26 UTC
Created attachment 126339 [details]
bzip2'ed "soffice --backtrace" output

Hello @ll,
after starting LO from command line with "--backtrace" parameter, I got the following output file, which I have compressed with "bzip2 gdbtrace.log" and renamed it to "bug101054_gbdrace.log" before. I hope this is OK ... ;)
HTH
Thomas.
Comment 2 thackert 2016-07-21 11:55:43 UTC
Created attachment 126340 [details]
bzip2'ed "soffice --strace" output

Hello again,
as before, I have started "soffice --strace" from command line to get this strace output. I renamed it to "bug10105_strade.log" before I bzip2'ed it. I hope this is OK for you ... ;)
HTH
Thomas.
Comment 3 thackert 2016-07-21 12:03:03 UTC
Additional info:

I have also downloaded and installed

Version: 5.2.1.0.0+
Build ID: 3af2382e6155abbb3e9e6102878bad1fa3f79373
CPU Threads: 4; OS Version: Linux 4.5; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-5-2, Time: 2016-07-20_15:57:49
Locale: de-DE (de_DE.UTF-8); Calc: group

and

Version: 5.3.0.0.alpha0+
Build ID: 0ccb3ccc4c7bafeb2fbbd689c90f710bc65d37e0
CPU Threads: 4; OS Version: Linux 4.5; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-07-20_23:34:15
Locale: de-DE (de_DE.UTF-8); Calc: group

and installed both in parallel, following the instructions mentioned in my first comment. I can reproduce this crash with them as well ... :( So it seems, that an change between 5.2.0.2 and 5.2.0.3 is the culprit for this crash (or maybe at any other version, daily or master?). If I could help any further (without downloading the source code and compile LO), feel free to ask :)
HTH
Thomas.
Comment 4 m.a.riosv 2016-07-21 12:22:20 UTC
No repro.
Win10x64
Version: 5.2.0.3 (x64)
Build ID: 7dbd85f5a18cfeaf6801c594fc43a5edadc2df0c
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL; 
Locale: es-ES (es_ES)

Have you tested with a clean profile?
Comment 5 thackert 2016-07-21 12:48:41 UTC
Hello m.a.riosv, *,
(In reply to m.a.riosv from comment #4)
> No repro.
> Win10x64
> Version: 5.2.0.3 (x64)
> Build ID: 7dbd85f5a18cfeaf6801c594fc43a5edadc2df0c
> CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL; 
> Locale: es-ES (es_ES)

thanks for testing :)

> Have you tested with a clean profile?

I have mentioned the parallel install, as it involves a change to bootstraprc to start with a clean profile (https://wiki.documentfoundation.org/Installing_in_parallel/Linux#Step_4_-_Optional.2C_but_Recommended_when_Testing:_Changing_the_User_Profile_location) ... ;) To my understanding of that description you always start with a clean profile, or am I wrong here?
Have a nice day
Thomas.
Comment 6 Robinson Tryon (qubit) 2016-07-21 13:48:18 UTC
TESTING with LO 5.2.0.3 on Ubuntu 14.04

(In reply to thackert from comment #0)
> 1. download and install 5.2.0.3 in parallel, following the instructions from
> https://wiki.documentfoundation.org/Installing_in_parallel/Linux
> 2. start /path/to/installdir/soffice from command line
> 3. open "Tools - Options" and go to "LibreOffice - Paths"
> 4. double-click on "My documents"

ok

> 5. change the path to some other dir (say "~/Desktop" or ~/an/existing/dir"
> 6. click on "Select"

In the dialog in which I've selected a different "My documents" path, I've got an 'OK' button (not a 'Select' button). Changing the path to the "~/Desktop" directory in this fashion, I can't reproduce this crash.
Comment 7 Robinson Tryon (qubit) 2016-07-21 13:51:59 UTC
(In reply to thackert from comment #0)
> 1. download and install 5.2.0.3 in parallel, following the instructions from
> [...]
> LO: Version: 5.2.0.3

Based on OP's repro steps, changing Version -> 5.2.0.3
Comment 8 thackert 2016-07-21 14:19:26 UTC
Hello Robinson, *,
(In reply to Robinson Tryon (qubit) from comment #6)
> TESTING with LO 5.2.0.3 on Ubuntu 14.04
> 
> (In reply to thackert from comment #0)
> > 1. download and install 5.2.0.3 in parallel, following the instructions from
> > https://wiki.documentfoundation.org/Installing_in_parallel/Linux
> > 2. start /path/to/installdir/soffice from command line
> > 3. open "Tools - Options" and go to "LibreOffice - Paths"
> > 4. double-click on "My documents"
> 
> ok
> 
> > 5. change the path to some other dir (say "~/Desktop" or ~/an/existing/dir"
> > 6. click on "Select"
> 
> In the dialog in which I've selected a different "My documents" path, I've
> got an 'OK' button (not a 'Select' button). Changing the path to the
> "~/Desktop" directory in this fashion, I can't reproduce this crash.

when I am in this "Select path" dialog, I am just seeing a "Select" button. In the next one ("LibreOffice Document Recovery") I see an OK button (though no document to recover as I was just changing the options without an open document ... ;) ).
Thanks for your comments and adding the newer versions to Bugzilla :)
Thomas.
Comment 9 Terrence Enger 2016-07-21 15:44:42 UTC
In daily Linux dbgutil repository version 2016-07-21 running on
debian-stretch, with SAL_USE_VCLPLUGIN=gen, the dialog "Select path"
has button <Select> and I received an assertion (whitespace added) ...

    /usr/include/c++/4.8/bits/unique_ptr.h:228:
        std::unique_ptr<_Tp, _Dp>::pointer std::unique_ptr<_Tp, _Dp>::
        operator->() const
        [with _Tp = DialogImpl; _Dp = std::default_delete<DialogImpl>;
            std::unique_ptr<_Tp, _Dp>::pointer = DialogImpl*
        ]: Assertion 'get() != pointer()' failed.

However, with SAL_USE_VCLPLUGIN undefined, the "Select Path" (note
extra capital letter) is different, allowing only selection from a
navigable list of directories, and it has an <OK> button.  I was able
to change the directory without any problem.

It is, of course, merely an assumption that my assertion is related to
thackert's crash.  I think his crash must be somewhat different
because he was not running a dbgutil build.

I am leaving bug status UNCONFIRMED because I have not searched for
duplicate bug reports.
Comment 10 Terrence Enger 2016-07-21 16:11:09 UTC
Created attachment 126347 [details]
terminal output from bibisection

I am setting status NEW and keywords regression, bibisected.

Working in the daily Linux dbgutil bibisect repository, I find that
the problem starts somewhere in the 40 commits between ...

         commit  date       source-has
    good 731486e 2016-07-05 0513291
    bad  3cbcf08 2016-07-06 eff871d
Comment 11 thackert 2016-07-21 16:23:51 UTC
Hello Terrence, *,
(In reply to Terrence Enger from comment #10)
> Created attachment 126347 [details]
> terminal output from bibisection
> 
> I am setting status NEW and keywords regression, bibisected.
> 
> Working in the daily Linux dbgutil bibisect repository, I find that
> the problem starts somewhere in the 40 commits between ...
> 
>          commit  date       source-has
>     good 731486e 2016-07-05 0513291
>     bad  3cbcf08 2016-07-06 eff871d

thank you very much for bisecting my bug and setting the status to "New" :) Hopefully, it will be fixed before 5.2's release ... ;)
Have a nice evening
Thomas.
Comment 12 Terrence Enger 2016-07-21 16:26:21 UTC
Created attachment 126349 [details]
typescript of gdb session

line  what
----  ----
  60  run
  99  info threads
 107  thread apply all backtrace
 222  backtrace full

I am setting keyword haveBacktrace.
Comment 13 Terrence Enger 2016-07-21 16:31:08 UTC
Further to comment 12 ...

The backtrace is from master commit ff4ce07, pulled 2016-07-18,
configured ...
    CC=ccache /usr/bin/gcc
    CXX=ccache /usr/bin/g++
    --enable-option-checking=fatal
    --enable-dbgutil
    --enable-debug
    --without-system-postgresql
    --without-myspell-dicts
    --with-extra-buildid
    --without-doxygen
    --with-external-tar=/home/terry/lo_hacking/git/src
built and running on debian-stretch.
Comment 14 Commit Notification 2016-07-21 20:46:34 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c1bd3156cf66318023f36d81ce809a38072588e4

Resolves: tdf#101054 crash on options->path with non-native file picker

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2016-07-22 08:49:03 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=354c148edce5cafa1efb136630618f3063ce3c99&h=libreoffice-5-1

Resolves: tdf#101054 crash on options->path with non-native file picker

It will be available in 5.1.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2016-07-22 10:41:55 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=aafdbb7763b939742050159ce784b799f26eb834&h=libreoffice-5-2

Resolves: tdf#101054 crash on options->path with non-native file picker

It will be available in 5.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2016-07-26 09:20:02 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-2-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=db8dfd15c09d57cfadc4181371818878a34fc881&h=libreoffice-5-2-0

Resolves: tdf#101054 crash on options->path with non-native file picker

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2016-07-26 09:22:35 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-1-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ce43440dd910c2ff27e95db3009752cfb2b608e3&h=libreoffice-5-1-5

Resolves: tdf#101054 crash on options->path with non-native file picker

It will be available in 5.1.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.