Bug 101189 - Libreoffice Scrolling very slow for even moderately sized documents
Summary: Libreoffice Scrolling very slow for even moderately sized documents
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.5.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
Depends on:
Blocks:
 
Reported: 2016-07-29 10:35 UTC by vince.barwinski@gmail.com
Modified: 2019-10-30 06:52 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vince.barwinski@gmail.com 2016-07-29 10:35:12 UTC
When I updated my system (Sparky Linux 4. Code Name: Tyche, based on Debian 9 Stretch Testing) on Friday 25th July 2016, and then used my upgraded Libreoffice, I found that when I scroll a large odt document of say fifty or more pages, I find lines of text disappear or only fractionally appear. Also, when I do word searches, I find sections of text getting jumbled as the scrolling often can't keep up with it. I never had this trouble with the previous version 5.1.4~rc1-1 and when I booted into my secondary OS, namely Debian Stable Jessie, using the old 4.3.3-2+deb8u5, I had no problems and was able to do my work.
Comment 1 Buovjaga 2016-08-06 19:25:03 UTC
Could you test version 5.2: https://wiki.documentfoundation.org/Installing_in_parallel/Linux

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 2 Rene Engelhard 2016-08-30 11:47:49 UTC
See https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=835662.

This was with 5.2.0.

See also https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=835662#17 (unfortunately he didn't Cc his reply to the bug so it's not recorded, but the
quote should be clear.)
Comment 3 Buovjaga 2016-08-30 12:16:35 UTC
Reporter sent this private mail:

Just over a week ago, I replaced my Sparky Linux based on Debian Testing Stretch with pure Debian Testing Stretch. It had Libreoffice 5.2, and it initially worked fine. However, a few days later after installing and uninstalling software to get my system the way I wanted, suddenly, the same problem with Libreoffice writer returned. I ended up submitting a bug report to Debian just last Sunday, and on that same day, someone from the Debian team suggested to me the problem may be related to libreoffice-gtk2/libreoffice-gtk3, and to execute the command

dpkg -l libreoffice-gtk2 libreoffice-gtk3

When I did,I got the following output:


Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                        Version            Architecture       Description
+++-===========================-==================-==================-============================================================
ii  libreoffice-gtk2            1:5.2.0-2          amd64              office productivity suite -- GTK+ 2 integration
rc  libreoffice-gtk3            1:5.2.0-2          amd64              office productivity suite -- GTK+ 3 integration

What is critical here, is that while I was installing/uninstalling software, I must have unwittingly uninstalled
libreoffice-gtk3 while I think I was uninstalling the buggy Mate desktop which had been giving me grief. My main desktop is Xfce.

When I reinstalled libreoffice-gtk3, the problem disappeared. Now when I scroll or do searches on a large document, libreoffice writer works fine. As well, the Mate desktop, having switched to gtk3, seems to me, much less stable.

Another thing. This problem only became apparent on sizeable documents like 50 pages or more. For say just eight pages, there was no problem. Hence, this is a bug that for most people would be hard to detect. However, I work on documents over 500 pages, so for me, this bug made libreoffice writer almost unusable.
Comment 4 Buovjaga 2016-08-30 18:30:22 UTC
Vince: maybe you could do some tests without touching the libreoffice-gtk3 package.

See, if you can reproduce the problem by running libreoffice from the terminal with the command:
SAL_USE_VCLPLUGIN=gtk libreoffice

If you get slow scrolling with that environment variable, you could next try this bit of sorcery:
SAL_USE_VCLPLUGIN=gtk SAL_SYNCHRONIZE=1 libreoffice

The results of these experiments might be useful information for developers.
Comment 5 Buovjaga 2016-08-31 06:38:03 UTC
Reporter again emailed me privately:

I just did the two quick experiments.

The first,

SAL_USE_VCLPLUGIN=gtk libreoffice

still produced the bug.

However, doing the sync with 

SAL_USE_VCLPLUGIN=gtk SAL_SYNCHRONIZE=1 libreoffice

eliminated the bug.

(end of quote)

Caolán just posted an explanation of what the synchronize variable does: https://bugs.documentfoundation.org/show_bug.cgi?id=100925#c33
Comment 6 Buovjaga 2016-09-21 10:10:45 UTC
Reporter emailed me again:

Presently I am using libreoffice 5.2.1-1 on Debian Testing. Recently I was noticing very slow or sluggish performance even when opening small documents. Small spreadsheets were  taking about 10 seconds or more to open for example.  I googled this problem and found I was not alone.

However, when I executed the magical:

SAL_USE_VCLPLUGIN=gtk SAL_SYNCHRONIZE=1 libreoffice

the sluggish performance is gone! --- Because I think,it is not using the bug riddled gtk3.
Comment 7 matthieupepin 2017-03-09 01:27:04 UTC
I have the same problem with LibreOffice 5.3.0.3 in Arch Linux. Using:

SAL_USE_VCLPLUGIN=gtk SAL_SYNCHRONIZE=1 libreoffice

helps with scrolling issues.
Comment 8 Buovjaga 2017-03-09 05:35:14 UTC
NEW per previous comment.
Severity minor as workaround exists.
Comment 9 matthieupepin 2017-03-09 12:27:00 UTC
Some additional observations:

- This issue does not happen with the mouse wheel, only with the touchpad of my Dell XPS 13
- Horizontal scrolling is way too fast, even with the workaround above. With one little swipe, I'm already at columns AE-AR

Running a Gnome Wayland session (with gdm login manager).
Comment 10 Buovjaga 2017-03-09 17:31:02 UTC
(In reply to matthieupepin from comment #9)
> - This issue does not happen with the mouse wheel, only with the touchpad of
> my Dell XPS 13

Other touchpad scroll issues: https://bugs.documentfoundation.org/buglist.cgi?list_id=682144&query_format=advanced&resolution=---&short_desc=touchpad%20scroll&short_desc_type=allwordssubstr
Comment 11 Jordan Maris 2017-03-21 08:59:16 UTC
I'm running LO 5.2.1.2 on Archlinux (from the Arch Repos), and in my opinion the bug is GTK3 related.

running SAL_USE_VCLPLUGIN=gtk libreoffice eliminates the bug for me, without even using SAL_SYNCHRONIZE=1.

If I run libreoffice with GTK3 the problem reappears, even if i run it using SAL_SYNCHRONIZE=1.
Comment 12 kunstenaar 2017-03-30 15:08:01 UTC
I updated today from Lubuntu 16.10 (LO 5.2. or 5.3.0) to 17.04 beta and have now LO 5.3.1.2. (LO-Build-ID: 1:5.3.1-0ubuntu2) -  and I have now the same problem with scrolling even small odts via touchpad on my compaq presario CQ61. 

SAL_USE_VCLPLUGIN=gtk libreoffice 
and
SAL_USE_VCLPLUGIN=gtk SAL_SYNCHRONIZE=1 libreoffice

both do help quite a bit, but I have the impression, scrolling with previous versions of LO (and/or gtk?) were much smoother.
Comment 13 kunstenaar 2017-03-30 15:28:26 UTC
Addition to my previous comment: uninstalling libreoffice-gtk3 also helps.
Comment 14 dr01 2017-11-21 15:42:40 UTC
Same issue (rough scrolling) under Win10, LibreOffice v5.3.4.2 (x64).  In particular, scrolling around the autogenerated Index takes more time for the page to refresh.  Text search seems to work fine.
Comment 15 Aron Budea 2017-11-21 16:27:21 UTC
(In reply to dr01 from comment #14)
> Same issue (rough scrolling) under Win10, LibreOffice v5.3.4.2 (x64).  In
> particular, scrolling around the autogenerated Index takes more time for the
> page to refresh.  Text search seems to work fine.

Your issue is likely bug 113347, let's set this to Linux only again.
Comment 16 QA Administrators 2019-10-30 03:37:38 UTC Comment hidden (obsolete)
Comment 17 vince.barwinski@gmail.com 2019-10-30 06:51:00 UTC
This bug has not been an issue for me for two years now. I just tested a document with over 495,000 words with the gtk3 integration (the bug was only an issue with the gtk3 integration). The good news is, the document scrolled perfectly.

All the best
Comment 18 vince.barwinski@gmail.com 2019-10-30 06:52:31 UTC
And I used the latest libreoffice 6.3.2 in Debian Testing (Bullseye).