Bug 101222 - Writer can not be pinned in the taskbar when launched by a document
Summary: Writer can not be pinned in the taskbar when launched by a document
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.6.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Desktop-Integration
  Show dependency treegraph
 
Reported: 2016-07-30 09:22 UTC by Chris
Modified: 2016-10-18 02:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris 2016-07-30 09:22:23 UTC
Hello

Under Windows 7, when I launch Writer by opening a document in the file Explorer, the Writer icon in the taskbar can not be pinned.

Steps to reproduce:
. Ensure Writer is not open.
. Launch the Windows File Explorer.
. In the Explorer, Open a Writer document (.odt).
. Once Writer is launched, right-click on its icon in the Windows taskbar.
. Note the menu has not the usual option "Pin this program to the taskbar".


As a developer, I suspect this is due to the fact the process that really displays the document is "soffice.bin", not a classic ".exe" file name (although it is an executable).


Suggestion to the developers:

1. Remove the unusual executable launch chain: swriter.exe, soffice.exe, soffice.bin .
2. Transform soffice.bin to a dynamic library: soffice.dll (in Windows, or equivalent on others OS).
3. Link soffice.dll to switer.exe, scalc.exe, sdraw.exe, etc.

This way, swriter.exe is the real process that displays the document. And only one process is launched (more clear, less resources, faster to run).

That will prevent all bugs that are linked to the current executable launch chain.
For example the bug #76131, I presume.

Thank you

P.S.
Please note Writer can be pinned to the taskbar when launched as an application, and not launched by a document.
Comment 1 V Stuart Foote 2016-07-30 19:24:10 UTC
Works correctly, able to pin to taskbar and record into Windows jump lists.

Windows 7
Windows 8.1
Windows 10

We already support handling on Windows Jumplist and Taskbar, the monolithic soffice.bin and soffice.exe launcher (or per module wrappers) have been  functional as independent launchers for each module since 4.1.1 release.

http://opengrok.libreoffice.org/xref/core/vcl/win/window/salframe.cxx#1829
http://opengrok.libreoffice.org/xref/core/vcl/win/app/salinst.cxx#984

=-ref-=
https://msdn.microsoft.com/en-us/library/windows/desktop/dd378459(v=vs.85).aspx
Comment 2 Yousuf Philips (jay) (retired) 2016-10-18 02:01:43 UTC
Tested 5.2.1.2 on Windows 7 and was able to pin writer to the taskbar after opening a document on the desktop.