Bug 101230 - EDITING: Embedded Firebird - Creating relationship in GUI doesn't show existing relations
Summary: EDITING: Embedded Firebird - Creating relationship in GUI doesn't show existi...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-31 09:05 UTC by Robert Großkopf
Modified: 2017-05-13 19:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Testdocument with 2 Firebird-tables without any relation. Try to create as described. (43.98 KB, application/vnd.oasis.opendocument.database)
2016-07-31 09:05 UTC, Robert Großkopf
Details
Same Testdocument, created with Firebird 3.0, LO 5.3 (2.92 KB, application/vnd.oasis.opendocument.database)
2016-11-27 16:27 UTC, Robert Großkopf
Details
test file from scratch with Firebird 3 (3.13 KB, application/vnd.oasis.opendocument.database)
2017-05-08 10:57 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2016-07-31 09:05:31 UTC
Created attachment 126494 [details]
Testdocument with 2 Firebird-tables without any relation. Try to create as described.

Since a patch for bug 71009 the dialog for creating of a relationship with Firebird appears. You could add tables. You could also connect fields (PK of one table to FK of the other). But the result won't be shown.

Try the following with the attached database:
1. Open table "Name".
2. Write down in first row '1','Bob','1'
> Entry could be saved, because there isn't any foreignkey.
3. Delete the crated row.
4. Enter Tools > Relationships
5. Add the tables to the relationship-dialog.
6. Draw with left mouse from "Name"."TownID" to "Town"."ID"
> There isn't any line shown, which connects the fields of the two tables.
7. Save the relationships.
8. Open table "Name".
9. Write down in first row '1','Bob','1'
> Entry could not be saved, because there is a foreignkey and the row in the table "Town" doesn't exist.
10. Enter Tools > Relationships
> There is a connection shown between the header of the two tables, not between the fields, which should be connected. Editing of the connection is impossible, because the dialog seems to know nothing of the connection it has been created in 6. Its the same when creating a connection directly by SQL. Wouldn't be shown, too.
Comment 1 Julien Nabet 2016-07-31 09:12:19 UTC
About Firebird, I suppose (I might be wrong) that we're waiting for 3.0 Firebird upgrade with this patch https://gerrit.libreoffice.org/#/c/27642/
For the moment, the upgrade works for Linux and the author is working on Windows integration. After this, there'll be MacOs integration.
Comment 2 Thomas Hackert 2016-08-01 12:59:55 UTC
Hello Robert, *,
(In reply to robert from comment #0)
<snip>
> Try the following with the attached database:
> 1. Open table "Name".
> 2. Write down in first row '1','Bob','1'
> > Entry could be saved, because there isn't any foreignkey.
> 3. Delete the crated row.

Up to this point I can follow the steps, but ...

> 4. Enter Tools > Relationships

Here I get the message
<quote>
LibreOffice Base Relation Design

The database does not support relations.
</quote>

Tested with
OS: Debian Testing AMD64
LO: Version: 5.2.0.4
Build ID: 066b007f5ebcc236395c7d282ba488bca6720265
CPU Threads: 4; OS Version: Linux 4.5; UI Render: default; 
Locale: de-DE (de_DE.UTF-8)
(parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel/Linux)

As a side note:

LO: Version: 5.1.5.1
Build-ID: 1:5.1.5~rc1-1
CPU-Threads: 4; BS-Version: Linux 4.5; UI-Render: GL; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group
(Debian's own version)

does not do anything, if I try to click on "Tables" (or open it via "View - Database Objects - Tables" ... :(
HTH
Thomas.
Comment 3 Robert Großkopf 2016-08-01 13:44:47 UTC
Hi Thomas,

Tools > Relationsships works for internal Firebird only with daily build. It will be available in 5.3.0 and 5.2.1. See 
https://bugs.documentfoundation.org/show_bug.cgi?id=71009#c8
https://bugs.documentfoundation.org/show_bug.cgi?id=71009#c11

Regards

Robert
Comment 4 Thomas Hackert 2016-08-01 15:59:26 UTC
Hello Robert, *,
thanks for your information :)

Retested it with
OS: Debian Testing AMD64
LO: Version: 5.3.0.0.alpha0+
Build-ID: f9f090d0d0f2b454d6c1dd14fe735e7e83fda9da
CPU-Threads: 4; BS-Version: Linux 4.5; UI-Render: Standard; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-07-24_06:28:54
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group
(parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel/Linux)
and can confirm your bug, so setting the status to "New".
Have a nice afternoon
Thomas
Comment 5 Robert Großkopf 2016-10-21 08:11:45 UTC
Have tested this again with 
Version: 5.3.0.0.alpha0+
Build ID: e7324c5705eaa38a2c9aa0636f01a73f033ba4d6
CPU Threads: 4; OS Version: Linux 4.1; UI Render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-10-20_06:12:58
Locale: de-DE (de_DE.UTF-8); Calc: group

and the new Firebird 3.0

Same buggy behavior: 
The relation won't be shown while editing.
Input of wrong data would be forbidden by the relation, so the relation exists.
Opening tools - relationship again shows a connection between the headers of the table, not between the connected fields.
Comment 6 Thomas Hackert 2016-11-25 14:26:40 UTC
Hello Robert, *,
when I retest your bug with your attached ODB file on

OS: Debian Testing AMD64
LO: Version: 5.3.0.0.beta1
Build-ID: 690f553ecb3efd19143acbf01f3af4e289e94536
CPU-Threads: 4; BS-Version: Linux 4.5; UI-Render: Standard; VCL: gtk2; Layout-Engine: neu; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group
(parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel/Linux)

I now get

<quote>
Error code: 1

firebird_sdbc error:
*unsupported on-disk structure for file /tmp/lu22832xvqq8v.tmp/lu22832xvqq8z.tmp/firebird.fdb; found 11.2, support 12.0
caused by
'isc_attach_database'
</quote>

Does this happen to you, too?
Have a nice afternoon
Thomas.
Comment 7 Julien Nabet 2016-11-25 14:47:30 UTC
(In reply to thackert from comment #6)
> Hello Robert, *,
> ...
> firebird_sdbc error:
> *unsupported on-disk structure for file
> /tmp/lu22832xvqq8v.tmp/lu22832xvqq8z.tmp/firebird.fdb; found 11.2, support
> 12.0
> caused by
> 'isc_attach_database'
> </quote>
> 
> Does this happen to you, too?
> Have a nice afternoon
> Thomas.
The test file has been create with a Firebird version < 3.
You must convert the file for Firebird 3.0. You can take a look here:
https://bugs.documentfoundation.org/show_bug.cgi?id=70506#c15
Comment 8 Thomas Hackert 2016-11-27 15:56:28 UTC
Hello Julien, *,
(In reply to Julien Nabet from comment #7)
> (In reply to thackert from comment #6)
> > firebird_sdbc error:
> > *unsupported on-disk structure for file
> > /tmp/lu22832xvqq8v.tmp/lu22832xvqq8z.tmp/firebird.fdb; found 11.2, support
> > 12.0
> > caused by
> > 'isc_attach_database'
> > </quote>
> > 
> > Does this happen to you, too?
>
> The test file has been create with a Firebird version < 3.
> You must convert the file for Firebird 3.0. You can take a look here:
> https://bugs.documentfoundation.org/show_bug.cgi?id=70506#c15

thank you for this information :) But would that not be too much of a hassle for a normal user?
Have a nice evening
Thomas.
Comment 9 Robert Großkopf 2016-11-27 16:27:54 UTC
Created attachment 129051 [details]
Same Testdocument, created with Firebird 3.0, LO 5.3
Comment 10 Alex Thurgood 2016-11-28 10:45:55 UTC
(In reply to robert from comment #9)
> Created attachment 129051 [details]
> Same Testdocument, created with Firebird 3.0, LO 5.3

Yes, and AFAIK it requires the user to download and install the whole FB2.5 server packages, which is simply not going to be an option for the majority of users.
Comment 11 Gerhard Schaber 2017-01-03 09:36:23 UTC
I can confirm the issue with the relationships editor in 5.3.0 beta 2.
Comment 12 Terrence Enger 2017-04-15 22:42:48 UTC
Bug 45257 looks like this one.  Setting this bug RESOLVED DUPLICATE.

*** This bug has been marked as a duplicate of bug 45257 ***
Comment 13 Robert Großkopf 2017-04-22 13:58:14 UTC
(In reply to Terrence Enger from comment #12)
> Bug 45257 looks like this one.  Setting this bug RESOLVED DUPLICATE.
> 
> *** This bug has been marked as a duplicate of bug 45257 ***

Isn't the same. Bug 45257 is for special relations of PostgreSQl and LO 3.5. This one is for embedded Firebird and LO 5.3. With embedded Firebird the relations won't be shown in any way.
Comment 14 Julien Nabet 2017-05-08 10:57:00 UTC
Created attachment 133157 [details]
test file from scratch with Firebird 3

On pc Debian x86-64 with master sources updated some days ago with experimental, I could see the relationships only after having opened a table.
If I don't do this, relationships window opens but never see tables with relationships with hourglass spinning.
I wonder if this symptom could be due to the migration between Firebird 2 and 3.

I recreated the same file as you and didn't reproduce the problem.
But perhaps I missed something.
Comment 15 Julien Nabet 2017-05-13 15:10:19 UTC
Let's put this one to NEEDINFO by waiting for Robert's feedback.
Comment 16 Robert Großkopf 2017-05-13 18:46:53 UTC
Semms it works with
Version: 5.4.0.0.alpha1+
Build ID: c0968aa4673a8ac9a8a09a0e291b58b94bdbb35e
CPU threads: 4; OS: Linux 4.1; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-05-13_09:11:52
Locale: de-DE (de_DE.UTF-8); Calc: group

... but doesn't work with 
Version: 5.3.3.2
Build-ID: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448
CPU-Threads: 4; BS-Version: Linux 4.1; UI-Render: Standard; VCL: kde4; Layout-Engine: neu; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group

Don't know if we should set this to WORKSFORME, because it isn't fixed in the actual fresh release.
Comment 17 Julien Nabet 2017-05-13 19:00:00 UTC
(In reply to robert from comment #16)
...
> ... but doesn't work with 
> Version: 5.3.3.2
> Build-ID: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448
> CPU-Threads: 4; BS-Version: Linux 4.1; UI-Render: Standard; VCL: kde4;
> Layout-Engine: neu; 
> Gebietsschema: de-DE (de_DE.UTF-8); Calc: group
> 
> Don't know if we should set this to WORKSFORME, because it isn't fixed in
> the actual fresh release.
The fix is initially for tdf#107196 put in See Also.
It's been cherry-picked on 5.3 branch and will be available in 5.3.4.
Let's put this one to FIXED too.
Of course, don't hesitate to reopen this tracker if you still reproduce this with 5.3.4