Download it now!
Bug 101263 - Insert Cross-reference points to wrong endnote entry.
Summary: Insert Cross-reference points to wrong endnote entry.
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fields-Cross-Reference
  Show dependency treegraph
 
Reported: 2016-08-02 19:16 UTC by jimrussell98116
Modified: 2019-05-25 02:56 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
test case for cross-reference bug (101263) (17.90 KB, application/vnd.oasis.opendocument.text)
2016-08-03 16:56 UTC, jimrussell98116
Details
.docx version of crossreference problem (6.11 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-08-03 16:57 UTC, jimrussell98116
Details
illustration of cross-reference problem with 5.1.4.2 release (15.56 KB, application/vnd.oasis.opendocument.text)
2016-08-03 17:25 UTC, jimrussell98116
Details
test of Bug 101263 (12.80 KB, application/vnd.oasis.opendocument.text)
2018-05-21 04:03 UTC, jimrussell98116
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jimrussell98116 2016-08-02 19:16:50 UTC
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.106 Safari/537.36
Build Identifier: LibreOffice 4.4.7.2

Insert Cross-reference brings up a dialog box, opened to a tab "Cross-references". Picking Endnotes provides a list of existing endnotes to assign to the cross-reference. Picking one (in this instance #2) results in insertion of a number in the text where the cross-reference is made. The incorrect number is used (in this case #3), pointing the reader to the wrong endnote.

Reproducible: Always

Steps to Reproduce:
1.Insert Cross-reference
2.Choose Endnotes tab
3.Select an item from the list.
4. Number inserted in text is off by one.
Actual Results:  
Wrong number inserted.

Expected Results:  
Right number inserted.

[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Mac OS X (All)
OS is 64bit: no


Reset User Profile?No
Comment 1 Alex Thurgood 2016-08-03 07:49:34 UTC
@Jim : did you force an update of the fields ?
(in Tools → Options → LibreOffice Writer → General, Update, Fields)

What you are describing sounds like bug 76794, but it would be helpful if you could provide a sample document so that we could attempt to reproduce the situation.

Setting NEEDINFO status as a result. Please set back to UNCONFIRMED when you have provided the requested information (and test file).
Comment 2 jimrussell98116 2016-08-03 16:56:34 UTC
Created attachment 126548 [details]
test case for cross-reference bug (101263)

I tried to attach two alternatives, one in .docx format, the other in .odt, but I haven't figured out how through this interface.
Comment 3 jimrussell98116 2016-08-03 16:57:31 UTC
Created attachment 126549 [details]
.docx version of crossreference problem

Okay, here's the .docx version as well.
Comment 4 jimrussell98116 2016-08-03 17:00:37 UTC
For what it's worth, this may be related to the but you reference (76794), but it is not the same. 76794 refers to failure to renumber correctly. The problem I am reporting occurs on initial insertion of a cross-reference.
Comment 5 jimrussell98116 2016-08-03 17:25:11 UTC
Created attachment 126550 [details]
illustration of cross-reference problem with 5.1.4.2 release

Documentation that the problem persists in latest stable release.
Comment 6 Alex Thurgood 2016-08-04 11:40:54 UTC
Thansk Jim, will test and report back.
Comment 7 Alex Thurgood 2016-08-05 06:52:58 UTC
@Jim : from your last comment, am I correct in understanding that the problem initially occurs on a DOCX document ?

Does the ODT document you provided come from a DOCX document originally ?

I am trying to narrow down the problem to of :

- a filter issue when importing from / exporting to docx ; 

or

- a problem with cross-referencing that is directly linked to the internal representation of an ODT file in application memory.


My understanding at present is that you have started from a DOCX file, or that you save your file directly to DOCX rather than ODT. 


Setting back to NEEDINFO
Comment 8 Alex Thurgood 2016-08-05 07:19:30 UTC
Reproducible steps :

1) open a new Writer document.
2) Type a phrase and insert an endnote at the end of the line.
3) Press Enter (paragraph return).
4) Type another phrase and insert another endnote at the end of the line.
5) Press enter (paragraph return)
6) Type a third phrase and insert another endnote at the end of the line.
7) Press enter (paragraph return)

8) Note how the default numbering for these endnotes is roman numbering.

8) Type a fourth phrase and insert a cross-reference to endnote ii. A digit "2" is inserted at the selected point. Clicking on this digit takes you to endnote ii.

9) Type some more text and now insert a cross-reference to endnote i. A digit "2" is inserted at the selected point, but clicking on this digit takes you to endnote i.

10) Type some more text again and insert a cross-reference to endnote iii. A digit "2" is inserted at the selected point, and clicking on this digit takes you to endnote iii.


CONFIRMING
Comment 9 Alex Thurgood 2016-08-05 07:23:47 UTC
The question now is whether this is a regression, and if so, when did it previously work correctly.
Comment 10 Alex Thurgood 2016-08-05 07:33:27 UTC
@Jim : you can ignore my question, I managed to reproduce the problem for myself. Thanks for your input.

Note that there appeart to be a considerable number of bugs related to cross-referencing that have been around for a while, so this particular bug may not get resolved anytime soon.
Comment 11 QA Administrators 2018-05-18 02:33:11 UTC Comment hidden (obsolete)
Comment 12 jimrussell98116 2018-05-21 03:55:58 UTC
At your request, I tested the latest offered stable version (5.4.7.2) to see whether this has been fixed. No, the problem remains. I will try to attach my test document. It explores the problem a bit further. The test document was originally created in 5.4.7.2 as a .odt - it has never been a .docx.

Not sure what status to assign. Default is NEW, and it seems as good as any at this point.
Comment 13 jimrussell98116 2018-05-21 03:58:17 UTC
You requested that I check whether this has been fixed. I checked with 5.4.7.2, and it has not been fixed. I am trying to attach a test document that explores the problem a little further. This document was created in .odt format, and has never been in .docx format.
Comment 14 jimrussell98116 2018-05-21 04:00:33 UTC
Third time trying to input this information.
At your request I tried to replicate the problem with 5.4.7.2. The problem remains. If I can manage to figure out how to attach a document again, I'll give you a test document that probes a bit further. This document Bug101263.odt, was created in .odt format and has not ever been in .docx format (in re: an earlier question).
Comment 15 jimrussell98116 2018-05-21 04:03:10 UTC
Created attachment 142221 [details]
test of Bug 101263
Comment 16 QA Administrators 2019-05-25 02:56:32 UTC
Dear jimrussell98116,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug