Download it now!
Bug 101347 - Closing a particular spreadsheet takes minutes
Summary: Closing a particular spreadsheet takes minutes
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.0.0.beta2
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0 target:5.2.2 target:5.2.1
Keywords: perf, regression
: 101365 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-08-06 01:05 UTC by Aron Budea
Modified: 2016-08-31 13:28 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2016-08-06 01:05:09 UTC
Open, and then close the spreadsheet attached to bug 101309:
https://bugs.documentfoundation.org/attachment.cgi?id=126623

There might be a crash when opening it (as reported in bug 101309), which I didn't encounter, but closing it is extremely slow, takes minutes.

Reproduced with: 5.2 beta 2, 5.2.0.4 and master build (be232a1b76fb263d17d2e52a420b6aba7272f3fd) / Windows 7 and 5.2.0.4 / Ubuntu 16.04.
Not reproduced with (closes quickly): 5.1.5.2 / Windows 7.
=> regression
Comment 1 MM 2016-08-06 10:19:23 UTC
Confirmed with v5.2.0.4 under windows 10 x64.
Comment 2 Caolán McNamara 2016-08-09 15:29:36 UTC
I'll bet this is since...

commit 88a0c7d01b7dfd085a0569030f97cc7de0f0d106
Author: Markus Mohrhard <markus.mohrhard@googlemail.com>
Date:   Sat Mar 26 13:11:53 2016 +0100

    switch to a listener based cond format update, tdf#95437
Comment 3 Caolán McNamara 2016-08-09 15:38:30 UTC
https://gerrit.libreoffice.org/#/c/28006/ makes the quit (relatively) super fast, assuming we don't care about the Notify when the Broadcaster is dying
Comment 4 Aron Budea 2016-08-09 17:12:13 UTC
Caolán, could bug 101365 be the same issue?
Comment 5 Caolán McNamara 2016-08-10 07:24:06 UTC
*** Bug 101365 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2016-08-18 16:05:26 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5c1812103a6c0cd29dd18e546d29ee683f675f6d&h=libreoffice-5-2

Resolves: tdf#101347 conditional formatting super slow on exit

It will be available in 5.2.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Aron Budea 2016-08-19 11:14:29 UTC
Caolán, could you cherry-pick the fix into the 5.2.1 branch as well?
Comment 8 Caolán McNamara 2016-08-19 11:21:33 UTC
Its in the 5-2-1 queue, but its not my field of expertise so its up to the calc guys if its inarguable the correct solution to get into 5.2.1
Comment 9 Aron Budea 2016-08-22 02:19:15 UTC
Thanks!

In the meantime, verified with master build (782dffe709158b1060a29f2882c8b72fe221bb7b).

Also, commit in master:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=cbab44f5eb27c8a45905167d2443f56b816b4a7b

Resolves: tdf#101347 conditional formatting super slow on exit
Comment 10 Commit Notification 2016-08-24 11:38:17 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-2-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ac51fb6a8642c5904db7e4de8dc89dabf284488c&h=libreoffice-5-2-1

Resolves: tdf#101347 conditional formatting super slow on exit

It will be available in 5.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Herbert Geiger 2016-08-31 13:28:35 UTC
thanks to all!!

today i've to tested version 5.2.1.2 prerelease downloaded from the offical webside via the torrent-network. the fix works

br

herbert