Download it now!
Bug 101408 - Calc crashs with conditional formating
Summary: Calc crashs with conditional formating
Status: CLOSED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: wantBacktrace
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2016-08-09 10:34 UTC by bonbon
Modified: 2018-05-24 16:31 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen capture (55.86 KB, image/jpeg)
2016-08-10 08:10 UTC, bonbon
Details
example file (14.62 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-08-10 08:27 UTC, bonbon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bonbon 2016-08-09 10:34:22 UTC
User-Agent:       Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build Identifier: LibreOffice 5.2.0.4

conditional formatting makes Calc Crash every day in my work(Dept.finance). Sorry i'm tired to give more informations. Just test it. It´s easy to prove.The conditional formatting is in a mess completely,can not maitain when you set it, varies every day if you use this sheet,till calc can not respond or crashes directly. It's sure to be a bug, all version tested since I use V4.0. I always update to the newest version, but not yet see any improvements about this. Why?

Reproducible: Always

Steps to Reproduce:
1.no predictions. Just crash when it likes.
2.
3.
Actual Results:  
crashes every day.

Expected Results:  
no crash anymore, 
no change conditional formating original setup(because it makes conditional formating to a mess day by day till the sheet stop respond)

[Information automatically included from LibreOffice]
Locale: zh-CN
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: yes


Reset User Profile?Yes
Comment 1 Julien Nabet 2016-08-09 20:23:25 UTC
Would it be possible you attach some example file?
(of course you need to sanitize your file, see https://wiki.documentfoundation.org/QA/Bugzilla/Sanitizing_Files_Before_Submission)
Comment 2 Kevin Suo 2016-08-10 02:59:24 UTC
(In reply to Kevin from comment #0)
I tried to create a new document with conditional formatting in version 5.2.0.4 and it works fine for me.

So, please provide test document, otherwise it's not possible to know what the problem is.

Also you can go to the LibreOffice Chinese discussion forum so we can discuss the issue: http://www.libreofficechina.org
Comment 3 bonbon 2016-08-10 08:05:38 UTC
Just try to do more copy and paste,drag to fill...etc.
Comment 4 bonbon 2016-08-10 08:10:51 UTC
Created attachment 126713 [details]
Screen capture
Comment 5 bonbon 2016-08-10 08:12:57 UTC
Your conditional formatting will start to be more and more like this(picture attached.)
Comment 6 bonbon 2016-08-10 08:27:14 UTC
Created attachment 126716 [details]
example file
Comment 7 bonbon 2016-08-10 08:31:14 UTC
(In reply to Julien Nabet from comment #1)
> Would it be possible you attach some example file?
> (of course you need to sanitize your file, see
> https://wiki.documentfoundation.org/QA/Bugzilla/
> Sanitizing_Files_Before_Submission)

Yes,sample file attached.
Comment 8 Buovjaga 2016-08-12 18:07:16 UTC
I did many fills and copy & paste operations in many different columns, but no crash.

You could try getting a backtrace: https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg

It would also be good to go through this checklist: https://wiki.documentfoundation.org/QA/FirstSteps

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: 5d8639aaf2f60157c99c3ee3a8bfa78e4efd010a
CPU Threads: 8; OS Version: Linux 4.6; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on August 9th 2016

Arch Linux 64-bit, KDE Plasma 5
Version: 5.2.0.4
Build ID: 5.2.0-1
CPU Threads: 8; OS Version: Linux 4.6; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Comment 9 bonbon 2016-08-16 09:04:05 UTC
When you do a lot of copy/paste day by day. you will find the conditional formatting more and more orderless,and the calc will respond slowlier and slowlier,then more crashes till calc stop respond nothing.
Comment 10 Buovjaga 2016-08-16 09:41:06 UTC
Please consider giving WinDbg a try, then.
Comment 11 Xisco Faulí 2016-09-23 08:30:13 UTC
Hi bonbon,
Could you please provide a backtrace so we can investigate it on our side?
Meanwhile, setting this to NEEDINFO
Comment 12 Julien Nabet 2016-09-27 19:36:05 UTC
There's been a lot of improvements from Markus (see https://cgit.freedesktop.org/libreoffice/core/log/?qt=author&q=markus).
If you've got some time, you can give a try to a master daily build (see http://dev-builds.libreoffice.org/daily/master/)
Comment 13 bonbon 2016-09-28 08:17:44 UTC
(In reply to Julien Nabet from comment #12)
> There's been a lot of improvements from Markus (see
> https://cgit.freedesktop.org/libreoffice/core/log/?qt=author&q=markus).
> If you've got some time, you can give a try to a master daily build (see
> http://dev-builds.libreoffice.org/daily/master/)

Yes, but nothing for this problem just as usual as all these years.
Comment 14 Buovjaga 2016-09-28 09:07:40 UTC
How about trying to get a backtrace?
Comment 15 pajaro 2017-01-26 13:00:35 UTC
I can feel this user

You have to avoid copy/paste any cell inside a conditional formatting (CF) range if you wanna keep your sanity

After a few copy/paste you end up with hundreds of lines in CF > manage and what looks like random different ranges

They are not random tho, they just subdivide the cells copied so you can modify them individually (I guess). Not sure if this is trying to copy how excel does it because I dont use excel, but its not very intuitive or what the user expect at all

To reproduce the crash you probably only have to copy and paste so many times that the list is so big that the computer cant handle it. Probably helps using a computer with low memory/cpu

My 2cents
Comment 16 QA Administrators 2017-07-27 12:06:29 UTC Comment hidden (obsolete)
Comment 17 Xisco Faulí 2017-07-27 14:44:02 UTC
Did you get any crashreport after it crashes?
Comment 18 QA Administrators 2018-01-29 10:27:07 UTC Comment hidden (obsolete)
Comment 19 Kevin Suo 2018-02-10 10:26:57 UTC
Bonbon: This problem must have been fixed in the fix of
Bug 95295 - Calc is fragmenting ranges for conditional formats without need. 

I see on your screenshot that the conditional formatting are duplicating each time you copy-paste. I think that is why Calc crashes (I also guess you are using a low memory PC). 

So the issue must have been fixed already, please try a most recent release. For finance department use I suggest you use the “Still” version (稳定版), rather than Fresh version (最新版).

By saying CRASHING here, I guess you mean that Calc is getting slow till no responding, but did not self-exit, am I correct?
Comment 20 Eike Rathke 2018-05-24 16:31:23 UTC
No further info, closing.