Bug Hunting Session
Bug 101510 - Installing an incomplete set of fonts causes issues in Google Chrome
Summary: Installing an incomplete set of fonts causes issues in Google Chrome
Status: RESOLVED DUPLICATE of bug 103080
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2016-08-13 20:26 UTC by Ed
Modified: 2017-10-31 18:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ed 2016-08-13 20:26:11 UTC
LibreOffice installs Open Sans Regular, Italic, Bold, and Bold Italic; however, it does not install Light, Light Italic, Semi-Bold, Semi-Bold Italic, Extra-Bold, and Extra-Bold Italic.  See the complete list here:

https://fonts.google.com/specimen/Open+Sans

Installing an incomplete set of fonts like this actually causes issues in Google Chrome: Google Chrome will prefer to use the locally installed font instead of a webfont, even if the font weight is not available locally.  For example, suppose a web page tries to display Open Sans Semi-Bold (font-weight: 600) with a webfont; Chrome will instead use the locally installed Open Sans Bold (font-weight: 700), even though it is not really the correct weight and there is a webfont with the correct weight available.

See the corresponding bug report for Chrome here (marked WontFix):

https://bugs.chromium.org/p/chromium/issues/detail?id=617419#c4
Comment 1 Aron Budea 2016-08-13 22:08:16 UTC
So, if any old application installs an incomplete set of fonts, it could cause rendering issues with Chrome on certain sites?
LibreOffice shipping with additional font weights for this particular font (ones it can't even use) wouldn't take care of this underlying issue.
Comment 2 Ed 2016-08-13 22:45:16 UTC
(In reply to Aron Budea from comment #1)
> So, if any old application installs an incomplete set of fonts, it could
> cause rendering issues with Chrome on certain sites?

Potentially, yes, although I don't know whether this is a common practice or not (LibreOffice is the only application I know of that does this).

> LibreOffice shipping with additional font weights for this particular font
> (ones it can't even use) wouldn't take care of this underlying issue.

I'm not sure what you mean by "can't even use"?  I just tried installing Open Sans Extra Bold manually and then running LibreOffice, and it seems to work.  (One issue is that it shows up as an additional font instead of an additional style - i.e., you end up with "Open Sans" and "Open Sans Extrabold" instead of just "Open Sans" with a new "Extra Bold" style - is that what you mean?)
Comment 3 Adolfo Jayme 2016-08-14 16:47:51 UTC
In any case we should be bundling Noto Sans instead of Open Sans. Noto is the succesor project replacing both Droid and Open Sans (now abandoned), it gives us much better character coverage, and more weights for Noto are planned. Open Sans was created as a brand font for Google and the old design team made a mistake picking it for LO to bundle.
Comment 4 Xisco Faulí 2017-10-31 18:32:13 UTC

*** This bug has been marked as a duplicate of bug 103080 ***