Download it now!
Bug 101516 - UI: Special Characters dialog additional work
Summary: UI: Special Characters dialog additional work
Status: RESOLVED DUPLICATE of bug 34882
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2016-08-14 10:35 UTC by Óvári
Modified: 2016-09-15 15:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Special Characters Dialog box (52.64 KB, image/png)
2016-08-14 10:35 UTC, Óvári
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Óvári 2016-08-14 10:35:13 UTC
Created attachment 126826 [details]
Special Characters Dialog box

Please see attachment which show suggestions to add the the Special Characters dialog box:
 1. Name (of character), this will enable:
(a) search by keyword
(b) the correct character to be selected, eg when selecting the ‘degree’ character
 2. Search box (for searching by keyword or codepoint)
 3. Search box for searching by drawing the character

Additionally, it is suggested to write the Hexadecimal code for ‘SPACE’ as ‘0020’ no ‘20’.
https://en.wikipedia.org/wiki/List_of_Unicode_characters

Further, when hovering with the mouse above a character, a bubble could come up with:
i. the character (which is larger)
ii. the name of the character (eg. SPACE); and
iii. the unicode value of the character (eg. U+0020).
This could make it quicker in selecting the correct character and improve accessibility for vision impaired and small screen devices.

Thank you
Comment 1 V Stuart Foote 2016-09-15 15:13:33 UTC
Thanks for the mockup, covers much of the same ground as the UX-Design team session:

http://user-prompt.com/libreoffice-design-session-special-character/

*** This bug has been marked as a duplicate of bug 34882 ***