Download it now!
Bug 101589 - "Disallow table to split across pages" does not work for a table after the file is saved as "doc" and reopened.
Summary: "Disallow table to split across pages" does not work for a table after the fi...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.4.2 release
Hardware: All All
: medium normal
Assignee: Justin L
URL:
Whiteboard: target:5.3.0 target:5.2.2
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-18 02:21 UTC by haim kilov
Modified: 2017-05-18 19:22 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
The attached file consists of a several lines and a 1-row and 1-column table. When the table was created, I did NOT allow the table to split across pages, and everything went well. After saving the fi (13.00 KB, application/msword)
2016-08-18 02:21 UTC, haim kilov
Details
A table with several rows having the same problem. (4.67 KB, application/unknown)
2016-08-24 03:03 UTC, haim kilov
Details
tdf101589_dontSplitTable.odt: single row, dontSplit-table that splits in doc and docx (11.05 KB, application/vnd.oasis.opendocument.text)
2016-08-24 04:22 UTC, Justin L
Details
table test-x2.docx: proof that 5.2 provides a non-splitting table (4.72 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-08-24 04:38 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description haim kilov 2016-08-18 02:21:37 UTC
Created attachment 126884 [details]
The attached file consists of a several lines and a 1-row and 1-column table. When the table was created, I did NOT allow the table to split across pages, and everything went well. After saving the fi

The attached file consists of a several lines and a 1-row and 1-column table. When the table was created, I did NOT allow the table to split across pages, and everything went well. After saving the file as "doc" and reopening the file, the table was split across pages.
Comment 1 Alex Thurgood 2016-08-18 07:39:23 UTC
@Haim : can you  also please provide an original ODT document in which splitting across page boundaries is allowed with which I can test ?

Please set back to unconfirmed afterwards.

Setting NEEDINFO
Comment 2 Alex Thurgood 2016-08-18 08:04:48 UTC

*** This bug has been marked as a duplicate of bug 62613 ***
Comment 3 Justin L 2016-08-23 13:34:19 UTC
This is probably not a bug, but an enhancement request.

I believe that .doc and .docx formats do not have a feature matching allow-table-to-split-across-pages. Therefore the best that LO can do is emulate that behaviour using other means. As of 5.2, this emulation exists for multiple rows, but doesn't apply to this particular example since this is only one row.

If you had simply disabled allow-row-to-break-across-pages-and-columns (without setting that for the entire table), then it would have exported as you expected.
Comment 4 haim kilov 2016-08-24 03:03:18 UTC
Created attachment 126996 [details]
A table with several rows having the same problem.
Comment 5 haim kilov 2016-08-24 03:08:41 UTC
The purpose of this was to start a table on a new page if it does not fit on the previous page, but leave it on the same page if it does fit there. In a large file this is very useful and cannot be replaced with "newpage".

Thsnk you for considering this issue.
Comment 6 Justin L 2016-08-24 04:22:37 UTC
Created attachment 126997 [details]
tdf101589_dontSplitTable.odt: single row, dontSplit-table that splits in doc and docx

Haim: please don't obsolete an attachment with one showing different characteristics that don't match the description.  It would also be better if you provided ODT (comment 1) versions of the test files in this case.
Comment 7 Justin L 2016-08-24 04:38:10 UTC
Created attachment 126998 [details]
table test-x2.docx: proof that 5.2 provides a non-splitting table

comment 4: I don't think you tested this using LO version 5.2 (see comment 3). This was fixed in bug 91083.

If you submit doc or docx bugs, those should be created using Microsoft Office.  You won't be able to create a "table that does not split" document in MSOffice I don't think.  If you can and it does not work in LO 5.2, then we need to do more work to achieve compatibility.

Proposed fix for a single-row-table is here: https://gerrit.libreoffice.org/28352.  I will request that it be backported to 5.2 so that it joins the other table-split fixes there.
Comment 8 Commit Notification 2016-08-29 09:48:34 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8fcb00173737f6243e459c9d7a80bf29b95c4839

tdf#101589 MS export: use dont-split-row for 1-row table

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Cor Nouws 2016-08-29 10:58:35 UTC
the issue in bug 62613 is with a table with multiple rows, and this issue (looking at the patch) for one row.
Comment 10 Cor Nouws 2016-08-29 10:59:04 UTC
fixed per comment #8
Comment 11 Commit Notification 2016-08-30 04:35:06 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4c0eb82f6e72d2ca19fbc0fb9345009b4873270a&h=libreoffice-5-2

tdf#101589 MS export: use dont-split-row for 1-row table

It will be available in 5.2.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2016-08-30 12:23:30 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c06d77c5eb57c1a7f5692028b6b04132593f9156

tdf#101589 MS import: set 1-row table to don't split if row is set

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.