Bug 101603 - LibreLogo python invocation error
Summary: LibreLogo python invocation error
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: x86-64 (AMD64) Mac OS X (All)
: high major
Assignee: Julien Nabet
URL:
Whiteboard: target:5.4.0 target:5.3.0.1 target:5.2.5
Keywords: bibisectRequest, regression
: 86791 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-08-19 07:50 UTC by Alex Thurgood
Modified: 2016-12-05 09:17 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2016-08-19 07:50:28 UTC
When testing LibreLogo on master 

Version: 5.3.0.0.alpha0+
Build ID: 77e792096502a7ac9506cbfba28aa6772d5a3e31
CPU Threads: 2; OS Version: Mac OS X 10.11.6; UI Render: default; 
Locale: fr-FR (fr.UTF-8); Calc: group

I get the following error message after activating the LibreLogo toolbar, and clicking on the menu entry "Set editing layout..."



com.sun.star.uno.RuntimeExceptionError during invoking function __translate__ in module file:///Applications/LibreOfficeDev.app/Contents/Resources/Scripts/python/LibreLogo/LibreLogo.py (<class 'TypeError'>: 'NoneType' object is not subscriptable
  File "/Applications/LibreOfficeDev.app/Contents/Resources/pythonscript.py", line 869, in invoke
    ret = self.func( *args )
  File "/Applications/LibreOfficeDev.app/Contents/Resources/Scripts/python/LibreLogo/LibreLogo.py", line 357, in __translate__
    lq = '\'' + lang['LEFTSTRING'].replace("|", "")
)
Comment 1 Alex Thurgood 2016-08-19 08:12:30 UTC
Also present in 

Version: 5.1.5.2
Build ID: 7a864d8825610a8c07cfc3bc01dd4fce6a9447e5
Threads CPU : 2; Version de l'OS :Mac OS X 10.11.6; UI Render : par défaut; 
Locale : fr-FR (fr.UTF-8); Calc: group

Confirming
Comment 2 Alex Thurgood 2016-08-19 08:13:44 UTC
Caolan : one for you ?
Comment 3 Caolán McNamara 2016-08-19 11:33:52 UTC
Don't know what it would have anything to do with me.

Works for me under Linux, maybe its the version of python on mac, or maybe its the language. Looking at the code there seems to be an eventual fallback to en_US there, so I wonder if share/Scripts/python/LibreLogo/LibreLogo_en_US.properties exists in the install
Comment 4 Alex Thurgood 2016-08-19 11:57:30 UTC
(In reply to Caolán McNamara from comment #3)
> Don't know what it would have anything to do with me.

OK, I'll take you off cc, sorry for the noise.

> 
> Works for me under Linux, maybe its the version of python on mac, or maybe
> its the language. Looking at the code there seems to be an eventual fallback
> to en_US there, so I wonder if
> share/Scripts/python/LibreLogo/LibreLogo_en_US.properties exists in the
> install

Will check and see.
Comment 5 Julien Nabet 2016-11-27 11:33:05 UTC
On MacOS 10.12 with master sources updated 3 days ago + FrenchUI
I reproduced this:
com.sun.star.uno.RuntimeException: Error during invoking function __translate__ in module file:///Users/XXX/lo/lode/dev/core/instdir/LibreOfficeDev.app/Contents/Resources/Scripts/python/LibreLogo/LibreLogo.py (<class 'TypeError'>: 'NoneType' object is not subscriptable
  File "/Users/XXX/lo/lode/dev/core/instdir/LibreOfficeDev.app/Contents/Resources/pythonscript.py", line 870, in invoke
    ret = self.func( *args )
  File "/Users/XXX/lo/lode/dev/core/instdir/LibreOfficeDev.app/Contents/Resources/Scripts/python/LibreLogo/LibreLogo.py", line 357, in __translate__
    lq = '\'' + lang['LEFTSTRING'].replace("|", "")
)
Comment 6 Commit Notification 2016-11-27 19:22:45 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ab3b5b0dfb0c92aa5e94a0f417950724c694ac57

tdf#101603: fix lgnpath for MacOs in LibreLogo

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2016-11-27 19:25:06 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=708554c0973718174c60eb566bb846146994b786&h=libreoffice-5-3

tdf#101603: fix lgnpath for MacOs in LibreLogo

It will be available in 5.3.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Julien Nabet 2016-11-27 19:25:20 UTC
For 5.2 branch, the patch is on review:
https://gerrit.libreoffice.org/#/c/31270/
Comment 9 Julien Nabet 2016-11-27 20:42:21 UTC
*** Bug 86791 has been marked as a duplicate of this bug. ***
Comment 10 Commit Notification 2016-12-05 09:17:49 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c5c7c011120b95bc782f200f1c46984d1e413e5d&h=libreoffice-5-2

tdf#101603: fix lgnpath for MacOs in LibreLogo

It will be available in 5.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.