Bug 101647 - GSoC table template: The table template read is not visible in menu item "Autoformat Styles.."
Summary: GSoC table template: The table template read is not visible in menu item "Aut...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: x86 (IA32) Windows (All)
: medium enhancement
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Table-Styles Writer-Table-Styles
  Show dependency treegraph
 
Reported: 2016-08-21 23:11 UTC by Regina Henschel
Modified: 2017-05-05 12:56 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
File, which contains a table-template element (14.91 KB, application/vnd.oasis.opendocument.text)
2016-08-21 23:11 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2016-08-21 23:11:49 UTC
Created attachment 126948 [details]
File, which contains a table-template element

After I open a file, which has got a custom table template, then I see this template in the new category "Table" in the Style&Formatting pane in the sidebar and I can use it from there for a new table. But this template does not exist in the list in menu Table > Autoformat Styles.

I have used the attached file with Version: 5.3.0.0.alpha0+
Build ID: 6431e91eca9e44684066a32ed3d6411509dac781
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-08-21_06:34:00
Locale: de-DE (de_DE); Calc: group
Comment 1 Cor Nouws 2016-08-22 08:26:36 UTC
(In reply to Regina Henschel from comment #0)

> ... But this template does
> not exist in the list in menu Table > Autoformat Styles.

Can confirm this.
I'm not sure however if that was intended to work, because I did not follow the project in details.
Comment 2 Regina Henschel 2016-09-01 14:31:07 UTC
"Enhancement" might be better. The user can add a table template via "Autoformat Styles" and then use this in all of his documents. If he assigns this template, it is listed in the new tab "Tables" in the Style&Formatting window and he can use it from there for the next table in the same document.

If the user opens a file which has a table template created by someone else, he sees it in the Style&Formatting window, but the user does not know, how to make it available for a different document. For true styles like paragraph or character styles, you can load the styles from an existing document to make them available in your new document. But that does not work for the table "style".

There should be something like "Add table template to personal table template collection." or the load style mechanism can be extended to table templates.
Comment 3 Yousuf Philips (jay) 2016-09-03 14:18:13 UTC
As table styles are intended to supersede autoformat styles, i wouldnt suggest listing them inside the autoformat style dialog as a new table styles dialog will be created.
Comment 4 Heiko Tietze 2016-09-05 11:58:43 UTC
We made also a proposal [1] how to access the feature. The dialog (or rather a new one) would be used to create a style, and the selection goes into the table format dialog as well as the sidebar. 

[1] https://design.blog.documentfoundation.org/2015/12/13/style-your-tables/
Comment 5 Yousuf Philips (jay) 2017-05-05 12:56:33 UTC
Non-autoformat styles wont appear in the autoformat list.