Bug 101654 - missing libpoppler header check in configure
Summary: missing libpoppler header check in configure
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-22 10:23 UTC by Riccardo Magliocchetti
Modified: 2017-03-03 13:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Riccardo Magliocchetti 2016-08-22 10:23:55 UTC
On a debian sid machine on 090e3fe4165aff11f557c7da2536fec44639607e and this autogen call:

./autogen.sh --without-java --without-epm --with-system-libs --without-system-libzmf --without-system-libstaroffice --without-system-boost --without-system-lpsolve

I get this error:

In file included from /home/rm/src/libo/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx:20:0:
/home/rm/src/libo/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx:34:22: fatal error: GfxState.h: File o directory non esistente
compilation terminated.
/home/rm/src/libo/solenv/gbuild/LinkTarget.mk:189: set di istruzioni per l'obiettivo "/home/rm/src/libo/workdir/CxxObject/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.o" non riuscito
make[1]: *** [/home/rm/src/libo/workdir/CxxObject/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.o] Errore 1
make[1]: *** Attesa per i processi non terminati....
In file included from /home/rm/src/libo/sdext/source/pdfimport/xpdfwrapper/pnghelper.hxx:24:0,
                 from /home/rm/src/libo/sdext/source/pdfimport/xpdfwrapper/pnghelper.cxx:20:
/home/rm/src/libo/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx:34:22: fatal error: GfxState.h: File o directory non esistente
compilation terminated.

For reference in debian the header is provided by libpoppler-private-dev
Comment 1 V Stuart Foote 2016-08-22 13:55:45 UTC
So, when was the last time you built cleanly?

Poppler was updated including several of the patches 2016-08-14 with https://cgit.freedesktop.org/libreoffice/core/commit/?id=10290000117b562e3f179c3d1073774dd54cdfee

subsequent to that?
Comment 2 Riccardo Magliocchetti 2016-08-22 15:02:38 UTC
(In reply to V Stuart Foote from comment #1)
> So, when was the last time you built cleanly?
> 
> Poppler was updated including several of the patches 2016-08-14 with
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=10290000117b562e3f179c3d1073774dd54cdfee
> 
> subsequent to that?

Haven't built on this machine since years i think. Anyway since i have --with-system-libs i think it's the system poppler and not the bundleld one.
Comment 3 David Tardon 2016-08-23 12:54:32 UTC
(In reply to Riccardo Magliocchetti from comment #2)
> Haven't built on this machine since years i think. Anyway since i have
> --with-system-libs i think it's the system poppler and not the bundleld one.

Well, could you make sure? What are the values of POPPLER_CFLAGS and POPPLER_LIBS in config_host.mk ? And what's your poppler version?
Comment 4 Riccardo Magliocchetti 2016-08-23 13:28:43 UTC
(In reply to David Tardon from comment #3)
> (In reply to Riccardo Magliocchetti from comment #2)
> > Haven't built on this machine since years i think. Anyway since i have
> > --with-system-libs i think it's the system poppler and not the bundleld one.
> 
> Well, could you make sure? What are the values of POPPLER_CFLAGS and
> POPPLER_LIBS in config_host.mk ? And what's your poppler version?

export POPPLER_CFLAGS=$(gb_SPACE)-isystem /usr/include/poppler
export POPPLER_LIBS=$(gb_SPACE) -lpoppler

ii  libpoppler-dev:amd64                                        0.44.0-3
Comment 5 QA Administrators 2017-03-01 10:41:15 UTC Comment hidden (obsolete)
Comment 6 David Tardon 2017-03-03 13:17:04 UTC
It is generally assumed that if a library's pkg-config file does exist, then everything needed to develop using that library (like headers) is in place too. So if Debian puts poppler headers into a different package than poppler.pc, it is a bug in Debian packaging.