Bug 101715 - Formula editor: Support aligning equations on a specified character (nominally by &)
Summary: Formula editor: Support aligning equations on a specified character (nominall...
Status: RESOLVED DUPLICATE of bug 44902
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
5.1.5.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-25 02:15 UTC by Bernd Wechner
Modified: 2016-09-21 19:38 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernd Wechner 2016-08-25 02:15:05 UTC
One the beauties of LibreOffice is indeed it's use of LaTex math allowing for rapid and easy work with math.

The newline is supported which rocks. But is useless until it also supports the align* feature of the LaTex asmath module. Here's an example:

\begin{align*} 
2x - 5y &=  8 \\ 
3x + 9y &=  -12
\end{align*}

Which aligns where the & characters are.

Aligning a series of equations on an = sign is stock standard need in mathematical expression and work arounds with phantom and/or matrices are wholly inadequate. 

phantom works well enough if the LHS is unchanging.

matrix works well enough if you have time to kill in formatting and finding the right settings to space them right and are happy with ugly back code for your equations anulling one of the beauties of the current LaTex style support.
Comment 1 Bernd Wechner 2016-08-25 02:18:54 UTC
My apologies to triage, I found this subsequent to filing:

https://bugs.documentfoundation.org/show_bug.cgi?id=44902

a clear duplicate. Though IMHO this one is worded better for what it's worth.
Comment 2 Buovjaga 2016-09-21 19:38:04 UTC

*** This bug has been marked as a duplicate of bug 44902 ***