Bug Hunting Session
Bug 101720 - TABLE: cell styles for text tables
Summary: TABLE: cell styles for text tables
Status: RESOLVED DUPLICATE of bug 34391
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-25 07:21 UTC by J. Magnin
Modified: 2017-05-04 13:25 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Preview of color overflow in OLE (545 bytes, image/png)
2016-08-25 07:21 UTC, J. Magnin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description J. Magnin 2016-08-25 07:21:53 UTC
Created attachment 127020 [details]
Preview of color overflow in OLE

Hello,
I would like to submit a feature request: adding the possibility to have cell styles for text tables in Writer - with background color support - like there exists in Calc; along with "Paragraph styles", "Character styles", etc.

I often need to format some cells in my reports, and it has to be consistent throughout it. Currently, for this, I need to select the cells individually (or by group if they are adjacent) and then setting formatting parameters.
The main problem I have is with cells background color: if I don't select the whole cell, that's only the paragraph background which is modified. I also have to remember which color I assigned to which value to keep consistent in my whole document.
For these tasks, having cell styles would be much more productive.

I know that there's the possibility of including a Calc table, in which I can use cell styles, but the result is not satisfying, as background colors often overflows in adjacent cells (see attachment).
Comment 1 Zenaan Harkness 2016-08-29 10:56:45 UTC
Such styles should be usable anywhere cells are used - e.g. in Calc too obviously, the same (or similar) styles dialogues and features should be available. This seems to be dup.

*** This bug has been marked as a duplicate of bug 34391 ***