Bug 101844 - Lapses in response time and cursor direction problem in Hebrew
Summary: Lapses in response time and cursor direction problem in Hebrew
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected) release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
Depends on:
Blocks: RTL-CTL
  Show dependency treegraph
Reported: 2016-09-01 14:33 UTC by menashe
Modified: 2017-11-14 10:14 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description menashe 2016-09-01 14:33:13 UTC
I installed 5.2 release on  several machines

2 windows 10 OS
and one windows 7

Each machines has different hardware
But this is not a hardware issue as it occurs a different machines

I had 2 major bugs

1) Every few seconds a major lapse in response time causing the system to freeze for about 30-60 seconds

It feels like a memory problem. Increasing the virtual memory helps slightly.

2) I almost exclusively write in Hebrew. Since the 5.2 update the arrows keys have switched directions. If I press < the cursor will move right (in Hebrew) and if I press > the cursor will move left.

This seems to certainly be a bug because I have since reverted to 5.15 and essentially no problems

BTW I had already removed the registrymodifications.xcu to force its recontruction. That had solved a previous bug (long response time) but the 5/2 has created its own problems as described - on several machines

Comment 1 Aron Budea 2016-09-01 14:47:50 UTC
Issue 2) has been reported in bug 101361, and is being worked on/might be already fixed in the master branch, I'd expect it to be backported for the 5.2 bugfix release after 5.2.1.
Comment 2 Buovjaga 2016-09-22 20:21:39 UTC
Not using OpenGL (mentioned in Help - About)?
Comment 3 Yousuf Philips (jay) (retired) 2016-10-17 21:14:23 UTC
Hi menashe,

Are you still facing the same issue with the latest version of 5.2 of the response time freezing? Any ideas if 5.1 had this same issue on these machines? Can you copy and paste the text found in the Help > About dialog which gives version information, etc. so we can better understand your installation environment?
Comment 4 menashe 2016-10-18 10:57:15 UTC
I reverted to 5.1 and am  waiting for resolution
I am working under windows 7
Comment 5 Yousuf Philips (jay) (retired) 2016-10-18 11:30:43 UTC
Hi menashe,

Unfortunately without additional information from you, we wont be able to investigated the issue. Please provide the requested details mentioned in my last comment.
Comment 6 Omer Zak 2017-11-14 10:04:33 UTC
I tested in version:

Build ID: 9050854c35c389466923f0224a36572d36cd471a
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.utf8); Calc: group

OS: Debian 64bit Stretch (Debian 9.2, with some backported packages)

1. The arrow keys move the cursor in the correct direction in Hebrew text.
2. I experienced no freezes. The file registrymodifications.xcu exists and I did not touch it.
My guess is that in Menashe's installation, this file somehow got corrupted (or there was a bad upgrade path for it).
Comment 7 Buovjaga 2017-11-14 10:11:59 UTC
Yeah, let's close.
Comment 8 Lior Kaplan 2017-11-14 10:14:45 UTC
Menashe - could you check with an updated version. Please reopen this issue if needed.