Bug 101851 - Autocorrect not working for words next to quotes when "localized options quote replacement" is on
Summary: Autocorrect not working for words next to quotes when "localized options quot...
Status: RESOLVED DUPLICATE of bug 54409
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-02 00:28 UTC by vic.orgos+bugslibreoffice
Modified: 2016-10-09 16:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the problem (1.69 KB, image/png)
2016-09-23 19:53 UTC, Buovjaga
Details
greek autocorrect fails for words in double quotation marks (1.83 KB, image/png)
2016-10-06 19:40 UTC, vic.orgos+bugslibreoffice
Details
autocorrecct fails in quoted words regardless of language (19.03 KB, image/png)
2016-10-07 08:52 UTC, vic.orgos+bugslibreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vic.orgos+bugslibreoffice 2016-09-02 00:28:54 UTC
I am working on a Greek document in Writer and because I am lazy I am letting the autocorrect system put accents when possible. Unfortunately the Autocorrect system fails to do its job when the word is next to punctuation or when it is in the beginning of a sentence.

See following small screenshot to better understand.

https://www.dropbox.com/s/foffokfi0c5cega/libreoffice-autocorrect-prob.PNG?dl=0
Comment 1 vic.orgos+bugslibreoffice 2016-09-02 07:23:04 UTC
I've checked v5.1.5.2 and the behaviour is the same.
Comment 2 Buovjaga 2016-09-23 19:53:07 UTC
Created attachment 127578 [details]
Screenshot of the problem
Comment 3 tommy27 2016-10-06 12:31:30 UTC
I tried with LibO 5.1.5.2 under Win7x64 and I can reproduce the issue you describe only if words are close to punctations such as « and » (exactly like in your screenshot).

It seems that the autocorrect engine doesn't recognize those characters as autocorrect "triggers".

other punctation marks like ( " , ; : . ) corretly trigger the autocorrect replacements.

status --> NEW

@Lazlo Nemeth
can we add those « and » to the "autocorrect" triggers list?
Comment 4 vic.orgos+bugslibreoffice 2016-10-06 19:19:47 UTC
What about the part where the word is at the start of the sentence? I showed that in the image I uploaded. Shouldn't autocorrect fix that as well?
Comment 5 vic.orgos+bugslibreoffice 2016-10-06 19:36:37 UTC
on my system, v5.0.5.2 on W7x64, autocorrect fails for words enclosed in left and right double quotation marks. I mean the unicode chars U+201C and U+201D

see here for the marks in question

http://unicode-table.com/en/sets/quotation-marks/
Comment 6 vic.orgos+bugslibreoffice 2016-10-06 19:40:18 UTC
Created attachment 127847 [details]
greek autocorrect fails for words in double quotation marks

example of greek autocorrect fails for words in double quotation marks
Comment 7 tommy27 2016-10-07 00:55:55 UTC
does this happen just with greek language?

Anyway I strongly suggest you to upgrade to LibO 5.1.x or 5.2.x since the 5.0.5.2 release you are using is obsolete and may suffer from bugs that have been fixed in newer branches
Comment 8 vic.orgos+bugslibreoffice 2016-10-07 08:52:03 UTC
Created attachment 127851 [details]
autocorrecct fails in quoted words regardless of language

using latest stable build arch linux 32bit
Comment 9 tommy27 2016-10-07 08:58:43 UTC
are you seeing this issue on Linux only on Windows too?
Comment 10 tommy27 2016-10-07 09:12:49 UTC
mmhhh... it seems the issue is triggered by automatic replacement of single and double quotes in Autocorrect Localized Options

https://help.libreoffice.org/Common/Localized_Options

if the replacement is enabled the autocorrect doesn't work after a quote.

if the replacement is disabled (like I have in my LibO) it seems to work fine.

regarding the issue at the start of the sentence remember that autocorrect is case sensitive so if you have an asdf -> aside rule, it will apply if you type asdf in middle of the phrase.

but if you type it at the beginning of the phrase and you have automatic first capitalization, your asdf will indeed turn into Asdfg and won't correct unless you add a new autocorrect rule such ad Asdfg -> Aside
Comment 11 tommy27 2016-10-09 16:45:40 UTC
after doing some queries in the bug tracker I found that this issue was already reported before.

*** This bug has been marked as a duplicate of bug 54409 ***