Bug 101852 - In the Startcenter there is no tooltip for the thumbnails
Summary: In the Startcenter there is no tooltip for the thumbnails
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All Linux (All)
: medium normal
Assignee: Maxim Monastirsky
URL:
Whiteboard: target:5.3.0
Keywords: regression
Depends on:
Blocks:
 
Reported: 2016-09-02 04:59 UTC by Jean-Baptiste Faure
Modified: 2016-09-04 10:40 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2016-09-02 04:59:23 UTC
In the master and with the GTK3 vclplugin, the startcenter does not show the pathname of the files in the recent file screen. It shows only the generic tooltip "Click an icon on the left pane..."
The problem does not occurs with the GTK2 vclplugin.
The problem does not occur in LO 5.2 branch, whatever the GTK vclplugin chosen, so regression.

Master and LO 5.2 both built at home under Ubuntu 16.04 x86-64. Tested with a clean new user profile.

Version: 5.3.0.0.alpha0+
Build ID: dcc56d663059b3baced58e34bb8186a05ceadf53
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; 
Ubuntu_16.04_x86-64
Locale: fr-FR (fr_FR.UTF-8); Calc: group

Best regards. JBF
Comment 1 Xisco Faulí 2016-09-02 09:04:22 UTC
I can't reproduce it with 

Version: 5.3.0.0.alpha0+
Build ID: dcc56d663059b3baced58e34bb8186a05ceadf53
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 2 Thomas Hackert 2016-09-02 15:35:23 UTC
Hello Jean-Baptiste, *,
Thank you for reporting this bug :) I can confirm your bug somehow with

OS: Debian Testing AMD64
LO: Version: 5.3.0.0.alpha0+
Build ID: a8a7b7114d96b2013b00e9bc0ced81aad5495457
CPU Threads: 4; OS Version: Linux 4.5; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-09-02_05:11:44
Locale: de-DE (de_DE.UTF-8); Calc: group
(parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel/Linux)

Interestingly, I see this only with a de_DE UI language, but not with the en_US one ... :( So I am not sure, if my observation is a different bug or if I should set the status of your bug to "New" ... :(
HTH
Thomas.
Comment 3 Jean-Baptiste Faure 2016-09-02 17:08:45 UTC
(In reply to thackert from comment #2)
> [...]
> Interestingly, I see this only with a de_DE UI language, but not with the
> en_US one ... :( So I am not sure, if my observation is a different bug or
> if I should set the status of your bug to "New" ... :(

Thank you Thomas for your tests. In my case, I see the bug in both fr_FR and en_US UI.

Best regards. JBF
Comment 4 Thomas Hackert 2016-09-03 09:33:27 UTC
Hello Jean-Baptiste, *,
(In reply to Jean-Baptiste Faure from comment #3)
> (In reply to thackert from comment #2)
> > [...]
> > Interestingly, I see this only with a de_DE UI language, but not with the
> > en_US one ... :( So I am not sure, if my observation is a different bug or
> > if I should set the status of your bug to "New" ... :(
> 
> Thank you Thomas for your tests. In my case, I see the bug in both fr_FR and
> en_US UI.

hm, O.K. Is this then the same bug / cause for this behaviour? I am still not sure, if I should set the status to "New" ...
Have a nice day
Thomas.
Comment 5 Maxim Monastirsky 2016-09-03 18:06:42 UTC
Unrelated to gtk3, and looks like a regression of one of my commits -> taking.
Comment 6 Commit Notification 2016-09-04 09:02:48 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d5081c16ac77971c9523405c4a10a10a628ce0da

tdf#101852 Revert "tdf#101779 Allow multiline tooltips in template manager"

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Jean-Baptiste Faure 2016-09-04 10:40:41 UTC
Hi Maxim,

Thank you very for the quick fix. It works as expected in Version: 5.3.0.0.alpha0+
Build ID: 4d0b71be75804dd2b008d3da932d620893fbd780
Threads CPU : 4; Version de l'OS :Linux 4.4; UI Render : par défaut; 
Ubuntu_16.04_x86-64
Locale : fr-FR (fr_FR.UTF-8); Calc: group

built at home.

Best regards. JBF