Download it now!
Bug 101869 - Template manager settings button should activate with spacebar or enter
Summary: Template manager settings button should activate with spacebar or enter
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Akshay Deep
URL:
Whiteboard: target:5.3.0
Keywords:
Depends on:
Blocks: Template-Manager a11y
  Show dependency treegraph
 
Reported: 2016-09-03 01:52 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-02-09 15:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-09-03 01:52:54 UTC
Presently the settings button menu in the template manager only activates through the keyboard with the up and down arrow keys, but as it is a button, it should also activate with the spacebar and enter key.

Version: 5.3.0.0.alpha0+
Build ID: 139d3b3e8b157c1f365f888126269f0902acbaa2
CPU Threads: 2; OS Version: Linux 3.19; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-08-26_00:01:39
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 Cor Nouws 2016-09-03 11:11:13 UTC
confirmed
Comment 2 Commit Notification 2016-09-07 19:51:10 UTC
Akshay Deep committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=eb20d3cdaacb96b23f1fc771120388e6628b09e2

tdf#101869 Allow toolbox to open from spacebar

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Samuel Mehrbrodt (CIB) 2016-09-07 19:52:01 UTC
There were some issues because of which we decided to allow only spacebar to open the dropdown for now.
Enabling the same for enter would change existing behavior and we are not sure about the impacts this might have.
Comment 4 Alex ARNAUD 2017-02-09 15:24:48 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #3)
> There were some issues because of which we decided to allow only spacebar to
> open the dropdown for now.
> Enabling the same for enter would change existing behavior and we are not
> sure about the impacts this might have.

It isn't logical for a blind user for instance because enter is often use for such stuff.

What is the fix do? On LibreOfficeDev 5.4 GTK2 on Debian 8.7, enter produces no effect.

Best regards.