Bug Hunting Session
Bug 101892 - Page style dialog has increased in width
Summary: Page style dialog has increased in width
Status: RESOLVED DUPLICATE of bug 101475
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Dialog Page-Dialog
  Show dependency treegraph
 
Reported: 2016-09-04 13:33 UTC by Yousuf Philips (jay) (retired)
Modified: 2016-10-18 02:16 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
the Page format dialog for Calc is oddly sized (16.61 KB, image/png)
2016-09-05 03:20 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-09-04 13:33:09 UTC
Steps:
1) Open Calc
2) Format > Page
3) Notice the dialog has alot of horizontal space

Width of dialog in 5.1 is 641px, while it is 775px in master.

Version: 5.3.0.0.alpha0+
Build ID: f7513f0f53f2d074c08610a68fb787bb379c31d4
CPU Threads: 2; OS Version: Linux 3.19; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-09-02_23:58:05
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 brucehohl 2016-09-04 18:09:25 UTC
See Bug 101475 comments 4 and 5.
Comment 2 V Stuart Foote 2016-09-05 03:20:05 UTC
Created attachment 127151 [details]
the Page format dialog for Calc is oddly sized

Confirmed on Windows 10 Pro 64-bit en-US with

Version: 5.3.0.0.alpha0+
Build ID: 696e83b663d4f3e00f23947613f9f3916a4dd14d
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-09-03_10:21:32
Locale: en-US (en_US); Calc: CL

clip attached shows the overly wide Page format dialog for Calc. Other modules for build are not so wide.
Comment 3 Yousuf Philips (jay) (retired) 2016-09-05 12:53:21 UTC
Clearing profile doesnt solve the issue.
Comment 4 raal 2016-09-21 15:23:25 UTC
This seems to have begun at the below commit.
Adding Cc: to Dennis Francis ; Could you possibly take a look at this one? Thanks

author    Dennis Francis <dennisfrancis.in@gmail.com>    2015-10-31 22:19:38 (GMT)
committer    Eike Rathke <erack@redhat.com>    2015-12-07 13:49:53 (GMT)
commit    2e512174f2116d86682037459fd5ab5164e9f510 (patch)
tree    f28b135f29c1246a7a1f6a766de1214ab49f3bf6
parent    1a032dcfebc2702f0612c470d6b9c3e3cf4fb637 (diff)
tdf#34449 : ability of deleting borders of a cell from adjacent cell



5247141e4beaf94fc750d18a14cf354792e97b01 is the first bad commit
commit 5247141e4beaf94fc750d18a14cf354792e97b01
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Wed Dec 9 03:59:57 2015 -0800
    source sha:2e512174f2116d86682037459fd5ab5164e9f510
    source sha:2e512174f2116d86682037459fd5ab5164e9f510
:040000 040000 84846b208e2610115569623b75bdf9c7c6f38b06 774d16c9e597bc14a4ea8e2b557ce6ee61d8e5cd M    instdir

git bisect log
# bad: [6380ca07b05f68dedcaa379302cfe1fa478571c4] source sha:60b74fe1775e647545d2da1fcc58a4c63ec18aa5
# good: [1f670510f08cb800cbae2a1dd6ea70d3542e4721] source sha:49c2b9808df8a6b197dec666dfc0cda6321a4306
git bisect start 'origin/master' 'oldest'
# bad: [38f37b8ec1a2d199bb957cfd2581df7d1b273b74] source sha:c0da1080b61a1d51654fc34fdaeba373226065ff
git bisect bad 38f37b8ec1a2d199bb957cfd2581df7d1b273b74
# bad: [6998931a34ad75eb555f882fbed223e585548721] source sha:1fbd073828ef52f5206aed4643226bae9fb85f4f
git bisect bad 6998931a34ad75eb555f882fbed223e585548721
# bad: [0ea9534d0f4c90833e004706de7c11abe5bc522d] source sha:97361478e64f11330f7f7aea819d60c7562fb0f6
git bisect bad 0ea9534d0f4c90833e004706de7c11abe5bc522d
# good: [f1485fe9fdb687868c722bcb082adecc451f7a91] source sha:ebe80ac6713b67b1801ede3d1e9038cb2c93cb11
git bisect good f1485fe9fdb687868c722bcb082adecc451f7a91
# bad: [df62dac2764f25a1365653cd038f0e44e6f15485] source sha:7201810cb88811b05b938cc3db3232d9cf84c82e
git bisect bad df62dac2764f25a1365653cd038f0e44e6f15485
# bad: [1c171d239864f3db766df4a4e6385874e576b577] source sha:0cde3ca230364492aa6b7f634b97178164268728
git bisect bad 1c171d239864f3db766df4a4e6385874e576b577
# bad: [c1136387cf46f4ae7175f02e69b9ca8ff20d8b32] source sha:ebafc4fef20944c9c0ba75fbea064bf285a73735
git bisect bad c1136387cf46f4ae7175f02e69b9ca8ff20d8b32
# bad: [3aa266c653fb8a4718ce390823d4f785e0e9c54f] source sha:4211eaf1357045d39049b12e80ff282553bcd053
git bisect bad 3aa266c653fb8a4718ce390823d4f785e0e9c54f
# bad: [38fdae5890e894fb318eed3dc51b286ba23da839] source sha:19c7af844f12436a48be2ef263ede8f0f27d257d
git bisect bad 38fdae5890e894fb318eed3dc51b286ba23da839
# good: [77c265ea671059c3255b9e77426dd19576ef93c6] source sha:0abfcb735e60757ee64aa6d0fbb1b601c29813f3
git bisect good 77c265ea671059c3255b9e77426dd19576ef93c6
# bad: [1f14224f41e619e98222dff828aabf3ddb13b9ab] source sha:a27f2397f091d37cb9cf1ab98b0e96ca8dfa7406
git bisect bad 1f14224f41e619e98222dff828aabf3ddb13b9ab
# bad: [5247141e4beaf94fc750d18a14cf354792e97b01] source sha:2e512174f2116d86682037459fd5ab5164e9f510
git bisect bad 5247141e4beaf94fc750d18a14cf354792e97b01
# good: [68a872a7740fecdac58318c6d7451633643dd4d4] source sha:1a032dcfebc2702f0612c470d6b9c3e3cf4fb637
git bisect good 68a872a7740fecdac58318c6d7451633643dd4d4
# first bad commit: [5247141e4beaf94fc750d18a14cf354792e97b01] source sha:2e512174f2116d86682037459fd5ab5164e9f510
Comment 5 V Stuart Foote 2016-09-21 16:04:33 UTC
Had doubts it was that far back, but the bibisection is reasonable. 

From builds of master on hand, good through 2015-11-25
Version: 5.1.0.0.alpha1+ (x64)
Build ID: d667e3210b12c7ce3b3727e2a0e369a520fbaaa4
Threads 8; Ver: Windows 6.19; Render: default; 

but dialog is over size by
Version: 5.2.0.0.alpha0+
Build ID: 813a319fe836d1ed1c967928bc044643d0b4c07d
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-01-12_07:46:53
Locale: en-US (en_US)
Comment 6 Dennis Francis 2016-09-21 16:13:15 UTC
See [2]. The width increase is due to long checkbox label "Remove border from adjacent cells". I thought Caolán's patch[2] had fixed the issue in master.

[1] https://bugs.documentfoundation.org/show_bug.cgi?id=99963
[1] https://cgit.freedesktop.org/libreoffice/core/commit/?id=ea3f74ba0a9d291f26a79f2568d59f1a030d0585
Comment 7 V Stuart Foote 2016-09-21 16:42:58 UTC
So, same bibisect result as for bug 99963 but issue for oversize dialog remained. 

Maybe something more than setting wrap of the checkbox labels was needed to control the dialog size?
Comment 8 V Stuart Foote 2016-09-22 13:09:36 UTC
A see also bug 102356 -- not explicitly related, but something is off with width controls for the .UI for the panels on the Page style dialog.
Comment 9 Caolán McNamara 2016-09-28 07:57:04 UTC
*wraps harder*

*** This bug has been marked as a duplicate of bug 101475 ***