Download it now!
Bug 101893 - Unable to select more than one image to create a Group
Summary: Unable to select more than one image to create a Group
Status: RESOLVED DUPLICATE of bug 34438
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-04 15:03 UTC by besancon4me
Modified: 2016-09-04 20:16 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description besancon4me 2016-09-04 15:03:44 UTC
To recreate:

Create a new Word document.

Insert two pictures (e.g. jpeg images).
Add a text box and position it on top of one of the pictures. (for example, as if you were adding a 'You Are Here' label on an image of a map.
 
Left Click to Select one of the pictures, so that the 8 blue squares are visible, showing the selection is active.
Now use Shift Left Click to select the second image.
The 8 blue squares on the 1st image disappear, and the 2nd image isn't selected either.  i.e. neither image is now selected.

Left Click to Select one of the pictures, so that the 8 blue squares are visible, showing the selection is active.
Now use Left Click to select the second image.
The 8 blue squares on the 1st image disappear, and 8 blue squares on the 2nd image now appear. i.e. only the 2nd image is now selected.

Left Click to Select the text box, so that the 8 green squares are visible, showing the selection is active.
Now use Shift Left Click to select the image underneath it.
The 8 green squares on the 1st image disappear, and the 2nd image isn't selected either.  i.e. neither object is now selected.

Left Click to Select the text box, so that the 8 green squares are visible, showing the selection is active.
Now use Left Click to select the image underneath it.
The 8 green squares on the text box disappear, and 8 blue squares on the 2nd image now appear. i.e. only the image is now selected.

The effect of this is that it is not possible to select images or text boxes and add them to a Group, so if an image is moved, the text box won't move with it.  In the example of the You Are Here label on top of a map, this means your label can easily end up in the wrong place on the map.

It seems somebody tried to reopen a closed bug report with this bug back in February, but it looks like it was just closed again, with no action taken.
Comment 1 Regina Henschel 2016-09-04 20:16:54 UTC
The underlaying problem is, that the images, which you insert in Writer, are no drawing objects. The request to allow grouping with such objects too, is very old.

There exist some workarounds:
- Insert the images in a temporary Draw document, group them there, and copy them back to Writer. The images are converted to drawing objects and as such can be grouped.
- Put the images together into a frame, anchor them to frame, and set frame border to none and transparency to 100%. So the frame takes the role of the group.
- Use the picture as background of an rectangle, and rectangles can be grouped.

*** This bug has been marked as a duplicate of bug 34438 ***