Bug 101918 - Hang if adding .oxt extension by extensions manager
Summary: Hang if adding .oxt extension by extensions manager
Status: RESOLVED DUPLICATE of bug 99784
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
5.2.1.1 rc
Hardware: x86 (IA32) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-05 23:20 UTC by Mike Protenic
Modified: 2016-10-04 08:28 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Protenic 2016-09-05 23:20:54 UTC
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:48.0) Gecko/20100101 Firefox/48.0
Build Identifier: 5.2.4

Upon opening Extensions Manager, none of the control buttons are active except ADD. However, upon adding an extension, the progress bar stops after a few seconds, and the application no longer responds to commands of any sort, and must be forced quit.

Reproducible: Always

Steps to Reproduce:
1.Open LibreOffice and click on menu choice "Tools>Extensions Manager"
2.Click "Add"
3.Wait for processing hang
Actual Results:  
Given in details

Expected Results:  
Add the extension and report it available after restart of application.




Reset User Profile?No
Comment 1 Buovjaga 2016-09-28 19:01:46 UTC
Your steps don't mention actually selecting an extension. Should they? Which extension? All or a specific one?

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 2 Alex Thurgood 2016-09-29 16:24:16 UTC
Sigh, DUP of bug 99784

*** This bug has been marked as a duplicate of bug 99784 ***
Comment 3 Mike Protenic 2016-10-04 00:57:30 UTC
As suggested, I have a QuickTime screen recording of the hang during attempt to update Language Tool from 2.6 to 3.5, and the warning from LT about Java 64-bit compatibility and some other issues. The recording is 288MB zipped, and cannot be attached here.

Please advise.
Comment 4 Alex Thurgood 2016-10-04 08:27:02 UTC

*** This bug has been marked as a duplicate of bug 99784 ***
Comment 5 Alex Thurgood 2016-10-04 08:28:23 UTC
This report is a duplicate of bug 99784. Please do not reset to UNCONFIRMED.