Bug 102017 - [l10n] Menu keyboard shortcuts are French instead of Dutch
Summary: [l10n] Menu keyboard shortcuts are French instead of Dutch
Status: RESOLVED DUPLICATE of bug 100414
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-09 10:30 UTC by Roel Schroeven
Modified: 2016-09-09 14:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roel Schroeven 2016-09-09 10:30:28 UTC
In my Dutch LibreOffice installation, keyboard shortcuts are in French instead of Dutch. This is visible in the menu itself, and also in Extra -> Aanpassen -> Toetsenbord.

For example, the menu shows Ctrl+Maj+Y instead of Ctrl+Shift+Y and Ctrl+Entree instead of Ctrl+Enter. The same happens in Writer, Calc, Impress, ...

OS is Windows 7 in Dutch with locale Dutch (Belgium).
LibreOffice is 5.2.0.4 (but I'm pretty sure I have seen the same in older versions), with UI language Dutch and locale Dutch (Belgium).

Not a showstopper, but mildly annoying and gives an (AFAIK undeserving) impression of lack of attention to detail.

(Aside: Bugzilla tells me "For all problems that are connected to a particular Language version of LibreOffice. Alternatively you can use one of the other components and set the l10n keyword.", but then it tells me "There is no keyword named 'l10n'. See the list of available keywords.")
Comment 1 Maxim Monastirsky 2016-09-09 10:45:27 UTC
In LibreOffice menu shortcuts appear in the current input language, not in system locale. Maybe you have French as your current input language?
Comment 2 Roel Schroeven 2016-09-09 11:36:36 UTC
Do you mean the current input language in Windows? That is also Dutch (Belgium), with keyboard Belgian (point).

Belgian keyboards are AZERTY, mostly the same as French keyboards; maybe that might be a source of confusion?
Comment 3 Maxim Monastirsky 2016-09-09 12:22:11 UTC
(In reply to Roel Schroeven from comment #2)
> Do you mean the current input language in Windows?
Yes. We use the GetKeyNameTextW Win32 API to get key names, and according to MSDN its result depends on current keyboard layout:

https://msdn.microsoft.com/en-us/library/windows/desktop/ms646300(v=vs.85).aspx

Thanks to Google I came across this thread, which suggests that we're not alone with this problem:

https://stackoverflow.com/questions/23008486/shift-shortcut-being-displayed-as-maj-for-culture-nl-be-when-it-should-be-shif
Comment 4 Roel Schroeven 2016-09-09 13:01:26 UTC
I see the problem. Windows doesn't make a distinction between Flemish and Walloon keyboards (Belgian AZERTY in Dutch and French respectively), even though Windows AFAICS does link the keyboard to an input language.

(There are more Dutch-speaking people in Belgium than French-speaking, so IMO the default should be Dutch instead of French, but let's not make this into a quarrel between languages or regions -- we have enough of those already).

Most software gets this right (GIMP, Inkscape, Firefox, Thunderbird for example); I suppose they don't use GetKeyNameTextW. Perhaps it's better to simply translate those texts instead of querying Windows for the text?
Comment 5 Aron Budea 2016-09-09 14:41:41 UTC
Good to see the discussion, please continue in bug 100414.

*** This bug has been marked as a duplicate of bug 100414 ***