Bug Hunting Session
Bug 102024 - DOCX import: Checkbox produced by LibreOffice doesn't import again.
Summary: DOCX import: Checkbox produced by LibreOffice doesn't import again.
Status: RESOLVED DUPLICATE of bug 50097
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-ActiveX-Legacy
  Show dependency treegraph
 
Reported: 2016-09-09 17:55 UTC by Gülşah Köse
Modified: 2017-06-21 14:33 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gülşah Köse 2016-09-09 17:55:15 UTC
Reproduction steps:
1- Open writer
2- Check View->Toolbars->Form Controls
3- Select Checkbox from Form Controls toolbar
4- Create a checkbox
5- Save as docx
6- Close document and reopen that docx

Bug: Checkbox is ignored while docx import.
Expected behaviour: We should see checkbox in the document.
Comment 1 Julien Nabet 2016-09-10 20:58:47 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.
During saving, I noticed this on console:
(soffice:30649): Gdk-CRITICAL **: gdk_window_get_window_type: assertion 'GDK_IS_WINDOW (window)' failed
warn:legacy.osl:30649:1:sw/source/filter/ww8/wrtww8.cxx:792: Where is my ItemSet / pChpIter ?
warn:vcl:30649:1:vcl/source/outdev/map.cxx:704: Please record only relative MapModes!
warn:vcl:30649:1:vcl/source/outdev/map.cxx:704: Please record only relative MapModes!
warn:legacy.tools:30649:1:sfx2/source/control/statcach.cxx:407: setting state of dirty message

On loading docx, I got this:
warn:unotools.config:30797:1:unotools/source/config/configitem.cxx:431: ignoring XHierarchicalNameAccess to /org.openoffice.Office.Compatibility// Exception: 
warn:unotools.config:30797:1:unotools/source/config/configitem.cxx:431: ignoring XHierarchicalNameAccess to /org.openoffice.Office.Compatibility// Exception: 
warn:writerfilter:30797:1:writerfilter/source/dmapper/DomainMapper_Impl.cxx:573: no context of type 1 available
warn:writerfilter:30797:1:writerfilter/source/dmapper/DomainMapper_Impl.cxx:573: no context of type 1 available
warn:writerfilter:30797:1:writerfilter/source/dmapper/DomainMapper_Impl.cxx:573: no context of type 1 available
warn:svl:30797:1:svl/source/items/style.cxx:262: StyleSheet-Follow not found
warn:legacy.osl:30797:1:oox/source/helper/storagebase.cxx:67: StorageBase::StorageBase - missing base input stream
warn:legacy.osl:30797:1:vcl/source/image/ImageList.cxx:151: ImageAryData::Load: failed to load image 'cmd/lc_setoutline.png' from icon theme 'tango'
Comment 2 V Stuart Foote 2016-11-26 16:44:17 UTC
Confirmed on Windows 10 Pro 64-bit (1607) with

Version: 5.3.0.0.beta1 (x64)
Build ID: 690f553ecb3efd19143acbf01f3af4e289e94536
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; Layout Engine: new; 
Locale: en-US (en_US); Calc: CL

A sample document saved to OOXML .docx reopens without the checkbox. Same sample document saved to MS Office 97-2003 binary .doc opens showing a "legacy" checkbox and losses properties of the ODF element.

Sample document reopens fully intact and functional in ODF .odt format.

Looking at a round trip of sample document saved to MS binary .doc on filter import shows just the check box as:

vnd.oasis.opendocument.field.FORMCHECKBOX

While the ODF retains full form details for the control with:
ooo:com.sun.star.form.component.Form
ooo:com.sun.star.form.component.CheckBox
com.sun.star.form.control.CheckBox
Comment 3 Aron Budea 2017-06-21 14:33:50 UTC
Seems to be the same as bug 50097.

*** This bug has been marked as a duplicate of bug 50097 ***