Download it now!
Bug 102033 - Sidebar's settings control exposed without a label
Summary: Sidebar's settings control exposed without a label
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility
: 102155 (view as bug list)
Depends on:
Blocks: Sidebar-Tab-Bar Sidebar-Accessibility
  Show dependency treegraph
 
Reported: 2016-09-09 22:25 UTC by Yousuf Philips (jay) (retired)
Modified: 2019-03-01 16:44 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-09-09 22:25:02 UTC
Steps:
1) Start orca or nvda
2) Open writer
3) Access the sidebar with F6
4) Use the down arrow key to navigate to the settings control
5) Orca says 'Checkbox not checked' though the control has the 'Sidebar Settings' tooltip

Code pointer
http://opengrok.libreoffice.org/xref/core/sfx2/source/sidebar/TabBar.cxx#65

Version: 5.3.0.0.alpha0+
Build ID: f7513f0f53f2d074c08610a68fb787bb379c31d4
CPU Threads: 2; OS Version: Linux 3.19; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-09-02_23:58:05
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 Yousuf Philips (jay) (retired) 2016-09-13 13:57:01 UTC
*** Bug 102155 has been marked as a duplicate of this bug. ***
Comment 2 am_dxer 2016-09-13 15:22:18 UTC
I confirmed this bug because when you marked mine as a duplicate, I thought it would be alright if I confirmed the original bug as a duplicate since you had created it. Is this discouraged behavior?
Comment 3 am_dxer 2016-09-13 15:30:37 UTC
Sorry for the noise. I see what I did. I meant to confirm this bug and I guess I confirmed the other bug that you commented on.
Comment 4 Quentin Christensen 2017-10-24 05:21:40 UTC
Just confirming this issue still exists in Writer 5.4.2.2 (x64) on Windows 10 running NVDA 2017.3
Comment 5 QA Administrators 2018-10-25 03:03:01 UTC Comment hidden (obsolete)
Comment 6 Patrick ZAJDA 2019-03-01 16:44:45 UTC
I can reproduce this bug on Linux:
Version: 6.3.0.0.alpha0+
Build ID: f23738139429358c11fa62708fbdf5bb0c43d199
Threads CPU : 12; OS : Linux 4.19; UI Render : par défaut; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-02-28_20:14:57
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded

And on Windows:
Version: 6.3.0.0.alpha0+ (x64)
Build ID: 9c5dbbe4b0a62ff1af009beb00f1fc45318dad79
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-02-27_20:03:12
Locale: fr-FR (fr_FR); UI-Language: en-US
Calc: threaded