Bug 102051 - EDITING: find sentence or paragraph with too many words
Summary: EDITING: find sentence or paragraph with too many words
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.6.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Find-Search Word-Count
  Show dependency treegraph
 
Reported: 2016-09-10 19:59 UTC by Nick Levinson
Modified: 2016-10-24 21:48 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Levinson 2016-09-10 19:59:02 UTC
Stylistically, I sometimes write sentences and paragraphs that are too long for most readers, and I do this sometimes in very long documents. It would be helpful if I could locate all of the sentences and paragraphs that are too long. This is not about run-on sentences, which would require more sophistication in parsing the syntax. For a simpler solution, the user could set a separate word-count threshold for sentences and for paragraphs. The document should then auto-scroll on command (e.g., by a button) to show the next sentence or paragraph that's too long, for the user to edit or not.

This complements the enhancement proposed in bug 87628.

I use LO version 5.0.6.3 (build 00m0(Build:3) & locale en_US.UTF-8) on Linux, all kept evergreen.
Comment 1 m.a.riosv 2016-09-11 11:23:00 UTC
If I understand what you are requesting, search for long sentences it's easy if you enable regular expressions for search.

Instead of 'Find' use Menu/Edit/Find & Replace [Ctrl+H],
for search use '.{120,}' and mark in more options regular expression,
with that you can find sentences with more than 120 letters.

You can fin more on the help about regular expression:
https://help.libreoffice.org/Common/List_of_Regular_Expressions

Please if you are not agree reopen it.
Comment 2 Nick Levinson 2016-09-15 00:25:58 UTC
Disagree. That's not a method for ordinary mortals. Common users -- people who want to type a letter, print it, and enjoy lunch without learning computer arcana -- don't know about regex. If they find their way to it, it's intimidating to most people and complicated. And most people think of sentence or paragraph length in terms of numbers of words, not letters, and don't know that in ordinary English they should multiply a word count by 7 (including spaces etc.), and many people don't use ordinary English, like scholars and maybe playwrights.

I'm geeky, so I saw that your solution should work and is logical. (Regex failed on my computer but it used to work, so I assume there's a glitch not relevant to this report.)

A grammar or style checker in a menu would be a lot friendlier. It can use regex behind the scenes, but ordinary users should not have to use regex except as a last resort, and that's available already. Friendliness in the software will expand LO's acceptance and help in competing against Microsoft Office.
Comment 3 Heiko Tietze 2016-09-15 09:19:09 UTC
Sounds reasonable to me, paragraph and sentence length should be added to the English grammar checker with (editable) minimum and maximum values. Wonder if this hasn't been implemented in an extension.

And wasn't there a similar discussion recently, Stuart? (CC'ing)
Comment 4 m.a.riosv 2016-09-15 09:27:24 UTC
I don't think Ordinary Mortals are worried about how many words, letters or anything else on a paragraph.

They can know how many words or characters are in paragraph selecting it, on status bar, and clicking on it more information.

If you go to Menu/Tools/Options/Language Settings you can find
Comment 5 Nick Levinson 2016-09-17 18:28:41 UTC
I just wrote an essay over 40,000 words long, over 80 pages long. Using Writer without regex, how would I find which sentences or paragraphs are longer than some given number of words? Usually, I don't need to find out if a chosen sentence is too long; I need to find which sentences are too long. The feature should check the whole document (or a large selection).

Min and max are good ideas (typing a period where a comma was intended could produce a too-short sentence and max could find those) but I might call them something else to be clearer to ordinary users, like "too long" for maximum and "too short" for minimum, as that would clarify why you would want to set those parameters.

I didn't find a way to do the length evaluation in Tools > Options > Language Settings > Writing Aids and either (Writing Aids >) Available Language Modules > Lightproof Grammar Checker (English) or (Writing Aids >) Options. (Options >) Check Grammar As You Type is already checkmarked on and it's not doing this.
Comment 6 Yousuf Philips (jay) (retired) 2016-10-20 00:42:14 UTC
Definitely would be nice to make such a feature easily usable to beginners, but doubt such users would care for such a feature, which is why advanced users have access to regex. So i'd agree with m.a.riosv that it isnt a useful enough feature to have builtin to LO and more suitable as an extension.

@UX-Advice, @Regina, @Cor, @Stuart: What's your take?
Comment 7 Cor Nouws 2016-10-24 19:39:29 UTC
(In reply to Yousuf Philips (jay) from comment #6)

> users have access to regex. So i'd agree with m.a.riosv that it isnt a
> useful enough feature to have builtin to LO and more suitable as an
> extension.
> 
> @UX-Advice, @Regina, @Cor, @Stuart: What's your take?

+1 for m.a.riosv's take on this
Comment 8 V Stuart Foote 2016-10-24 20:00:16 UTC
Yes, this does not belong in core and should be done as a proper extension addressing these simpler metrics, and more ambitious WOPSE/TEKSTAT and readability scoring from bug 87628.
Comment 9 Yousuf Philips (jay) (retired) 2016-10-24 21:21:11 UTC
So i believe we've gotten a big enough consensus about this, so lets close it. If other ux-advise members disagree, we can discuss it at the weekly design meeting.