Download it now!
Bug 102061 - Mail merge: can`t select a data set anymore by creating a file from a database sheet. Only the first data set is used
Summary: Mail merge: can`t select a data set anymore by creating a file from a databas...
Status: RESOLVED DUPLICATE of bug 101841
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.2.1.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 101841
Blocks: Mail-Merge
  Show dependency treegraph
 
Reported: 2016-09-11 16:06 UTC by Rüdiger Hölscher
Modified: 2016-12-19 12:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
here are the 3 files that create the bug (162.32 KB, application/gzip)
2016-10-06 08:54 UTC, Rüdiger Hölscher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rüdiger Hölscher 2016-09-11 16:06:12 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0
Build Identifier: LibreOffice 5.2.1.2

If i try to save a file by printing a mail merge, i can`t select any data set from the database file anymore. No matter what data set i chose, the new file is built from the first row of the data chart.
The bug is new. Former release of libre office worked well.

Reproducible: Always

Steps to Reproduce:
1. connect writer document to a data source
2. print the writer document
3. klick selected records
4. "output": File" and "save as single document"
Actual Results:  
it does not matter what record you select, always the first is used for the new document.

Expected Results:  
The new document should be created with the chosen record

[Information automatically included from LibreOffice]
Locale: de
Module: TextDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes


Reset User Profile?No
Comment 1 Rüdiger Hölscher 2016-09-13 07:04:32 UTC
The bug occurs only by using one special combination data source - mail merge file. I try to find out, what the difference between the working and not working combinations is and will tell you here.
Comment 2 Jan-Marek Glogowski 2016-10-05 21:42:46 UTC
This seems to be very similar to bug 101841.

Since you see this problem in Linux, I hope we can find a way to reproduce the bug.

BTW: there is also bug 102010, which might be related.

And please check, if you really created a new file, just in case some other bug actually prevents writing a new output file.

Does it also happen, if you print it, for example to a PDF printer?
Comment 3 Rüdiger Hölscher 2016-10-06 06:38:51 UTC
I really created new files. The new file is a .odt file and it contains the data from the record of the first row even if I selected another one.

I tried to print it into a pdf file as you recommended, and the correct File was created.

You are right, it seem to be the same bug as 101841.
Comment 4 Jan-Marek Glogowski 2016-10-06 07:45:01 UTC
Please can you check, if current master fixes your bug too, by trying to reproduce the bug using a daily build available at http://dev-builds.libreoffice.org/daily/master/ ? More information about daily builds can be found at: http://wiki.documentfoundation.org/Testing_Daily_Builds

I already had a look, but nothing in the mail merge code area looks suspicious as a bugfix for your problem. There is something about broken DB change, but that's nothing, which would result in a "always first" bug?! I hope I can also reproduce the bug with 5.2, because it's really puzzling me, and I need to get this fixed too...
Comment 5 Rüdiger Hölscher 2016-10-06 07:56:22 UTC
woluld it help to send you the files, that create the bug?
Comment 6 Jan-Marek Glogowski 2016-10-06 08:13:31 UTC
It would be an other data point, so generally yes. Please attach them to the bug report. Be aware these files will be public! If you can create a reproducable, simplified test case, I could use it for a unit test, so this won't break again. I still have to reproduce the bug, when I have access to my 5.2 build at work next week.
Comment 7 Rüdiger Hölscher 2016-10-06 08:54:20 UTC
Created attachment 127833 [details]
here are the 3 files that create the bug
Comment 8 Norbert Fuhr 2016-12-13 10:57:47 UTC
This is really a nasty error: I am using this function for generating form letters.
 
As a workaround, I have to do this for the whole database, although I need it only for a single entry. Then I generate a PDF file only for the pages relating to the entry I am interested in - this also brakes sometimes when the file is too long.

I regard mailmerge as a central function for using libreoffice in a productive way, and this function is badly needed!!!
Comment 9 Jan-Marek Glogowski 2016-12-19 12:44:15 UTC

*** This bug has been marked as a duplicate of bug 101841 ***