Bug 102156 - Start center not navigational by keyboard when launched
Summary: Start center not navigational by keyboard when launched
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.6.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility, bibisected, bisected, regression
Depends on:
Blocks: a11y-Windows Start-Center
  Show dependency treegraph
 
Reported: 2016-09-13 13:28 UTC by am_dxer
Modified: 2018-02-20 18:22 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description am_dxer 2016-09-13 13:28:16 UTC
When launching LibreOffice, I cannot navigate between the controls in the Start dialog using the Tab key. I have to use Alt_Tab to navigate out of the window and then Alt_Tab again to cause the focus to be placed in the window again before I can navigate between the controls with the Tab key.
Comment 1 Yousuf Philips (jay) (retired) 2016-09-13 14:10:03 UTC
Yes i've seen this before and thought i had reported it, but i cant find the bug report. :D

On linux, the Open File button has focus when the start center appears and this would solve it.
Comment 2 Yousuf Philips (jay) (retired) 2016-09-13 14:37:52 UTC
workaround: press F6.
Comment 3 Thomas Hackert 2016-12-10 10:53:40 UTC
Hello am_dxer, *,
I cannot confirm your bug with

OS: Debian Testing AMD64
LO: Version: 5.3.0.0.beta1+
Build-ID: 1093721a260d25f986fd794acd914b8fb7bcf92a
CPU-Threads: 4; BS-Version: Linux 4.5; UI-Render: Standard; VCL: gtk2; Layout-Engine: neu; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-5-3, Time: 2016-12-10_03:55:11
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group
(parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel/Linux w/ de_DE lang- as well as helppack)

Would you be so kind to test it with a newer version of LO than 5.3.0.0.alpha0, please?
TIA
Thomas.
Comment 4 Yousuf Philips (jay) (retired) 2016-12-10 19:00:39 UTC
(In reply to thackert from comment #3)
> Would you be so kind to test it with a newer version of LO than
> 5.3.0.0.alpha0, please?

Hi Tomas,

This is a windows only bug as it doesnt happen in linux.

So this is a regression as it worked fine in 4.4 and is broken in 5.0.
Comment 5 am_dxer 2017-06-26 16:32:55 UTC
Can't reproduce in 5.0.0.2. Must be newer.
Comment 6 am_dxer 2017-06-26 18:05:53 UTC
Can't reproduce in Version: 5.1.0.0.alpha1+
Build ID: 87ac0b1e75a880a68ecb748bd4b34ae5a3d2ae98
Locale: en-US (en_US). Must be newer.
Comment 7 am_dxer 2017-06-27 13:20:33 UTC
bibisect-win32-5.1

# bad: [05d11632892a322664fb52bac90b2598b7fb7544] source sha:5616d22b57a9a5e57d545e912e029162a230829b
# good: [c1efd324c6ad448ac9edb030dc9738b9e6899e4d] source sha:ab465b90f6c6da5595393a0ba73f33a1e71a2b65
git bisect start 'origin/master' 'oldest'
# good: [97526ab777da7e58ce283c05498262ecdd4d6f7f] source sha:4ea70f87f7a2b61eda6e5ab1f48debf6fcfadc1f
git bisect good 97526ab777da7e58ce283c05498262ecdd4d6f7f
# good: [86fee7ded76d9c2756ccab6aef160a2d7fab0ab6] source sha:1b62841b1859ae3443e2bf1ebe99ec3d6afb6cc2
git bisect good 86fee7ded76d9c2756ccab6aef160a2d7fab0ab6
# bad: [11864a7db429a57aeea021e0b3f1fb1412282d32] source sha:e5b721a14c1c8e5261a70588b30353cbb5bd55c6
git bisect bad 11864a7db429a57aeea021e0b3f1fb1412282d32
# bad: [cec39174971f789b01d212afe8b5ffdd1ba466ca] source sha:76e75d2dd6dafe55fd1740693529640652ed6455
git bisect bad cec39174971f789b01d212afe8b5ffdd1ba466ca
# good: [a8a2139bffcee59cfb8887106ac3f9bc6569cf9a] source sha:1848581f4f3a3f22e2d104a2890699c26d35e1e8
git bisect good a8a2139bffcee59cfb8887106ac3f9bc6569cf9a
# bad: [51e0379831d38049a498ff5d6c70eb647c93dee8] source sha:ac630469789b8b1fd93d3ae90acae83ed463d756
git bisect bad 51e0379831d38049a498ff5d6c70eb647c93dee8
# good: [ac87de9d4ee0020419ad1961156de4ac0321ec02] source sha:7bcd8ed0faaefb8fe3783d6e31dea5c727eddc2a
git bisect good ac87de9d4ee0020419ad1961156de4ac0321ec02
# good: [f6420ff1264f1c468f3fbd5bf5429ff1b68b6b88] source sha:30cdd16cbfaaa34fd0da010bf4de18f9d649d22e
git bisect good f6420ff1264f1c468f3fbd5bf5429ff1b68b6b88
# good: [884b901996cd55a4df0bfce490d3e842a291868a] source sha:f99e8f84f5421076b6c0c10a592e43843eabd8ff
git bisect good 884b901996cd55a4df0bfce490d3e842a291868a
# bad: [1a5c56aa14e7b9a325cbb732a929b93eaebb7f1a] source sha:125f0c95b7f5613d71bcf107b73a0ba422d54643
git bisect bad 1a5c56aa14e7b9a325cbb732a929b93eaebb7f1a
# good: [77442162720ce0a97195319f3782dce9bdf9d33c] source sha:623f5b26ffd77041d0b06d7ce9c3b32d05625440
git bisect good 77442162720ce0a97195319f3782dce9bdf9d33c
# bad: [b52018ea405c53d0c3cf4cd465ffd1dc80dd15a1] source sha:9b322ace3b8f316104f7138b082d2ffdb282c816
git bisect bad b52018ea405c53d0c3cf4cd465ffd1dc80dd15a1
# good: [ad463231323943d069dae745ebc4b8eea2ced3ad] source sha:ce15c93cec284440244e63bea75a016e9f2c9f04
git bisect good ad463231323943d069dae745ebc4b8eea2ced3ad
# first bad commit: [b52018ea405c53d0c3cf4cd465ffd1dc80dd15a1] source sha:9b322ace3b8f316104f7138b082d2ffdb282c816
Comment 8 am_dxer 2017-06-27 14:02:47 UTC
The commit that introduced the regression was:

commit 9b322ace3b8f316104f7138b082d2ffdb282c816 (HEAD)
Author: Aybuke Ozdemir <aybuke.147@gmail.com>
Date:   Fri Oct 23 23:12:08 2015 +0300

    tdf#88548 fontwork gallery always have transparent/checkered background.
    
    Change-Id: I8995ef12edb64c14788ba3a2c3c1c2ceb3775b11

@Aybuke: do you have any ideas about this one?
Comment 9 am_dxer 2018-02-20 18:07:05 UTC
I can no longer produce this in 6.1.
Comment 10 V Stuart Foote 2018-02-20 18:22:32 UTC
Agree <Alt>+<Tab> window selection works correctly landing on StartCenter.
=> WFM

The issue of bug 102005 for F6 component cycling stopping in the Thumbnail views remains.