Download it now!
Bug 102211 - Writer UI : in the paragraph style pane, organizer tab, the contains field is inconsistent
Summary: Writer UI : in the paragraph style pane, organizer tab, the contains field is...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Paragraph-Dialog
  Show dependency treegraph
 
Reported: 2016-09-15 17:10 UTC by bug.reporter.21
Modified: 2019-06-25 07:28 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bug.reporter.21 2016-09-15 17:10:16 UTC
LO 5152
0S X 10.10.5

One behavior:
0) Create a new empty writer document
1) Open the paragraph style pane to edit the Caption style
2) Switch to the Organizer tab
3) The Contains field reads : Western Text: ... + 12pt + Italic + ...
4) Switch to Indent & Spacing tab
5) Change the before text indent to say 1 cm
6) Switch back to the Organizer tab
7) The Contains field now reads : Western Text: ... + 12pt + Italic + Indent left 1.0 cm ...

The inconsistent behavior: same points 1) )to 5)
0) Create a new empty writer document
1) Open the paragraph style pane to edit the Caption style
2) Switch to the Organizer tab
3) The Contains field reads : Western Text: ... + 12pt + Italic + ...
4) Switch to Indent & Spacing tab
5) Change the before text indent to say 1 cm
6') Press the Apply button           <====== HERE IS THE CHANGE
7') Switch back to the Organizer tab
8') The Contains field now is unexpectedly void

This might be related to the fact that sometimes this pane does not save style changes.
Comment 1 Octavio Alvarez 2016-09-18 08:01:58 UTC
Yes, same here. Looks like clicking "apply" does something that erases the "Contains" description.

Tested on Debian/Sid

Version: 5.1.3.1
Build ID: 1:5.1.3~rc1-1
CPU Threads: 4; OS Version: Linux 4.5; UI Render: default; 
Locale: en-US (en_US.utf8)
Comment 2 Ákos 2016-09-21 10:20:49 UTC
I can confirm in LO 5.2.1.2 32 bit (win10 Ent 64bit)
Comment 3 Buovjaga 2016-10-06 10:50:20 UTC
In 3.5 it becomes:
Shadow: Gray, not transparent, 0,18cm, No Shadow.

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 4 QA Administrators 2017-10-23 14:10:01 UTC Comment hidden (obsolete)
Comment 5 Roman Kuznetsov 2018-09-17 14:15:57 UTC
still repro in LibreOffice 6.1.1.1
Comment 6 Jim Raykowski 2019-06-20 23:33:26 UTC
Here is a patch made for Bug 125362 that also fixes this bug. 

https://gerrit.libreoffice.org/#/c/74325/

Confirmation, review, comments appreciated.
Comment 7 Buovjaga 2019-06-21 12:13:18 UTC
(In reply to Jim Raykowski from comment #6)
> Here is a patch made for Bug 125362 that also fixes this bug. 
> 
> https://gerrit.libreoffice.org/#/c/74325/
> 
> Confirmation, review, comments appreciated.

I confirm the fix

Arch Linux 64-bit
Version: 6.4.0.0.alpha0+
Build ID: ff6456b851cbe80f9fa03522c88699cc30ffcfb6
CPU threads: 8; OS: Linux 5.1; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 21 June 2019
Comment 8 Jim Raykowski 2019-06-21 21:23:52 UTC
Thank you Buovjaga for confirming. I will put this in.