Bug Hunting Session
Bug 102226 - Change of character kerning setting has no effect
Summary: Change of character kerning setting has no effect
Status: RESOLVED DUPLICATE of bug 105454
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: Font-Rendering HarfBuzz-regressions
  Show dependency treegraph
 
Reported: 2016-09-16 13:02 UTC by Johnny_M
Modified: 2017-02-28 15:00 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Kerning disabling example on Linux (LO 5.1.5) (117.21 KB, image/png)
2016-09-16 13:02 UTC, Johnny_M
Details
Kerning disabling example on Windows Vista (LO 5.2.1; Carlito and Caladea kerning always disabled due to different issue - bug 102224)) (107.76 KB, image/png)
2016-09-16 13:12 UTC, Johnny_M
Details
Writer file used for the test (10.39 KB, application/vnd.oasis.opendocument.text)
2016-09-16 13:13 UTC, Johnny_M
Details
Kerning disabling example on Windows Vista (LO 5.3.0.beta1) (109.88 KB, image/png)
2016-12-08 14:49 UTC, Johnny_M
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johnny_M 2016-09-16 13:02:32 UTC
Created attachment 127363 [details]
Kerning disabling example on Linux (LO 5.1.5)

As can be seen in the attached screenshot, disabling of kerning in the character properties (context menu -> Character... -> Position tab) does not actually disable it. It can be observed with "Te" in "Test" and "Ve" in "Version" in the text.

Observed with 64-bit Lunux Mint 17.1 (based on Ubuntu 14.04.1 LTS), where the additional fonts were installed by installing Ubuntu's ttf-mscorefonts-installer, fonts-crosextra-carlito and fonts-crosextra-caladea packages (manual installation triggering). LO as provided by its Ubuntu PPA:
Version: 5.1.5.2
Build ID: 1:5.1.5~rc2-0ubuntu1~trusty1
CPU Threads: 2; OS Version: Linux 3.13; UI Render: default; 
Locale: de-DE (en_GB.UTF-8); Calc: group

This does not seem to depend on the used font - tested with Carlito, Caladea, Areal and Liberation Sans.

Reproducible with Writer, Impress, Draw and Calc. Whereby character kerning is disabled by default in the latter and that's where it becomes visible.

==> The issue leads to different Calc text display on Linux and Windows with default character configuration.


On Windows, the situation is a bit different:
- LO 5.2.1 on Vista: Kerning disabling works for all fonts, while its enabling doesn't work for Carlito and Caladea, which is a different issue - see bug 102224.
- LO 5.0.5 on Vista (tested as portable release on machine with LO 5.2.1 installed): The current Linux issue existed here as well.
Comment 1 Johnny_M 2016-09-16 13:12:38 UTC
Created attachment 127365 [details]
Kerning disabling example on Windows Vista (LO 5.2.1; Carlito and Caladea kerning always disabled due to different issue - bug 102224))
Comment 2 Johnny_M 2016-09-16 13:13:28 UTC
Created attachment 127366 [details]
Writer file used for the test
Comment 3 Johnny_M 2016-09-16 13:50:59 UTC
The issue is also reproducible on 32-bit Debian (liveUSB) with:
Version: 5.2.3.0.0+
Build ID: 08f79e4686b97b8dae4acf0a804b8bbd1c29dd34
CPU Threads: 2; OS Version: Linux 4.3; UI Render: default; 
TinderBox: Linux-rpm_deb-x86@71-TDF, Branch:libreoffice-5-2, Time: 2016-09-09_09:34:52
Locale: en-US (en_US.UTF-8); Calc: group
Comment 4 Johnny_M 2016-10-21 11:53:06 UTC
Note: The Windows-to-Linux difference might be explained by the platform differences described in bug 89870 and other issues enumerated by its implementer in https://somefoobar.wordpress.com/2016/08/24/gsoc-project-comes-to-an-end/
Comment 5 Johnny_M 2016-12-08 14:49:12 UTC
Created attachment 129401 [details]
Kerning disabling example on Windows Vista (LO 5.3.0.beta1)

Version: 5.3.0.0.beta1
Build-ID: 690f553ecb3efd19143acbf01f3af4e289e94536
CPU-Threads: 2; BS-Version: Windows 6.0; UI-Render: Standard; Layout-Engine: neu;
Gebietsschema: de-DE (de_DE); Calc: group


Status after introduction of HarfBuzz on Windows (bug 89870): The behavior on Windows is now equal to the one on Linux. Therefore, I assume that this is a regression related to HarfBuzz introduction. 
Notes:
- HarfBuzz was introduced on Linux with LO 4.1 - see https://wiki.documentfoundation.org/ReleaseNotes/4.1#Core and on Windows and Mac with LO 5.3 - see https://wiki.documentfoundation.org/ReleaseNotes/5.3#Text_Layout
- The Areal font in the above test shows an always-off kerning for some reason. I'm not sure if its OS, LO version or font version dependent.

Indeed, tests with TDF builds on 32-bit Debian Linux reveal that:
- Following does not show the issue:
Version 4.0.6.2 (Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24

- Following does show the issue:
Version: 4.1.0.4
Build ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28
Comment 6 Khaled Hosny 2017-02-28 15:00:21 UTC

*** This bug has been marked as a duplicate of bug 105454 ***