Download it now!
Bug 102232 - FILESAVE: Crash in Confirm Format dialog when saving a file in the non-default format
Summary: FILESAVE: Crash in Confirm Format dialog when saving a file in the non-defaul...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility, wantBacktrace
Depends on:
Blocks: a11y-Windows
  Show dependency treegraph
 
Reported: 2016-09-16 18:25 UTC by am_dxer
Modified: 2018-01-30 20:45 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description am_dxer 2016-09-16 18:25:58 UTC
Steps to reproduce:
1. Open a file containing data. (I tried xlsx and xls.)
2. Press Control+s to save the file.
3. Select use XLS or XLSX in the Confirm Format dialog.
4. The program crashes most of the time. It seems like once in a while the program doesn't crash and I am returned to the spreadsheet but for me the crash occurs much more frequently.

I am adding accessibility to this in the hopes that someone can confirm whether this crash also occurs when accessibility is disabled. I tested with NVDA 2016.3 and Windows 10.
Comment 1 am_dxer 2016-09-16 18:31:42 UTC
I forgot to add that this crash doesn't occur if Warn When not Saving in ODF or Default Format is unchecked in Options>Load/Save>General
Comment 2 Julien Nabet 2016-09-16 19:24:25 UTC
It could be useful you retrieve a backtrace (see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace)
Comment 3 am_dxer 2016-09-17 13:39:25 UTC
Did you try with the NVDA screen reader enabled? You can download this from www.nvda-project.org and it is free and open source. I tried deleting my user profile for LibreOffice and I can still reproduce this bug.
Comment 4 Yousuf Philips (jay) (retired) 2016-09-17 15:24:40 UTC
Wasnt able to reproduce this with Orca 3.20 or NVDA 2016.3. If this happens on a particular xls or xlsx file, please submit it so we can test against it.

Would assume this isnt a11y related. If you are able to reproduce the crash on libreoffice 5.2.1, then after it crashes, libreoffice will prompt you to send in a crash report, so please do so and then we'll be able to track down the issue.

Version: 5.3.0.0.alpha0+
Build ID: 78404fe5549fded2eaf0c5ea6e1ca66039e995af
CPU Threads: 2; OS Version: Linux 3.19; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-09-11_09:14:01
Locale: en-US (en_US.UTF-8); Calc: group
Comment 5 am_dxer 2016-09-17 18:41:49 UTC
The crash doesn't occur in the 5.2 version. I had someone sightred test with NVDA disabled on this Windows machine and the crash does not occur in the 5.3 version. The key to causing the crash in nVDA for me is ensuring that an existing document is used. The crash will not occur if it is the first save of a new document. The crash even occurrs if I save a spreadsheet with the text test in cell aq and then close and reopen that and save it.
Comment 6 Yousuf Philips (jay) (retired) 2016-09-17 19:03:14 UTC
Which windows version are you using? Can you ask the sighted person to test 5.3 with NVDA and see if they can confirm it? If he/she is able to confirm it, ask them to follow the instructions below to obtain a backtrace.

https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg
Comment 7 V Stuart Foote 2016-09-17 20:22:31 UTC
Using STR I confirm crash on Windows 10 Pro 64-bit en-US (v.1607) with
NVDA 2016.3 and LibreOffice master
Version: 5.3.0.0.alpha0+
Build ID: 681d5fd37e469491268d40147c621187dc6f4b95
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-09-10_06:06:09
Locale: en-US (en_US); Calc: group

attempt to check with TB39 that should have symbols available.
Version: 5.3.0.0.alpha0+
Build ID: d5fab973d0af95c433c5f6a9492014f7db642489
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-08-24_00:07:50
Locale: en-US (en_US); Calc: CL

But, seems NVDA 2016.3 on Windows 10 Pro "anniversary update", e.g. ver 1607 is not especially stable.

NVDA freezes all reading activity when attempting to open LibreOffice.

@Jamie, Mick -- any insight?
Comment 8 V Stuart Foote 2016-09-17 20:41:16 UTC
Opened an NVACCESS issue against NVDA

https://github.com/nvaccess/nvda/issues/6385
Comment 9 am_dxer 2016-09-27 15:43:19 UTC
The Windows computers that I have access to were downgraded to Windows 7 due to software incompatibilities. I can confirm that the issue did occur with NVDA before and after the Anniversary update. It does not occur in Windows 7 which I tested after the machines were downgraded. I can't do any further testing on this issue in Windows 10 because I do not personally own any Windows computers.
Comment 10 am_dxer 2016-09-27 15:45:38 UTC
I am not able to reproduce this on my personal laptop with Orca that runs BSD.
Comment 11 Alex ARNAUD 2017-07-17 14:17:57 UTC
Dear all,

It looks like it is a Windows specific issue. I move the a11y tag to a11y-Windows and change the targeted platform.

Best regards.
Comment 12 Julien Nabet 2018-01-29 13:20:43 UTC
About NVDA, https://github.com/nvaccess/nvda/issues/6385 has been closed.
another bugtracker https://github.com/nvaccess/nvda/issues/7631 had been opened and finally closed.

Any better with last stable LO version 5.4.4 + last stable nvda 2017.4 ?
As usual, if someone still reproduces this, a debug bt could be useful
Comment 13 Xisco Faulí 2018-01-30 10:51:33 UTC
(In reply to Julien Nabet from comment #12)
> About NVDA, https://github.com/nvaccess/nvda/issues/6385 has been closed.
> another bugtracker https://github.com/nvaccess/nvda/issues/7631 had been
> opened and finally closed.
> 
> Any better with last stable LO version 5.4.4 + last stable nvda 2017.4 ?
> As usual, if someone still reproduces this, a debug bt could be useful

@Alex ARNAUD, @V Stuart Foote, Do you still reproduce this issue in 5.4.4 and the latest stable verion of nvda ?
Comment 14 V Stuart Foote 2018-01-30 20:45:25 UTC
(In reply to Xisco Faulí from comment #13)

> @Alex ARNAUD, @V Stuart Foote, Do you still reproduce this issue in 5.4.4
> and the latest stable verion of nvda ?

With NVDA 2017.3 on Windows 10 Enterprise 64-bit en-US--no issues with 6.0.0.3, nor with /a admin installs of 5.4.4.2 or 6.1.0alpha1+ master.

=> WFM