Download it now!
Bug 102252 - Impress hangs on .odp save
Summary: Impress hangs on .odp save
Status: RESOLVED DUPLICATE of bug 101898
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.2.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-18 03:34 UTC by E. Wayne Johnson
Modified: 2016-09-18 22:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description E. Wayne Johnson 2016-09-18 03:34:31 UTC
When trying to save any presentation in impress in the .odp format, the program displays "save document" at the bottom of the screen and hangs in a tight loop.  

Saving in other format such as .ppt or .pptx are no problem.
Comment 1 Jean-Baptiste Faure 2016-09-18 06:17:36 UTC
Not reproducible for me with version 5.2.3.0+ under Ubuntu 16.04 x86-64

What is your Linux distribution ? Did you install LO 5.2.1 from your distribution repository or from LibreOffice website ?

When you write "any presentation" does that mean an empty presentation too ?

Set status to NEEDINFO, please set it back to UNCONFIRMED once requested
informations are provided.

Best regards. JBF
Comment 2 E. Wayne Johnson 2016-09-18 10:22:03 UTC
My distribution is Slackware64 -current with the 4.20 kernel.

http://www.slackware.com/changelog/current.php?cpu=x86_64

I have tried the LibreOffice build from source from SlackBuilds, the rpms from the LibreOffice website,

and the packages from "Alien Bob".   I have also tried a LibreOfficeDev5.3 from the LO -current development repository.

All installations express the same behaviour.

I have also reformatted the root partition and reinstalled Slackware64 -current in case something had been damaged.

None of those fixed the problem.

I have communicated this bug to the LinuxQuestions Slackware community and no one has yet said that they experience this problem.

When I try to save a presentation, whether an empty Untitled 1.odp or one with content I create, or previously saved presentation in any format

the result is the same.  When I try to "save" or "save as" there is a hang if I use the .odp format. 

If there is some other format like .ppt or .pptx there is no problem with saving.

I have used LibreOffice for more than 2 years and have followed the upgrade paths closely in that time.

This is the first time I have seen this problem.

I don't know how to get any debug information from soffice to see more about what is happening.
Comment 3 Jean-Baptiste Faure 2016-09-18 10:39:44 UTC
What happens if you try with a new clean user profile ? 
https://wiki.documentfoundation.org/UserProfile

Best regards. JBF
Comment 4 E. Wayne Johnson 2016-09-18 13:01:40 UTC
I tried renaming the userprofile and also tried deleting the .config/libreoffice directory and neither were able to solve this problem.

All other features of impress seem to be working ok and other components of libreoffice are able to save files quite normally.
Comment 5 Aron Budea 2016-09-18 18:44:33 UTC
This is eerily similar to bug 101898. Possible duplicate?
Comment 6 Ofir 2016-09-18 20:32:18 UTC
Aron:I can confirm that Impress hangs for me when saving .odp.
Saving .pptx works fine.

Looks like the same issue.
In my report I also attached a gdb backtrace.
Comment 7 E. Wayne Johnson 2016-09-18 20:38:54 UTC
Yes this is a similar problem to the one reported in bug 101898.

But it's not me reporting the other one.

How can I help more in diagnosing this problem and what can I do to fix my problem?
Comment 8 E. Wayne Johnson 2016-09-18 20:39:26 UTC Comment hidden (obsolete)
Comment 9 Aron Budea 2016-09-18 22:06:13 UTC
Let's continue the discussion in the other report.

*** This bug has been marked as a duplicate of bug 101898 ***