Bug 102260 - Make Paste unformatted text work in Calc
Summary: Make Paste unformatted text work in Calc
Status: RESOLVED DUPLICATE of bug 50746
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval, topicUI
Depends on:
Blocks: UNO-Command-New Paste
  Show dependency treegraph
 
Reported: 2016-09-18 18:42 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-08-31 15:27 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-09-18 18:42:47 UTC
Paste unformatted (.uno:PasteUnformatted) works in Wrtier, Impress and Draw, but not in Calc, so it would be good that it be extended to also work here.
Comment 1 m.a.riosv 2016-09-18 21:13:59 UTC
Maybe because in calc works in a different way, showing the text import box, not pasting the unformatted text directly.
Comment 2 Yousuf Philips (jay) (retired) 2016-09-19 01:52:56 UTC
If you open up the menu portion of the paste split button in the toolbar, you will see paste unformatted text, which is where i would believe the uno command pulls the text from.
Comment 3 m.a.riosv 2016-09-19 13:44:58 UTC
Sure, but in calc if the clipboard has more than one line, then 'Text import' window comes up. It always was so, inherited from OOo.
What is a different behavior than other components.

Maybe would be nice having calc's behavior with other components, with two options on the split button instead one, for all components:
- Unformatted text. ->To past directly only the text,
- Text import. -> To get the 'Text import' window, making available to past as table.
Comment 4 Cor Nouws 2016-09-20 08:39:29 UTC
I use Ctrl+Shft+V every day in Calc..
Ah yes, then I type U ( select Unformatted )
Comment 5 Yousuf Philips (jay) (retired) 2017-08-31 15:27:41 UTC

*** This bug has been marked as a duplicate of bug 50746 ***