Bug 102271 - Emoji drop-down menu is empty
Summary: Emoji drop-down menu is empty
Status: RESOLVED DUPLICATE of bug 105689
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0
Keywords:
Depends on: HarfBuzz
Blocks: Font-Rendering Emoji-Button
  Show dependency treegraph
 
Reported: 2016-09-19 07:39 UTC by kompilainenn
Modified: 2017-05-27 16:01 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
empty emoji drop-down menu (5.66 KB, image/png)
2016-09-19 07:39 UTC, kompilainenn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kompilainenn 2016-09-19 07:39:58 UTC
Created attachment 127422 [details]
empty emoji drop-down menu

on Windows new emoji drop-down menu from icon Emoji on Standart toolbar is empty 

see attach
Comment 1 kompilainenn 2016-09-19 07:40:19 UTC
Version: 5.3.0.0.alpha0+
Build ID: 8697d18f717c75ddeedfe08161091da71007b859
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-09-15_02:55:18
Locale: ru-RU (ru_RU); Calc: group
Comment 2 Buovjaga 2016-10-12 10:58:43 UTC
Confirmed. It is not empty on Linux, I tried.

Note for testers: you have to customize the Standard toolbar and enable the emoji button.

Win 7 Pro 64-bit Version: 5.3.0.0.alpha0+
Build ID: e2f6c7f0d0cc14f851d7028ff846c5dc658a81c6
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-10-10_23:08:02
Locale: fi-FI (fi_FI); Calc: group
Comment 3 V Stuart Foote 2016-10-13 23:04:58 UTC
It is a font fallback issue...

On Windows LibreOffice UI is exclusively using system font, Segoe UI (On 8, 8.1 and 10). 

And the problem is Segoe UI has no coverage of the SMP Unicode blocks handled by emoji.json:

"Miscellaneous Symbols and Pictographs" 1f300 - 1f5ff
"Emoticons" 1f600 - 1f64f
"Ornamental Dingbats" 1f650 - 1f67f
"Transport and Map Symbols" 1f680 - 1f6f3

Rather, these are mostly covered in other Segoe UI family fonts-- Segoe UI Symbol and Segoe UI Emoji.  Noto Symbol and Symbola cover the ranges, but LibreOffice on Windows builds does not fall back to any of those fonts. The mangled fallback affects both OpenGL with DirectWrite (WinLayout) and GDI DirectWrite (SimpleWinLayout)--Tor L and Chris S have been chasing this for months. Maybe the Harfbuzz work (bug 89870) will also resolve this.

On Linux boxes coverage is often provided by a NOTO install or likewise installing Symbola (apt-get install ttf-ancient-fonts, or yum install gdouros-symbola-fonts).

George Douros provides license free Symbola font (v.9) here: 
http://users.teilar.gr/~g1951d/Symbola.zip

DejaVu Sans has limited coverage of the Emoticons--but again no fallback occurs from system Segoe UI.

Note -- you can force use of the Segoe UI Symbol or Emoji (same coverage in these ranges) by setting a font substitution replacing Segoe UI with Segoe UI Symbol (or Emoji). The system font does fall back from the symbols/emoji font so menus and dialogs are well formed--while retaining the glyphs.
Comment 4 Khaled Hosny 2016-11-16 06:21:15 UTC
Is this still an issue?
Comment 5 V Stuart Foote 2016-11-16 06:28:58 UTC
With HrfBuzz layout engine, fully populated with either default or OpenGL rendering.
Comment 6 V Stuart Foote 2016-11-16 06:50:43 UTC

*** This bug has been marked as a duplicate of bug 92940 ***
Comment 7 V Stuart Foote 2017-05-27 15:49:49 UTC

*** This bug has been marked as a duplicate of bug 105689 ***