Bug 102348 - Formatting Marks: Visual difference between space and non-breaking space
Summary: Formatting Marks: Visual difference between space and non-breaking space
Status: RESOLVED DUPLICATE of bug 58434
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Formatting-Mark
  Show dependency treegraph
 
Reported: 2016-09-22 03:24 UTC by Yousuf Philips (jay) (retired)
Modified: 2022-02-22 12:11 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of BabelPad showing spaces only (51.17 KB, image/jpeg)
2021-04-18 21:33 UTC, Ulrich Windl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-09-22 03:24:26 UTC
Both space and non-breaking space use the same dot character (ascii 183) when formatting marks are enabled and it would be useful to differentiate the non-breaking space with a different character. It would be useful to stay with a dot character, so maybe a period (ascii 46) or alternatively the degree sign (ascii 176) like MS Word.
Comment 1 Heiko Tietze 2016-09-22 08:40:15 UTC
Non-breaking space is applied as field and get a gray background with field shading (ctrl+F8). WORKSFORME
Comment 2 Yousuf Philips (jay) (retired) 2016-09-22 16:58:02 UTC
It is incorrectly linked with field shading (bug 58434) and instead of a gray shading, it should simply have a different character.
Comment 3 Ulrich Windl 2017-02-01 09:42:49 UTC
An enhancement to comment #0:
> Both space and non-breaking space use the same dot character (ascii 183)
> when formatting marks are enabled and it would be useful to differentiate
> the non-breaking space with a different character. It would be useful to
> stay with a dot character, so maybe a period (ascii 46) or alternatively the
> degree sign (ascii 176) like MS Word.

Other spaces (like Unicode "EM SPACE") produce no formatting mark at all. Maybe these could be displayed as a "empty tray-like symbol", and as there are many spaces, maybe some explanation when hovering with the mouse over the mark could be used (that could be extended to the existing marks as well).
Or, maybe, do it like BabelPad: Explain the character in the status line.
Comment 4 Xisco Faulí 2020-03-09 13:28:13 UTC
Please add keyword 'needsUXEval' and CC 'libreoffice-ux-advise@lists.freedesktop.org' if input from UX is needed.
Comment 5 Gabriele Ponzo 2021-04-16 16:05:00 UTC
(In reply to Ulrich Windl from comment #3)
> 
> Other spaces (like Unicode "EM SPACE") produce no formatting mark at all.
> Maybe these could be displayed as a "empty tray-like symbol", and as there
> are many spaces, maybe some explanation when hovering with the mouse over
> the mark could be used (that could be extended to the existing marks as
> well).
> Or, maybe, do it like BabelPad: Explain the character in the status line.

I do subscribe that a different character and possibly a tooltip when hovering the mouse pointer on all special marks would be really useful, especially for novice users, may be preventing them from making a mess for not understanding.

A specific character could be enough as far as a recap table could be provided in the help and documentation. The tooltip would be the best, probably going beyond the other wordprocessing softwares ;)
Comment 6 Ulrich Windl 2021-04-18 21:33:19 UTC
Created attachment 171273 [details]
Screenshot of BabelPad showing spaces only

(In reply to Ulrich Windl from comment #3)
> Or, maybe, do it like BabelPad: Explain the character in the status line.

Just in case nobody knows BabelPad or does not know what I meant:
The screen shot shows the cursor in the middle of different spaces, and on the bottom line BabelPad explains the glyph where the cursor is.
I highlighted those (Yellow).
Comment 7 V Stuart Foote 2021-04-18 21:56:58 UTC
Work on bug 58434 to move the full range of formatting marks out of the <Ctrl>+F8 Field shading and into the <Ctrl>+F10 'Non-printing character' highlighting offers the most likely approach.

Full spaces (U+0020) would still receive the "blue dots" or the Harfbuzz handled layout, other NPC including the U+2000-200F marks would receive field shading corresponding to font metrics for the non-visible characters.  Idealy in a color other than the grey of the field shading, or even from the "Solarized Blue" used for the <space>, Paragrah (U+204B), and VCL page margins.
Comment 8 Heiko Tietze 2022-02-22 12:11:01 UTC
(In reply to V Stuart Foote from comment #7)
> Work on bug 58434 to move the full range of formatting marks out of the
> <Ctrl>+F8 Field shading and into the <Ctrl>+F10 'Non-printing character'
> highlighting offers the most likely approach.

Concur, let's make this one a duplicate.

*** This bug has been marked as a duplicate of bug 58434 ***