Download it now!
Bug 102368 - FILESAVE: data list with comma "," saved as *.xlsx give wrong data list
Summary: FILESAVE: data list with comma "," saved as *.xlsx give wrong data list
Status: RESOLVED DUPLICATE of bug 90104
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.4.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-22 18:09 UTC by VLB
Modified: 2017-10-22 08:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
test file (7.88 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-09-24 12:44 UTC, VLB
Details
Screenshot (100.74 KB, application/vnd.oasis.opendocument.text)
2016-09-24 12:55 UTC, VLB
Details
A file with validity list in A1 having a "2,3" item (7.91 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2016-12-01 20:00 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description VLB 2016-09-22 18:09:36 UTC
wi 10 64 bit LO 5.2.1.2

Howe to reproduce:

1) open file "Geldigheid.ods"
2) look at cell A1 and is make a data list with 2 rows "21,8" and "45"
3) save file as *.xslx and close file
4) open file in excel 2010 and see there are in the data list 3 rows in cell A1 "21", "8" and "45"

I hope this issue is solve.
Comment 1 Bartosz 2016-09-23 20:54:54 UTC
Please attach "Geldigheid.ods" file.
Could you please attach screenshot which compare behaviour on Excel and LO?
Comment 2 VLB 2016-09-24 12:44:07 UTC
Created attachment 127611 [details]
test file
Comment 3 VLB 2016-09-24 12:55:01 UTC
Created attachment 127612 [details]
Screenshot
Comment 4 Bartosz 2016-09-25 20:35:06 UTC
I could confirm bug with .xlsx file format.
The bug doesn't exists with .xls file format.
Comment 5 VLB 2016-11-03 18:26:33 UTC
(In reply to Bartosz from comment #4)
> I could confirm bug with .xlsx file format.
> The bug doesn't exists with .xls file format.

Is this bug resolved for LO 5.3?
Comment 6 Mike Kaganski 2016-12-01 20:00:34 UTC
Created attachment 129197 [details]
A file with validity list in A1 having a "2,3" item

This is a complex problem.
1. When saving the file from LO, it creates the following items in sheetN.xml:
>  <dataValidations count="1">
>    <dataValidation allowBlank="true" operator="equal" showDropDown="false" showErrorMessage="true" showInputMessage="false" sqref="A1" type="list">
>      <formula1>&quot;1,2,3,4&quot;</formula1>
>      <formula2>0</formula2>
>    </dataValidation>
>  </dataValidations>

2. When opening in Excel 2013, correcting and saving back, it saves this:
>  <dataValidations count="1">
>    <dataValidation type="list" operator="equal" allowBlank="1" showErrorMessage="1" sqref="A1">
>      <mc:AlternateContent xmlns:x12ac="http://schemas.microsoft.com/office/spreadsheetml/2011/1/ac" xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006">
>        <mc:Choice Requires="x12ac">
>          <x12ac:list>1,"2,3",4</x12ac:list>
>        </mc:Choice>
>        <mc:Fallback>
>          <formula1>"1,2,3,4"</formula1>
>        </mc:Fallback>
>      </mc:AlternateContent>
>    </dataValidation>
>  </dataValidations>

Note that it uses x12ac:list, which is discussed here: https://msdn.microsoft.com/en-us/library/documentformat.openxml.office2010.excelac.list.aspx - and it is only available since v.2013.

When opening the above Excel-saved file in LO, it doesn't import validity condition (incl.list) properly (test the attachment).

3. I don't have Excel 2010 to test, but testing with Excel 2007, it seems to be unable to create such items itself, so possibly it's missing functionality in versions prior to 2013.
Comment 7 Martin Spacek 2017-08-04 22:35:46 UTC

*** This bug has been marked as a duplicate of bug 90104 ***