Bug 102498 - Filesave: hang on save as .doc for a specific .odt
Summary: Filesave: hang on save as .doc for a specific .odt
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc
Depends on:
Blocks: DOC
  Show dependency treegraph
 
Reported: 2016-09-24 10:26 UTC by Timur
Modified: 2019-10-03 14:09 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
odt that hangs when saved as doc (73.04 KB, text/odt)
2016-09-24 10:27 UTC, Timur
Details
backtrace master 5.3 - svllo (11.81 KB, text/plain)
2016-09-24 10:28 UTC, Timur
Details
backtrace master 5.3 - atioglxx (13.52 KB, text/plain)
2016-09-24 10:28 UTC, Timur
Details
dump with master 5.3 - atioglxx - other crash (8.66 KB, text/plain)
2016-09-24 10:29 UTC, Timur
Details
odt that hangs when saved as doc - reduced (35.61 KB, text/odt)
2016-09-24 11:00 UTC, Timur
Details
backtrace - msvcp120 (11.31 KB, text/plain)
2016-09-24 11:01 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2016-09-24 10:26:27 UTC
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build Identifier: master

Had crashdump with atioglxx, attached. 
Then had s reproducible hang with 5.2. and master when .odt saved as .doc. Bactraces attached, hope they are helpfull, svllo and atioglxx.

Reproducible: Always







Reset User Profile?
Comment 1 Timur 2016-09-24 10:27:16 UTC
Created attachment 127605 [details]
odt that hangs when saved as doc
Comment 2 Timur 2016-09-24 10:28:06 UTC
Created attachment 127606 [details]
backtrace master 5.3 - svllo
Comment 3 Timur 2016-09-24 10:28:33 UTC
Created attachment 127607 [details]
backtrace master 5.3 - atioglxx
Comment 4 Timur 2016-09-24 10:29:25 UTC
Created attachment 127608 [details]
dump with master 5.3 - atioglxx - other crash
Comment 5 Timur 2016-09-24 11:00:18 UTC
Created attachment 127609 [details]
odt that hangs when saved as doc - reduced

This reduced odt still hangs with 5.2 and master, but it doesn't hang with OO.
It seems to produce a different backtrace, which I'll also attach. 
Finally, it's not clear whether this is "save as doc" bug or some graphics or msvcp120 bug that I experience lately.
Comment 6 Timur 2016-09-24 11:01:34 UTC
Created attachment 127610 [details]
backtrace - msvcp120
Comment 7 m.a.riosv 2016-09-24 11:46:37 UTC
Seems that table 'table48' is the source of the issue, deleting it saves fine for me.

Win10x64
Version: 5.2.2.2 (x64)
Build ID: 8f96e87c890bf8fa77463cd4b640a2312823f3ad
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL; 
Locale: es-ES (es_ES); Calc: CL
Comment 8 Timur 2016-09-24 13:13:44 UTC
Thank you for confirming. When I tried to reduce this, even deleting chart or footnote or header/footer prevented crash. 
Anyway, I'm not clear about those different backtraces, feel free to link appropriate bugs for atioglxx and msvcp120.
Comment 9 Timur 2016-12-20 12:47:57 UTC
Xisco, please take a look on those different backtraces, now it's even sth. else.
Comment 10 Timur 2017-05-04 09:08:23 UTC
attachment 127605 [details] hangs with 5.2.6 and 5.3.1 but doesn't hang on save as DOC now with 5.3.2 and 5.4+.
So I'll set this one to WFM. 
But, it shows 20 pages in LO and 24 on RT DOC with 5.4+, layout is changed.
Comment 11 Timur 2017-05-04 09:25:40 UTC
Fixed in 5.2.7, maybe a duplicate of Bug 101178.