Bug 102499 - WebDAV ucp provider: Add management of unofficial HTTP response status codes
Summary: WebDAV ucp provider: Add management of unofficial HTTP response status codes
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Giuseppe Castagno (aka beppec56)
URL:
Whiteboard: target:5.3.0 target:7.3.0 inReleaseNo...
Keywords:
: 69998 (view as bug list)
Depends on:
Blocks: WebDAV
  Show dependency treegraph
 
Reported: 2016-09-24 13:53 UTC by Giuseppe Castagno (aka beppec56)
Modified: 2022-01-26 13:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Giuseppe Castagno (aka beppec56) 2016-09-24 13:53:04 UTC
Checking the current behavior of bug 90700, I found that LO receives the HTTP response status code "522 Connection timed out" while accessing the URL reported in bug 90700, comment 3.
That code sits outside the official assigned range as described in <https://tools.ietf.org/html/rfc7231#section-6>, in <https://tools.ietf.org/html/rfc4918#section-11> and in <https://tools.ietf.org/html/rfc7725#section-3>
RFC7231 applicable excerpt:
"
...
HTTP status codes are extensible.  HTTP clients are not required to
understand the meaning of all registered status codes, though such
understanding is obviously desirable.  However, a client MUST
understand the class of any status code, as indicated by the first
digit, and treat an unrecognized status code as being equivalent to
the x00 status code of that class, with the exception that a
recipient MUST NOT cache a response with an unrecognized status code.
...
"
At the moment LO does not implement this default remapping. 
As a further reference Wikipedia has some description too: <https://en.wikipedia.org/wiki/List_of_HTTP_status_codes#Unofficial_codes>.

This bug is meant to be an anchor point for all the changes needed to make LO behave well to unofficial HTTP response status code.

First there will be a general implementation, as suggested by RFC; then one more to the point, whenever the status code is clearly described.
For example a description as in: <https://support.cloudflare.com/hc/en-us/sections/200820298-Error-Pages>.

All links where retrieved on 2016-09-24.
Comment 1 Commit Notification 2016-09-25 10:59:01 UTC
Giuseppe Castagno committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e62c02a089e454eeea472e758e113e7e28568a02

tdf#102499 (1): Add WebDAV test to check HTTP reponse status codes retry

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 2 Commit Notification 2016-09-26 11:05:10 UTC
Giuseppe Castagno committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ac060f97cc937787b4079e435c5b312f6894c277

tdf#102499 (2): Refactor the WebDAV resource access retry

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2016-10-05 12:12:14 UTC
Giuseppe Castagno committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f423a9d695814b1babf5f2c3f42821190adc7e53

tdf#102499 (3): Change caching model for HTTP response status code

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2016-10-06 07:21:04 UTC
Giuseppe Castagno committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a9f820679a70ec3fc4fe4f43c8fed175b362d1fd

Related: tdf#102499 (4), default css::ucb::XCommandEnvironment.

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2016-10-11 06:07:50 UTC
Giuseppe Castagno committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=16df731a30917a426df81d751a0bfd0ae5fcdd45

tdf#102499 (5): Deal with HTTP unofficial response status codes

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2016-10-12 19:22:54 UTC
Giuseppe Castagno committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1ca68d386bc0345240bf288bec023faaba2e07af

tdf#102499 (6): Cache OPTIONS if not present or if lifetime different

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2016-10-13 12:29:27 UTC
Giuseppe Castagno committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=97cc70d7285526ae2ee3b3bac425eb031c4c0321

tdf#102499 (7): Caching connect timeout or cannot connect.

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2016-10-21 17:50:22 UTC
Giuseppe Castagno committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bb27b2ff87e534b6f4fb9583271db29d6bbae8b6

tdf#102499 (8): Return empty property when not present.

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2016-10-21 17:54:48 UTC
Giuseppe Castagno committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=59d6d5579528a66e55b75987d2d959968db485a8

tdf#102499 (9): Fix eXo Platform WebDAV on 'Save Remote File'

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Xisco Faulí 2017-07-14 13:17:57 UTC
Polite ping: is this bug fixed? if so, please close it as RESOLVED FIXED
Comment 11 Xisco Faulí 2017-10-17 08:23:20 UTC
*** Bug 69998 has been marked as a duplicate of this bug. ***
Comment 12 Xisco Faulí 2018-01-16 09:39:55 UTC
A polite ping to Giuseppe Castagno (aka beppec56): is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Thanks
Comment 13 Xisco Faulí 2018-04-18 15:33:16 UTC
Putting to RESOLVED FIXED.

@Giuseppe Castagno, please reopen this issue if it's not completely fixed!!
Comment 14 Commit Notification 2021-11-01 17:50:09 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2785402a4b47cb4d5764d0ad9f1554b579a9e5d2

ucb: webdav-curl: tdf#102499 (1): Add WebDAV test to check HTTP reponse status

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2021-11-01 17:50:19 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b3fc6caf392809d844e84f6a36db6a0fe3111c39

ucb: webdav-curl: tdf#102499 (2): Refactor the WebDAV resource access retry

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2021-11-01 17:52:02 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e3c2294c351892ca864f7dd5827dbe04cfcc8021

ucb: webdav-curl: tdf#102499 (3): Change caching model for HTTP response status code

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2021-11-01 17:53:15 UTC
Giuseppe Castagno committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2afb51076c3f766ab39cbfc66d8469889a2b0a5c

ucb: webdav-curl: tdf#102499 (5): Deal with HTTP unofficial response status codes

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2021-11-01 17:53:26 UTC
Giuseppe Castagno committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/805a4e9d3e03e1339e9149fa745ac14fe334ccdf

ucb: webdav-curl: tdf#102499 (6): Cache OPTIONS if not present or if lifetime different

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2021-11-01 17:53:37 UTC
Giuseppe Castagno committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2346a19dfeba7f0f2082888ab76c1c731e9e591c

ucb: webdav-curl: tdf#102499 (7): Caching connect timeout or cannot connect.

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2021-11-01 17:54:49 UTC
Giuseppe Castagno committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3665527ea9f003830eb47ecd221a950c35caf731

ucb: webdav-curl: tdf#102499 (8): Return empty property when not present.

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2021-11-01 17:54:59 UTC
Giuseppe Castagno committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/62069267024a35e323e8685c3808bf80d64ddb5c

ucb: webdav-curl: tdf#102499 (9): Fix eXo Platform WebDAV on 'Save Remote File'

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.