Download it now!
Bug 102779 - Notebookbar: Add spacing/padding around tab labels
Summary: Notebookbar: Add spacing/padding around tab labels
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:5.4.0
Keywords: needsDevEval, topicUI
Depends on:
Blocks: Notebookbar-Theming
  Show dependency treegraph
 
Reported: 2016-09-29 00:14 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-10-13 13:15 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
LibreOffice windows 7 with minimum tab wide (71.40 KB, image/png)
2017-02-28 08:03 UTC, andreas_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-09-29 00:14:24 UTC
The notebookbar's tabs are very cramped which will make them more difficult to toggle, so it would be more ideal to extend them horizontally and possibly vertically.

I tested adding this spacing to the tab labels with the xpad, ypad, and margin_* properties but none of them worked and the only way i was able to achieve the intended horizontal space was to add blank spaced to the label text, like so '  File  '.
Comment 1 Heiko Tietze 2016-09-29 10:03:54 UTC
Not being a friend of these tabs, the issue is valid: if tabs should be used it has to be as comfortable as known from Mozilla's Australis UI for instance.
Comment 2 Volga 2016-10-03 00:53:02 UTC
This is really useful when LO 5.3 interface will be translated into Chinese, Japanese and Korean.
Comment 3 Volga 2016-10-23 19:35:39 UTC
This would also making them unreadable to some Indian people
Comment 4 Volga 2016-11-03 03:39:07 UTC
(In reply to General Kutuzov from comment #3)
> This would also making them unreadable to some Indian people

Add spacing/padding around tab labels, it would making them more readable to some Indian people
Comment 5 Volga 2016-11-10 07:54:28 UTC
I guess this can be done via inserting a space around the text, for example, U+2000.
Comment 6 Adolfo Jayme 2016-11-10 13:58:11 UTC
This is a UI toolkit issue that is not exclusive to the Notebookbar interface. Adding space characters to strings wouldn’t be a correct fix, since it involves hundreds of changes in all languages.
Comment 7 sophie 2016-11-21 14:23:16 UTC
I agree with Adolfo here, finding double empty spaces as strings in our l10n files are seen as bug in the process. Sophie
Comment 8 Yousuf Philips (jay) (retired) 2017-02-25 11:00:39 UTC
@Maxim, @Szymon, @Samuel: Any thoughts on how this can be resolved?
Comment 9 andreas_k 2017-02-25 11:10:42 UTC
From the design the tabs look (in windows 7) really really ugly. Only in Gnome they look good (in KDE it's ok, but more space could help)

As you can read different designes, different layout. Is on one hand very good on the other hand the problem is on the most used platform windows (7) the tabs look really ugly.

Make tham less tiny would help. Maybe we can add an action button to open the files menubar or view, ... shown an save icon in the files tab could also help to give the user an information what's in the tab and for save the user didn't have to switch to the tab.
Comment 10 Commit Notification 2017-02-27 14:14:06 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4d73a7227f4f341aece7ab3376823f70a3e87d71

tdf#102779 Notebookbar: extra space for small tab labels

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 andreas_k 2017-02-28 08:03:29 UTC
Created attachment 131526 [details]
LibreOffice windows 7 with minimum tab wide

look much better but in my point of view something is still missing. Does someone has a good idea?
Comment 12 andreas_k 2017-03-10 07:55:04 UTC
can you test if additional padding could help? That's not only an issue of the tabbed toolbar all tabs (dialogues) are very tiny, so maybe add an padding could help.

Issue is for me on windows and kde only in gnome it look (and work) good.
Comment 13 andreas_k 2017-04-15 20:13:43 UTC
In general I would suggest padding to ALL tabs also in the dialog windows the tabs could look way better.
Comment 14 Thomas Lendo 2017-04-21 22:37:22 UTC
I perceive the Notebookbar tabs as too wide now. Mouse ways are increased unnecessarily. Half of the space would be sufficient, more like https://blog.cometdocs.com/wp-content/uploads/themes-in-word-2013.png.
Comment 15 Commit Notification 2017-04-22 08:51:08 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=59ef98de50ad7892454b35bec823df6869ec6421

tdf#102779 Set a minimum height for Notebookbar tabs

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Xisco Faulí 2017-07-14 13:17:00 UTC
Polite ping: is this bug fixed? if so, please close it as RESOLVED FIXED
Comment 17 andreas_k 2017-07-14 13:33:19 UTC
from my point of view it's a big visual improvement. hope so see something like this fot the dialog tabs too.