Download it now!
Bug 102855 - LibreOffice crashes when opening document
Summary: LibreOffice crashes when opening document
Status: RESOLVED DUPLICATE of bug 102073
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.3.2 release
Hardware: All All
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, dataLoss, regression
Depends on:
Blocks:
 
Reported: 2016-09-30 11:34 UTC by Guillaume Pothier
Modified: 2016-09-30 12:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
The document that makes Writer crash (163.41 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-09-30 11:34 UTC, Guillaume Pothier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Guillaume Pothier 2016-09-30 11:34:01 UTC
Created attachment 127745 [details]
The document that makes Writer crash

The attached document crashes LibreOffice writer when attempting to open it. The first page gets displayed, and the the application crashes.
This occurs on 5.1.4 on Ubuntu and 5.2.2 on Windows 10.
Original bug report on Ubuntu: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1627874
Comment 1 Xisco Faulí 2016-09-30 11:44:07 UTC
Confirmed in

Version: 5.3.0.0.alpha0+
Build ID: 0d3ba1d4b507b555b086c687fcd202d69a9a2ffa
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

@Caolan: One for you?
Comment 2 Xisco Faulí 2016-09-30 11:52:19 UTC
Not crashing in

Version: 5.0.0.0.alpha1+
Build ID: 0db96caf0fcce09b87621c11b584a6d81cc7df86
Locale: ca-ES (ca_ES.UTF-8)

thus, it's a regression!
Comment 3 Aron Budea 2016-09-30 12:11:16 UTC
Occurs in v5.1.3.2 first.
Crash is "SEH Exception: ACCESS VIOLATION", no crash report triggered.

Raising importance as it's a crash, and the document can't be opened.
Comment 4 Caolán McNamara 2016-09-30 12:14:54 UTC

*** This bug has been marked as a duplicate of bug 102073 ***