Bug Hunting Session
Bug 102951 - Mail Merge Wizard no longer works
Summary: Mail Merge Wizard no longer works
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Mail-Merge
  Show dependency treegraph
 
Reported: 2016-10-04 12:06 UTC by Alex Kempshall
Modified: 2017-04-12 15:19 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Kempshall 2016-10-04 12:06:26 UTC
When using the Mail Merge wizard, in Writer, the last few steps are missing.  

There should be 8 steps which are - 

Select starting document
Select document type
Insert address block
Create salutation
Adjust layout
Edit document
Personalise document
Save, print or send

Whereas in 5.3.0.0+Alpha Master there are now only 5 steps which are -

Select starting document
Select document type
Insert address block
Create salutation
Adjust layout

With only 5 steps it is not possible to create a merged document

This procedure was OK in version 5.1.5.2.

The problem also occurs in Fresh 5.2.2

Steps to reproduce the problem.

1.
Start LibreOffice writer with empty text document.

2.
Tools -> Mail Merge Wizard

3.
The “Select starting document" dialog box should appear. The left pane should contain 8 steps. In the right pane select the "Use Current Document" Radio Button. Then press the "Next >>" Button.

4.
The "Select document type" dialog box should appear. Select the "Letter" Radio Button. Then press the "Next" Button.

5.
The "Insert address block" dialog box should appear. Press the "Select Different Address List" Button.

6.
The "Select Address List" dialog box should appear. Press the "Create" Button.

7.
An empty "New Address List” dialog box should appear. Enter the text "ABC" in the Company Name field and press the "New" Button.

8.
An empty "New Address List” dialog box should appear. Enter the text "DEF" in the Company Name field and press the "New" Button.

9.
An empty "New Address List” dialog box should appear. Enter the text "GHI" in the Company Name field and press the "OK" Button.

10.
A “Save – LibreOffice” dialog box should appear enabling the newly created address list to be saved as a csv file. Select a suitable directory to save the file to. In the "Name" Field enter a name of the CSV file to be saved i.e. CompanySeed. Then press the "Save" button.

11.
The "Select Address List" dialog box should re-appear. Press the "OK" Button.

12.
The "Insert Address Block" dialog box should appear. Check the "This document must contain an address block" Tick Box. Press the "More" Button.

13.
The "Select Address Block" dialog box should appear. Press the "New" Button.

14.
The “New Address Block” dialog box should appear. Select the "Company Name" address element in the left hand panel and drag it to the "Drag Address Elements Here" Panel. Can also use the right pointing arrow.

16.
The "Drag Address Elements Here" Panel should only contain the "Company Name" and the "Preview" Panel should contain the text "ABC". Press the "OK" Button.

17.
The "Select Address Block" dialog box should appear. Press the "OK" button

18.
The "Insert Address Block" dialog box should appear. Press the "Next >>" Button.

19.
The "Create salutation" dialog box should appear. If ticked uncheck the "This document should contain a salutation" Tick Box and press the "Next >>" Button.

20.
The "Adjust layout" dialog box should appear. The "Next >>" is greyed out - it should no be. The only buttons available are the "Finish" and "Back <<" Button. If the "Finish" button is pressed the Mail Merge Wizard closes and the user is returned to the Starting Document.


The last step is not correct. The "Next >>" should not be greyed out. It should be available to be pressed and if it was pressed the following should happen -

21.
The "Preview/Edit document" dialog box should appear. Press the "Next >>" Button.

22.
A Message box should appear counting the 3 Company Names to be merged as entered in the steps above.

23.
The "Personalise document" dialog box should appear. Press the "Next >>" Button.

24.
The "Save, print or send" dialog box should appear. Click the “Save merged document” radio button. Click the “Save as single document” radio button. Press the “Save Documents” button.

25.
A “Save – LibreOffice” dialog box should appear enabling the newly created merged document to be saved as an odt file. Select a suitable directory to save the file to. In the "Name" Field enter a name of the CSV file to be saved i.e. CompanyMerged. Then press the "Save" button.

26.
The "Save, print or send" dialog box should appear. Press the “Finish” button.

27.
A single paged document should now be visible with the name “Untitled n”, where n can be any number normally 2.  Close the document without saving. From the menu bar File → Close. A message box should appear. Press the “Don't Save” button.

27.
A three paged document should now be visible with the name “Untitled n”, where n can be any number normally 1.  Close the document without saving. From the menu bar File → Close. A message box should appear. Press the “Don't Save” button.

28.
Using your file manager navigate to the directory in which you saved the CompanyMerged.odt file and open it with LibreOffice. A three paged document should now be visible with the name CompanyMerged.odt. The first page should contain the characters ABC, the second page DEF and the third page GHI.


Alex
Comment 1 Thomas Hackert 2016-10-09 11:15:39 UTC
Hello Alex, *,
I can confirm your bug beginning with 5.2 series of LO on

OS: Debian Testing AMD64
LO: Version: 5.2.0.4
Build-ID: 066b007f5ebcc236395c7d282ba488bca6720265
CPU-Threads: 4; BS-Version: Linux 4.5; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE.UTF-8)
(parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel/Linux)

nor with

Version: 5.2.2.2.0+
Build-ID: 1:5.2.2~rc2-2
CPU-Threads: 4; BS-Version: Linux 4.5; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group
(Debian's own version)

... This seems to have changed since the 5.1.x series as

LO: Version: 5.1.6.1
Build-ID: f3e25ec0581f5012f54d8810dcddd5824f4ee374
CPU-Threads: 4; BS-Version: Linux 4.5; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group

and

LO: Version: 5.1.5.2
Build-ID: 7a864d8825610a8c07cfc3bc01dd4fce6a9447e5
CPU-Threads: 4; BS-Version: Linux 4.5; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group

show eight steps in the Mail Merge Wizard. As I can confirm your observation with 5.2.0.4, I will change the version number and the status to new ... ;)
HTH
Thomas.
Comment 2 Alex Kempshall 2016-10-11 12:21:24 UTC
It seems that the Mail Merge functionality has changed with release 5.2.n. Can't find this documented anywhere. Mail Merge now has it's own Toolbar. I would suggest that the Mail Merge Wizard in the Tools menu be dropped to avoid confusion.

These appear to be the changes 

 ba0796b 2015-12-23 | mailmerge: Killed the 'Save, print or send' page. (HEAD) [Jan Holesovsky]
* 6b35590 2015-12-23 | mailmerge: Implemented "Edit Individual Documents" toolbar button. (refs/bisect/good-6b355901a7e7a1fd8710e743621ad655068a5817) [Jan Holesovsky]
* 6d08322 2015-12-23 | mailmerge: Icon for the Mail Merge Wizard too. [Jan Holesovsky]
* 7342baf 2015-12-23 | mailmerge: Really show the icons for first/prev/next/last mailmerge entry. [Jan Holesovsky]
* d0f7cdc 2015-12-22 | mailmerge: Icons for the first/prev/next/last mailmerge entry buttons. (refs/bisect/good-d0f7cdc36d9858c3eed461377564a1875305d6e0) [Jan Holesovsky]
* 00fa85e 2015-12-22 | mailmerge: Make the SwMailMergeConfigItem instance long-living. [Jan Holesovsky]
* 906333a 2015-12-22 | mailmerge: Decrease indentation level by an early return. [Jan Holesovsky]
* 55202ec 2015-12-21 | mailmerge: Enable/disable the first/prev/next/last mailmerge entry buttons. [Jan Holesovsky]
* 827ff2e 2015-12-18 | mailmerge: Introduce buttons for first/prev/next/last mailmerge entry. [Jan Holesovsky]
* 299cc33 2015-12-18 | mailmerge: Don't hide the source document. [Jan Holesovsky]
* ac522d1 2015-12-18 | mailmerge: Introduce a mailmerge toolbar. [Jan Holesovsky]


The above changes now mean that my test case, quoted as the original comment to this bug report, has to change to and on that basis works -


1.
Start LibreOffice writer with empty text document.

2.
View -> Toolbars

If unticked check the "Mail Merge" Tick Box.

3.
Focus should be returned to the empty text document. Also, the Mail Merge Toolbar should have appeared which includes 6 "buttons" which are <Mail Merge Wizard>, <Navigation Arrows>, <Exclude Recipient | Edit Individual Documents>, <Save Merged Documents>, <Print Merged Documents> and <Send E-Mail Messages>. The <Mail Merge Wizard> button should be enabled the other 5 buttons should be disabled (greyed out).

4.
Left click the <Mail Merge Wizard> button on the Mail Merge Toolbar

5.
The “Select starting document" dialog box should appear. The left pane should contain 5 steps. In the right pane select the "Use Current Document" Radio Button. Then press the "Next >>" Button.

6.
The "Select document type" dialog box should appear. Select the "Letter" Radio Button. Then press the "Next" Button.

7.
The "Insert address block" dialog box should appear. Press the "Select Different Address List" Button.

8.
The "Select Address List" dialog box should appear. Press the "Create" Button.

9.
An empty "New Address List” dialog box should appear. Enter the text "ABC" in the Company Name field and press the "New" Button.

10.
An empty "New Address List” dialog box should appear. Enter the text "DEF" in the Company Name field and press the "New" Button.

11.
An empty "New Address List” dialog box should appear. Enter the text "GHI" in the Company Name field and press the "OK" Button.

12.
A “Save – LibreOffice” dialog box should appear enabling the newly created address list to be saved as a csv file. Select a suitable directory to save the file to. In the "Name" Field enter a name of the CSV file to be saved i.e. CompanySeed. Then press the "Save" button.

13.
The "Select Address List" dialog box should re-appear. Press the "OK" Button.

14.
The "Insert Address Block" dialog box should appear. Check the "This document must contain an address block" Tick Box. Press the "More" Button.

15.
The "Select Address Block" dialog box should appear. Press the "New" Button.

16.
The “New Address Block” dialog box should appear. Select the "Company Name" address element in the left hand panel and drag it to the "Drag Address Elements Here" Panel. Can also use the right pointing arrow.

17.
The "Drag Address Elements Here" Panel should only contain the "Company Name" and the "Preview" Panel should contain the text "ABC". Press the "OK" Button.

18.
The "Select Address Block" dialog box should appear. Press the "OK" button

19.
The "Insert Address Block" dialog box should appear. Press the "Next >>" Button.

20.
The "Create salutation" dialog box should appear. If ticked uncheck the "This document should contain a salutation" Tick Box and press the "Next >>" Button.

21.
The "Adjust layout" dialog box should appear. The "Next >>" is greyed out. The only buttons available are the "Finish" and "Back <<" Button. Press the "Finish" button is pressed the Mail Merge Wizard closes.

22.
Focus is returned to a text document which is populated with a text box containing the field <Company Name>. All buttons on the <Mail Merge> Toolbar are now enabled. Press the <Save Merged Documents> on the <Mail Merge> Toolbar.

23.
The "Save merged document" dialog box should appear. If not already selected click the "save as a single large document" Radio Button. Press the “Save Documents” button.

22.
A Message box should appear counting the 3 Company Names to be merged as entered in the steps above.

24.
A “Save – LibreOffice” dialog box should appear enabling the newly created merged document to be saved as an odt file. Select a suitable directory to save the file to. In the "Name" Field enter a name of the CSV file to be saved i.e. CompanyMerged. Then press the "Save" button.

25.
A single paged document should now be visible with the name “Untitled n”, where n can be any number normally 2.  Close the document without saving. From the menu bar File → Close. A message box should appear. Press the “Don't Save” button.

26.
Using your file manager navigate to the directory in which you saved the CompanyMerged.odt file and open it with LibreOffice. A three paged document should now be visible with the name CompanyMerged.odt. The first page should contain the characters ABC, the second page DEF and the third page GHI.
Comment 3 Cor Nouws 2016-10-27 10:37:53 UTC
Hi, please use View > Toolbar > Mailmerge..
There are some imperfections, but that is the new way to go.
Comment 4 G.Ostner (LOBugs) 2017-04-12 15:19:36 UTC
I think that as soon as someone starts the mailmerge-wizard, two things should happen automatically:

1) show the mailmerge-toolbar and
2) show the correct OPEN datasource (View/Datasource) as soon as a datasource has been selected for this document.

Also, when a mailmerge main document is reopened, these two things should happen, again automatically.

As it is, users have to restart the mailmerge-wizard and go at least one step and click "Finish", before the toolbar is shown.

Other than that, the new workflow is great!