Download it now!
Bug 102986 - Using mail merge, images only print in the first instance. Images don't print in subsequent pages.
Summary: Using mail merge, images only print in the first instance. Images don't print...
Status: RESOLVED DUPLICATE of bug 100617
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.2.3.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-04 22:38 UTC by Aled
Modified: 2017-01-12 18:10 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aled 2016-10-04 22:38:00 UTC
User-Agent:       Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Build Identifier: 8f96e87c890bf8fa77463cd4b640a2312823f3ad

I've created a ticket that contains images. The ticket contains unique numbers via mail merge. For 100 tickets, mail merge produces one document with 100 pages - one ticket per page. All tickets/pages appear fine, including images. When I go to print, only the first ticket/page includes the images in the print preview and the printed output. For testing purposes, I have varied the image types so there is one GIF, one JPG and one PNG. Two are anchored as characters. One is anchored to the page and set to be in the background with text through-aligned. All the images appear in the first printed ticket/page, but not in subsequent pages. If I change the print range to start with ticket/page 2 or higher, the images don't appear. The images therefore are only printed for ticket/page 1, regardless which ticket/page is printed first. As I said, the images appear fine in each ticket/page of the 100-page ODT created by mail merge, so it appears a print problem. PDF export is fine - and that's how I've got around the issue.

Reproducible: Didn't try

Steps to Reproduce:
1. Create a document including an image and with a mail merge field.
2. Print to file via mail merge to create an ODT file with one page per mail merge entry.
3. Print the multi-page mail merged ODT file and the images are only printed in the first page, even though they appear in every page.






Reset User Profile?No
Comment 1 Buovjaga 2016-10-06 18:24:30 UTC
Which LibreOffice version are you using?
If I understand you correctly, the problem is not with mail merge itself, but with LibreOffice printing in general?

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 2 Aled 2016-12-20 14:16:55 UTC
Since posting initially I have upgraded to 5.2.3.3 (x64) and the problem persists.

I have recreated it again in this version with mail merge, but it seems Buovjaga is right that the issue is with LO printing in general, though there does seem to be a difference between a manually-created multi-page document and a mail merge created multi-page document.

1. Create new document. 
2. Insert image.
3. Copy image.
3. Create page break.
4. Paste image in new page.
Repeat 3 & 4 to create several pages, each with the image.
5. Open Print dialog (Ctrl+P)
6. Select Page Layout tab.
7. With one page per sheet, the image appears in the preview on every sheet.
8. With two or more pages per sheet, the image does not appear in the preview. It does not print either. (Note that this is different to the case with a document created by mail merge. With a mail merge created document, the image does appear and print for the first but not subsequent pages.)
Comment 3 Buovjaga 2016-12-20 14:28:20 UTC
Do set the version field to the one you first saw the problem in.
Comment 4 Xisco Faulí 2017-01-12 18:10:28 UTC

*** This bug has been marked as a duplicate of bug 100617 ***