Download it now!
Bug 103034 - LO Impress 5.0.6.3 crash with a fatal error - SEH Exception Access Violation
Summary: LO Impress 5.0.6.3 crash with a fatal error - SEH Exception Access Violation
Status: RESOLVED DUPLICATE of bug 100151
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0.6.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-06 10:17 UTC by Peter-Lenné-Schule
Modified: 2016-10-13 17:11 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Eventlog (13.55 KB, image/png)
2016-10-06 10:17 UTC, Peter-Lenné-Schule
Details
Error Message (3.55 KB, image/png)
2016-10-06 10:18 UTC, Peter-Lenné-Schule
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter-Lenné-Schule 2016-10-06 10:17:23 UTC
Created attachment 127837 [details]
Eventlog

We have a Windows Server 2008 r2 terminal server farm with 2500 users. We use LibreOffice for sustainability reasons and are actually satisfied with it. The error is reproducible on all servers. The user profiles are roaming profiles.

Since the introduction of LibreOffice 5.0.6.3, we have a problem with LibreOffice Impress. Prior to this, we were able to work with the version LO 4.6.3 Impress without problems.

Our students create a presentation with Impress with pictures, videos, etc.
Afterwards the students have to present your results. This is what the students test in advance of their presentation, of course.

Whenever the prompt "please click to close the presentation", the error message "Fatal error - SEH Exception Access Violation" comes up.

In the eventlog of the server I get the error message Event ID 1000 (see appendix).

We hope that you can help us.

Best regards

Peter-Lenné School
Comment 1 Peter-Lenné-Schule 2016-10-06 10:18:15 UTC
Created attachment 127838 [details]
Error Message
Comment 2 Aron Budea 2016-10-06 11:12:47 UTC
There've been a couple of similar bug reports, mostly the crash happened when the presentation was played in a VM and hardware acceleration was turned on. As a workaround, can you try turning off OpenGL as described in the 3rd point of [1]?

[1] https://wiki.documentfoundation.org/QA/FirstSteps

*** This bug has been marked as a duplicate of bug 100151 ***
Comment 3 Peter-Lenné-Schule 2016-10-07 11:58:39 UTC
Unfortunately our problem could not be solved by the help.

I have the following points with a restricted user and an administrative user:
- Rename the user profile
- OpenGL per GPO banned, in the settings was both unchecked
- OpenCL disabled

The result is unfortunately the identical

We use VMWare ESXi 6.0 as a virtualization platform.

There was no cache folder in the% AppData% \ LibreOffice \ 4 \ User folder.
The folder "% AppData% \ LibreOffice \ 4 \ cache" was empty.

Therefore, I can unfortunately no file opengl_device.log append.

We hope you have an idea for us.
thank you
Comment 4 V Stuart Foote 2016-10-07 14:47:46 UTC
back to duplicate of bug 100151, or equally to bug 96539

for OP, please test if disabling hardware acceleration (Tools -> Options -> View, all of graphics output section unchecked) makes your VM instances behave. Post result on the duplicate

*** This bug has been marked as a duplicate of bug 100151 ***
Comment 5 Peter-Lenné-Schule 2016-10-13 08:52:58 UTC
To uncheck all the graphical components was the solution for us.
Thank you very much.

Only a problem remains. We now need to disable hardware acceleration and edge smoothing for all students. To disable OpenGL I have already found an Admx template.

Do you have to deactivate the hardware acceleration and the edge smoothing likewise an admx template or can you tell us the registry keys?
Comment 6 V Stuart Foote 2016-10-13 14:36:30 UTC
@Michel, need a little help, this has been duped to bug 100151--but I was looking for the answer to OPs question as to where to set the "Use hardware acceleration" to off in profile or (Windows) registry.

It does not appear to be recorded to "registrymodifications.xcu" in LOs user profile and of course is not recorded to Windows registry.

Looking at http://opengrok.libreoffice.org/xref/core/cui/source/options/optgdlg.cxx#951 I can see where the values are set/reset, but where is the check looking for the setting in user profile?
Comment 7 Michael Meeks 2016-10-13 16:24:57 UTC
Hmm - interesting. So - I guess these guys are using 3D transitions - and we're mapping those to our new GL transitions, and -then- there is some awful / crashing GL driver for 3D transitions.

Might be interesting to get some GL info out of this. If there is a document that is used, can we confirm that setting all the transitions to cuts avoids the problem here ?

I guess we need to think through the use of OpenGL for several separate domains - Impress transitions, VCL rendering etc. I forget how the configuration works for those several uses. But worth checking.

Thanks.
Comment 8 Aron Budea 2016-10-13 16:36:33 UTC
Michael, as Caolán mentioned in [1], this crash is more likely related to some residual VclPtr issues in the DX9 canvas class. That's why enabling/disabling OpenGL has no effect, and hardware acceleration itself has to be disabled.

[1] https://bugs.documentfoundation.org/show_bug.cgi?id=100151#c23
Comment 9 V Stuart Foote 2016-10-13 17:11:16 UTC
(In reply to Michael Meeks from comment #7)
> Hmm - interesting. So - I guess these guys are using 3D transitions - and
> we're mapping those to our new GL transitions, and -then- there is some
> awful / crashing GL driver for 3D transitions.
> 
> Might be interesting to get some GL info out of this. If there is a document
> that is used, can we confirm that setting all the transitions to cuts avoids
> the problem here ?
> 
> I guess we need to think through the use of OpenGL for several separate
> domains - Impress transitions, VCL rendering etc. I forget how the
> configuration works for those several uses. But worth checking.

Michael, *

That seems the case, and as Caolan and Aaron mention believe it is residual DirectX canavs goo, but discussion probably belongs with the dupe bug 100151. 

Here I was hoping to pin down configuration details to answer comment 5 and provide OP some way to programatically disable hardware acceleration for new user profiles in LibreOffice so their VM instances can run.