Bug 103040 - Mixed english and hebrew sentences starting with english are always LTR
Summary: Mixed english and hebrew sentences starting with english are always LTR
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-CTL
  Show dependency treegraph
 
Reported: 2016-10-06 17:20 UTC by Tharbad
Modified: 2016-10-25 12:32 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Demonstration of the bug - Impress file (11.45 KB, application/vnd.oasis.opendocument.presentation)
2016-10-06 17:24 UTC, Tharbad
Details
Screenshot (22.05 KB, image/png)
2016-10-06 17:24 UTC, Tharbad
Details
Screenshot of not reproducing (74.05 KB, image/jpeg)
2016-10-24 10:56 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tharbad 2016-10-06 17:20:27 UTC
Description:
When I add a new sentence to a slide starting with an English word it's always LTR, even if I try to set it as RTL.



Steps to Reproduce:
1. Set direction to RTL
2. Start a sentence with English word
3. Write an Hebrew word after the English one


Actual Results:  
Direction becomes LTR

Expected Results:
Direction is RTL


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
Comment 1 Tharbad 2016-10-06 17:24:04 UTC
Created attachment 127843 [details]
Demonstration of the bug - Impress file
Comment 2 Tharbad 2016-10-06 17:24:45 UTC
Created attachment 127844 [details]
Screenshot
Comment 3 Buovjaga 2016-10-24 10:56:44 UTC
Created attachment 128202 [details]
Screenshot of not reproducing

I don't reproduce the problem. Cursor is inside the Hebrew word in the screenshot.

Win 7 Pro 64-bit Version: 5.3.0.0.alpha1+
Build ID: 02e6c1c95993740e0dbea724b3014348c4b6559d
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-10-24_04:01:05
Locale: fi-FI (fi_FI); Calc: group
Comment 4 Yousuf Philips (jay) (retired) 2016-10-24 11:38:51 UTC
Hi Tharbad,

Thank you for reporting the bug. Unfortunately i cant reproduce when writing in arabic. With attachment 127843 [details], the paragraph is set to RTL, as can be seen in the alignment tab of the paragraph dialog.

Version: 5.3.0.0.alpha1+
Build ID: 928776b734c6aa188151bbce048d5bef4486dce7
CPU Threads: 2; OS Version: Linux 3.19; UI Render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-10-23_00:39:08
Locale: en-US (en_US.UTF-8); Calc: group
Comment 5 Khaled Hosny 2016-10-24 12:45:35 UTC
The ordering in the screenshot (which is identical to what I get locally) is the correct bidi order. There is no bug here. Bidi control characters can be used to change the default bidi behavior as it can be sub-optimal sometimes.