Download it now!
Bug 103098 - Applying a style after copy & paste causes hang
Summary: Applying a style after copy & paste causes hang
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks: Styles
  Show dependency treegraph
 
Reported: 2016-10-10 20:47 UTC by Octavio Alvarez
Modified: 2018-08-02 07:15 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
File with the content to be copied (29.04 KB, application/vnd.oasis.opendocument.text)
2016-10-10 20:48 UTC, Octavio Alvarez
Details
bug-new-template.odt (8.72 KB, application/vnd.oasis.opendocument.text)
2016-10-10 20:49 UTC, Octavio Alvarez
Details
bug-content.odt (29.04 KB, application/vnd.oasis.opendocument.text)
2016-10-10 20:50 UTC, Octavio Alvarez
Details
GDB trace of hang with 5.4 master (35.16 KB, text/plain)
2017-04-23 12:19 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Octavio Alvarez 2016-10-10 20:47:11 UTC
Description:
Writer goes hangs with high CPU and the only way to proceed is to kill it after the following steps.

Steps to Reproduce:
1. Copy all content from bug-content.odt:
   - Open bug-content.odt, Ctrl+A, Ctrl+C.

2. Open bug-new-template.odt.

3. Open the Styles and Formatting side pane.
   - F11

4. Paste it at the end of bug-new-template.odt:
   - Ctrl+End, Ctrl+V.

Observe how the original A to D content is now 1 to 4 on both questions. This is probably a bug. However it is not the bug I am reporting.

5. Select the first set of possible answers, the ones that include 100, 200, 300 and 400 as options. Select them from the start of "100" to the end of "400".

6. Double click on style "Pregunta".


Actual Results:  
Writer goes hangs with high CPU and the only way to proceed is to kill it.

Expected Results:
Writer should apply the style Pregunta.


Reproducible: Always

User Profile Reset: No

Additional Info:
Version: 5.2.1.2
Build ID: 1:5.2.1-1
CPU Threads: 8; OS Version: Linux 4.7; UI Render: default; 
Locale: en-US (en_US.utf8); Calc: group


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.92 Safari/537.36
Comment 1 Octavio Alvarez 2016-10-10 20:48:03 UTC Comment hidden (obsolete)
Comment 2 Octavio Alvarez 2016-10-10 20:49:21 UTC
Created attachment 127937 [details]
bug-new-template.odt
Comment 3 Octavio Alvarez 2016-10-10 20:50:21 UTC
Created attachment 127938 [details]
bug-content.odt

I'm reattaching bug-content.odt with a description that better matches the bug report.
Comment 4 Yousuf Philips (jay) (retired) 2016-10-18 02:46:51 UTC
Confirmed.

@Meeks, @Maxim: Is a trace needed for this?

Version: 5.3.0.0.alpha0+
Build ID: 45a7137c6796f33fbf5b8f7cb64e293260d991cb
CPU Threads: 2; OS Version: Linux 3.19; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-10-13_23:38:06
Locale: en-US (en_US.UTF-8); Calc: group
Comment 5 Yousuf Philips (jay) (retired) 2017-04-21 11:15:08 UTC
@Buovjaga, @Aron: Any suggestions on how to move this forward?
Comment 6 Buovjaga 2017-04-23 12:19:23 UTC
Created attachment 132766 [details]
GDB trace of hang with 5.4 master

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: f1f210866f9590eb59ef83b9ac0d434d7d29ef18
CPU threads: 8; OS: Linux 4.10; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on April 21st 2016
Comment 7 Julien Nabet 2017-04-24 20:14:43 UTC
On pc Debian x86-64 with master sources updated yesterday, I could reproduce this.
I noticed this log repeatedly:
warn:legacy.osl:2401:1:sw/source/core/layout/flowfrm.cxx:2405: <SwFlowFrame::MoveBwd(..)> - layout loop control for layout action <Move Backward> applied!
Comment 8 QA Administrators 2018-04-25 02:32:53 UTC Comment hidden (obsolete)
Comment 9 Octavio Alvarez 2018-08-02 00:59:21 UTC
Can't reproduce anymore on 6.1.0.2.
Comment 10 Julien Nabet 2018-08-02 07:15:35 UTC
Thank you for your feedback.
Let's put this one to WFM then.