Bug 103124 - Unusable UI - hidden text near the main windows icon and unreadable text menu inside each application
Summary: Unusable UI - hidden text near the main windows icon and unreadable text menu...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.1.5.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-11 15:25 UTC by Guido Maurano
Modified: 2016-10-14 19:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Main window screenshot (83.72 KB, image/png)
2016-10-11 15:26 UTC, Guido Maurano
Details
Writer screenshot (147.28 KB, image/png)
2016-10-11 15:27 UTC, Guido Maurano
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Guido Maurano 2016-10-11 15:25:38 UTC
Description:
Most of the times I run LibreOffice (99 on 100) I see the main windows with sidebar menu on the left side. There I can only see icons, without description text (such as Writer, Calc etc.). Then if I run an application (Writer for example) I see unreadable tooltip text (on each menu button) and unreadable dropdown menu for font family and font style. It seems each font of the list is put on top of the previous one. 

I have to quit the main app and run it again 20 or 30 times before I can see every text properly. 

Actual Results:  
I can use the whole application because every icon has unreadable tooltip text

Expected Results:
It should be work properly every time I run it. It only works one time each 100


Reproducible: Sometimes

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.143 Safari/537.36
Comment 1 Guido Maurano 2016-10-11 15:26:46 UTC
Created attachment 127945 [details]
Main window screenshot
Comment 2 Guido Maurano 2016-10-11 15:27:31 UTC
Created attachment 127946 [details]
Writer screenshot
Comment 3 Alex Thurgood 2016-10-12 07:47:11 UTC
@Guido :

Please indicate your screen resolution, screen output hardware (type of screen) and the hardware that OSX is installed on.

Also please indicate which version of OSX you are using.

Setting to NEEDINFO, please set back to UNCONFIRMED once you have provided this information.
Comment 4 Guido Maurano 2016-10-12 08:26:45 UTC
I have a Mac Book Pro Retina 15-inch, Late 2013

The screen is the integrated one, with default resolution (1400x900)

I'm using OSX 10.12 (MacOS Sierra) but I had the same issue with the previous version (El Capitan).

Please, tell me if you need other informations.

Thank you for your reply.

Guido
Comment 5 Alex Thurgood 2016-10-12 10:12:02 UTC
@Guido : thanks.

Have you tried resetting your LO user profile ?

I don't see this issue on

MBPro Retina 15" (end-2013)
NVIDIA GeForce GT 750M and
Intel Iris Pro graphics chips
Comment 6 Guido Maurano 2016-10-12 10:20:15 UTC
I just deleted the ~/Library/Application Support/LibreOffice/4/user folder.

Nothing seems to be changed... the issue is still on.
Comment 7 Alex Thurgood 2016-10-12 10:24:42 UTC
@Guido : are you running a version of LO from the Apple Store, or from the LibreOffice download page ?
Comment 8 Guido Maurano 2016-10-12 10:26:12 UTC
I got it from the LO download page ("Still" version)
Comment 9 Alex Thurgood 2016-10-12 10:27:24 UTC
OK, thanks, one final question for now :
Which graphics cards do you have on your MBPro ?
Comment 10 Guido Maurano 2016-10-12 10:28:29 UTC
NVIDIA GeForce GT 750M 2048 MB
Intel Iris Pro 1536 MB

Thanks for you replies
Comment 11 Alex Thurgood 2016-10-12 10:28:59 UTC
Actually, I've just thought of another :

what is your default system font ? This has been known to cause problems with LO if it is a font with font weights that are not fully supported by LO
Comment 12 Alex Thurgood 2016-10-12 10:38:06 UTC
You can try resetting the font cache with :

sudo atsutil databases -remove

in a terminal.

You can also :

"To go back to Apple’s default font, simply move your modified fonts out of the Macintosh HD > Library > Fonts folder, and then restart or log out and back in to your user account. This approach will also have the font available in Apple’s included Font Book utility, so you can also use this program to select and disable the font accordingly."
Comment 13 Guido Maurano 2016-10-12 10:50:22 UTC
I tried "sudo atsutil databases -remove", then I restarted the machine.

Issue was still on.

Then I run "Font Book" application, I disabled all User font and now everything seems to works properly. I should try to enable each font one by one to check which one causes the issue.

Thanks a lot for your help