Bug 103151 - SVG rendered wrong in the presenter console
Summary: SVG rendered wrong in the presenter console
Status: RESOLVED DUPLICATE of bug 95438
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, filter:svg, regression
Depends on:
Blocks: Slide-Show Presenter-Console
  Show dependency treegraph
 
Reported: 2016-10-12 11:38 UTC by Jan-Marek Glogowski
Modified: 2019-03-29 19:02 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Failing presentation with embedded SVG. (210.79 KB, application/vnd.oasis.opendocument.presentation)
2016-10-12 11:38 UTC, Jan-Marek Glogowski
Details
Screenshot of the broken logo in in the Impress presentation console (452.71 KB, image/png)
2016-10-12 11:39 UTC, Jan-Marek Glogowski
Details
Correct preview screenshot of the presenter console of the first slide (254.88 KB, image/png)
2016-10-12 15:54 UTC, Jan-Marek Glogowski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan-Marek Glogowski 2016-10-12 11:38:29 UTC
Created attachment 127963 [details]
Failing presentation with embedded SVG.

The attached presentation just contains the SVG Windows 7 logo from Wikipedia https://upload.wikimedia.org/wikipedia/de/c/c2/Microsoft_Windows_7_logo.svg

It's rendered wrong in the presenter console on

Version: 5.3.0.0.alpha0+
Build-ID: 74ead0785f7a08709cf6da6c24a936001b1a7d9c
CPU-Threads: 14; BS-Version: Linux 3.16; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group

The presenting screen is ok, as you can see in the attached screenshot.

To reproduce just load and start the presentation and switch to the 2nd page.

Loaded canvas libraries are:

# lsof -p 10224 | grep canvas
soffice.b 10224  jmg  mem       REG              252,1   9570960 2118171 /home/jmg/Development/libreoffice/symbols/instdir/program/libvclcanvaslo.so
soffice.b 10224  jmg  mem       REG              252,1   8390376 2118167 /home/jmg/Development/libreoffice/symbols/instdir/program/libcairocanvaslo.so
soffice.b 10224  jmg  mem       REG              252,1    628992 2122995 /home/jmg/Development/libreoffice/symbols/instdir/program/libcanvasfactorylo.so
soffice.b 10224  jmg  mem       REG              252,1   5677720 2137791 /home/jmg/Development/libreoffice/symbols/instdir/program/libcppcanvaslo.so
soffice.b 10224  jmg  mem       REG              252,1   3470664 2126025 /home/jmg/Development/libreoffice/symbols/instdir/program/libcanvastoolslo.so
Comment 1 Jan-Marek Glogowski 2016-10-12 11:39:46 UTC
Created attachment 127964 [details]
Screenshot of the broken logo in in the Impress presentation console
Comment 2 Jan-Marek Glogowski 2016-10-12 11:47:52 UTC
My Linux distro is a KDE NEON 5.8.0 (user) based on Ubuntu 16.04.
Comment 3 Jan-Marek Glogowski 2016-10-12 15:54:59 UTC
Created attachment 127974 [details]
Correct preview screenshot of the presenter console of the first slide

Just realized the preview is also correct.
Comment 4 tommy27 2016-10-13 03:50:10 UTC
I confirm issue under Win8.1 x64 as well using older releases back to 4.0.4 (where the poor rendering was even worse)

it worked fine in 3.6.7 so it's a 4.0.x regression (did not have 4.0.0 to test but I suspect it was buggy too)

needs bibisecting
Comment 5 QA Administrators 2017-10-23 14:15:46 UTC Comment hidden (obsolete)
Comment 6 Buovjaga 2018-07-04 12:48:10 UTC
Still repro.

Version: 6.2.0.0.alpha0+
Build ID: e1a77d0affef507d597e7dceb5514073658332df
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-06-27_04:47:54
Locale: fi-FI (fi_FI); Calc: group threaded
Comment 7 Roman Kuznetsov 2019-03-29 19:02:58 UTC

*** This bug has been marked as a duplicate of bug 95438 ***