Bug 103203 - Full Screen Mode - Windows 10 Taskbar is allways on top - requires auto-hide workaround
Summary: Full Screen Mode - Windows 10 Taskbar is allways on top - requires auto-hide ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.2.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 110985 (view as bug list)
Depends on:
Blocks: Full-Screen-Mode Desktop-Integration
  Show dependency treegraph
 
Reported: 2016-10-13 21:11 UTC by tredock.valder
Modified: 2018-12-26 17:07 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tredock.valder 2016-10-13 21:11:29 UTC
If I enter the full screen mode in any product (Writer, Calc, Impress) the Windows Taskbar does not disappear and overlaps the content. 

This is most annoying when I try to use Writer on full screen mode, because the last row on the page is under the windows taskbar, so I don't see what I'm writing and constantly need to add blank lines.

This only happens in LibreOffice (all other software I have work well on full screen, so it isn't likely to be a Windows issue)

I have Windows 10 64bit, with the latest Anniversary Update installed and OpenOffice 5.2.2.2.
Comment 1 V Stuart Foote 2016-10-14 03:44:58 UTC
Confirming on Windows 10 Pro 64-bit (1607) en-US with
Version: 5.2.2.2 (x64)
Build ID: 8f96e87c890bf8fa77463cd4b640a2312823f3ad
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; 
Locale: en-US (en_US); Calc: group

or with current master

The full screen size calculated is the full screen--and the Windows taskbar when active overlays the bottom of LibreOffice in full screen mode.

However, it is fully functional with Windows task bar configured to auto hide with "Automatically hide the taskbar in desktop mode" set on.

Would be necessary for LO Windows builds to detect status of Taskbar mode as set either auto-hide or always show--and adjust the size of the "full screen". A lot of effort for a trivial issue, but it is valid issue.

Until a dev chooses to implement, setting Windows Taskbar to auto-hide when planning to use LibreOffice full screen mode is sufficient.
Comment 2 tredock.valder 2016-10-14 04:47:18 UTC
Thank you, but setting the Windows Taskbar to auto-hide is not the best solution, because when Windows hides the taskbar, it still leaves the top selected item line visible. 

So I will still get a line of 1-2px on the bottom (with a small indicator on it, where the selected button is). 

While, I agree, this fixes the last row problem in writer, it still does not deliver the distraction-free experience I was hoping for (and it used to deliver).
Comment 3 QA Administrators 2017-10-23 14:10:21 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2017-10-26 11:39:37 UTC
*** Bug 110985 has been marked as a duplicate of this bug. ***
Comment 5 QA Administrators 2018-10-27 02:56:13 UTC Comment hidden (obsolete)
Comment 6 Buovjaga 2018-12-26 17:07:35 UTC
(In reply to V Stuart Foote from comment #1)
> However, it is fully functional with Windows task bar configured to auto
> hide with "Automatically hide the taskbar in desktop mode" set on.

It is working fine for me even though this setting is "Off".

The description mentions Impress, but fullscreen mode for it is not yet implemented: bug 35008

Closing as WFM

Version: 6.3.0.0.alpha0+ (x64)
Build ID: ffa5b8a82eab18041bbee4d6914892b82c7801d3
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-12-19_03:24:54
Locale: fi-FI (fi_FI); UI-Language: en-US
Calc: threaded